Welcome! Log In Create A New Profile


Beginner troubles

Posted by Skypuppet 
Beginner troubles
December 08, 2011 01:49AM
Hi. I'm VERY new to this RepRap stuff. I'm also seriously lacking in code hacking or programming, so please bear with me. I am a product designer in the watersports industry and I work in SolidWorks primarily. I've designed products using SW since their early days (starting in 1998). So my CAD modeling experience is extensive, but computer language... lacking. Oh, and I run my SolidWorks in Windows Vista.

I know it can be annoying when new guys don't seem to search the forum before asking questions, but I couldn't find answers to my particular questions. Similar ones, yes, but not what I need.

I just received my assembled prusa today and was happy to start playing with it. It was listed as having RAMPS 1.3 electronics, but it seems like a lot of machines have 1.4. Not sure if there is a significant diffference.

It also came pre-flashed with sprinter and was listed as calibrated and working.

Now I have it all hooked up with power and USB, but I cant seem to "connect to printer". I DL'd the software/drivers for the Arduino Mega 2560 (windows).

Once I installed the Arduino software, the "new hardware detected" prompt went away and I saw a notification that the new device was connected to com-7. It was actually in a USB, but I suppose it see's that as com-7.

I also have Skeinforge and Printrun downloaded. In addition, I downloaded RepSnapper and played with it some. It seems to be simpler than Skeinforge.

On another note, I did see some people having trouble with Vista. Please let me know if there is an issue.

So in summary:

1) I use Windows Vista

2) I have a Prusa based printer

3) RAMPS 1.3 electronics

4) Flashed with Sprinter

5) Arduino software installed

6) Skeinforge or RepSnapper... Which one?

I really need some "dummy advice" on where to start. What to do first and in layperson terms, considering that I'm already lost just trying to "see" the device.

If there is somebody who would be willing to walk me through some of this, I would REALLY appreciate it. If I could return favors with some cad modeling, I'd be happy to do that as well.

I've already modded a full set of prusa parts with LM8UU holders. I have those parts in .sldprt format for easy modification.

Thanks in advance for help winking smiley

Re: Beginner troubles
December 08, 2011 09:51AM
Welcome to another SW user. I started using it just before 2000 was released. Ah, the bad old days... I have a fork of Prusa in SW in progress on GitHub, if you're interested.

MakerGear has a new getting started guide here. It will walk you though the steps between having the printer built to being ready to print something. Hopefully, following that, you wil lbe able to connect to the printer and move onto your next problem printing.

For on-the-fly help, discussion, and conversation, you can't beat IRC. #MakerGearV2 is a great channel for MakerGear customers, and maybe others as well. I've never been in #Reprap, but I expect the people there are about as helpful.

Your item 6 is a revealing question. RepSnapper and Skeingforge are for different things. Repsnapper is a host program that controls the printer and streams G code commands to it. Skeinforge generates G code for the printer from stl files. Repsnapper can do some of that too, but not at all well. I wouldn't recommend either right now. MakerGear's getting started guide uses Pronterface and SFACT. Pronterface is the host, and SFACT generates the G code. I very much recommend using those, as they seem to the current mainstream tools.

Hope that helps.
Re: Beginner troubles
December 08, 2011 06:13PM
Thanks a ton. This "quick start reference guide" already seems to have more detailed instructions which should help.

So it looks like Repsnapper is a sort of substitute for Pronterface? I've had a lot of trouble with Repsnapper and I'm done with it. I had it running in all respects except for extruding. It was really weird, the extruder stepper was humming, but would not turn most of the time. Then every so-often, it would spin freely. I took the hobbed bolt and large gear off to make sure there wasn't a bind and got the same result.

Then I decided to check my extruder stepper motor by plugging in to my X axis and jogging. It jogged the motor flawlwssly.

So with that, either Repsnapper really sucks, or my extruder output is wacky... VERY wacky considering the intermittent functionality.

I'm guessing it is the Repsnapper prog.

A shame since I've put a full day into configuring it, but just couldn't get it to extrude. Everything else worked; Heat to bed, to hot end, home all axis and jog all axis... no prob.

Time to move on and work with this SFACT/Pronterface. It looks a little cryptic tho... I'm a wee-bit scared D:

Thanks for your help. I'll let you know how I make out.
Re: Beginner troubles
December 08, 2011 11:07PM
Well I did as best I could according to those MakerGear instructions. First off I installed all the support files (Python,pyserial,pyreadline and wxpython) and then moved on to pronterface. After re-naming the unpacked kliment printrun file folder (Pronterface) and inserting it in the C root, I created the shortcut, and assigned its button to it. At this point they suggest doing a quick test to see if it's a success.

They don't tell you what the test results should be. I only saw the command prompt flash for a fraction of a second. Nothing else. I think that's wrong... right? Probably should have seen a gui with buttons and stuff. That's my guess.

But never having used this software before, I hope for the best and move on to SFACT. Maybe when it's all working together, the user interface will materialize.

It becomes even more vague when dealing with SFACT tho. They instruct to unzip to C;\Pronterface\Skeinforge as if this folder exists. It doesn't. Then it refers to reprap wiki for further instructions.

So I did all this and came up with the same result that I was getting all along. No pronterface. I've seen SFACT correctly (I think) right from the start, but nothing with pronterface. Just a blink of command prompt.

The SFACT opens as "Skeinforge settings" and is loaded with buttons/controls and is accompanied by a python 26 command prompt page (forgive my terms).

So I'm guessing the SFACT stuff is good, but my pronterface is not.

This is what I've dealt with every time I've downloaded and installed this software. Not on just one computer either. I have two laptops that I'm trying to load. One with XP and one running Vista.

Conversely, RepSnapper loaded and ran my printer almost immediately with the exception of the extruder. I wish it had worked, because it has a pretty intuitive interface and I might be printing by now.Help meeeee!
Re: Beginner troubles
December 09, 2011 01:23AM
I can help pm your #
Re: Beginner troubles
December 09, 2011 09:56AM
Hmm. Repsnapper should have moved your Extruder just fine if it managed to connect to the printer at all. If I remember correctly, the extruder "jog" speed controls need to be turned way down, since they are old enough to be assuming mm of extrudate instead of filament. I think I used to run it at 150mm/min for 1.75mm filament. If yo have 3mm filament, it will need ot be slower to avoid jams. My guess is that Repsnapper was trying to run the extruder stepper so fast that it never made the first step. I used to do this by accident once in a while.

Sorry I can't offer any help on the Pronterface install. It sorta just worked for me. You definitely should have got the application, not just the brief blip of a command shell. Hopefully DanielG can get you going.
Re: Beginner troubles
December 09, 2011 12:29PM
Hi Dale. Thanks for confirming some of my thoughts. I just finished up with a format and fresh install of Vista and still get just a blip. I PM'd Daniel so I'm sure we'll get it figured out.

The repsnapper thing is really strange. I thought maybe my extruder stepper was faulty, but I connected it to my X axis and it turned when I jogged it. Yet it just hums on the extruder channel.

I had played with the feed settings in Repsnapper, but turned them up only. I don't recall if I adjusted speed, but I ran more length just to give me time to make some little videos for what was happening. I did that for the builder. I bought this machine on ebay and wanted to cover my rear in case it was a faulty build.

Now I don't even have Repsnapper installed, so I can't see what settings I tried, haha! Figures. I may install it just to see, but I keep hearing that Pronterface/Sfact is what I will ultimately want to use.

On a side note, I was thinking of installing Ubuntu and going that route (if all else fails). Any thoughts on that?

Thanks again to all of you for the help.

Edit: I just found a similar repsnapper post that confirms the slower speed setting for the extruder. I'll re-install repsnapper and play with it again. I'm still interested in getting the pronterface working though.

2nd Edit Bingo!! Repsnapper is extruding at a 1600 speed setting. Now I can play some more. I don't know if that is acceptable for ABS, but at least I know my machine is good. I'll still pursue the Pronterface tho. You guys are great smiling smiley

Edited 2 time(s). Last edit at 12/09/2011 12:53PM by Skypuppet.
Re: Beginner troubles
December 09, 2011 01:47PM
Great news! I hope you can get Pronterface working, as it really is better.

These numbers are starting to come back to me. 1600 sounds high enough that the E_steps_per_mm setting in configuration.h is set up for Skeinforge 39, not 40+ or SFACT. I don't know if you've calibrated this or not, but you want to adjust this setting so that when you command Repsnapper or Pronterface to extrude 100mm, it pulls exactly 100mm of filament through the extruder.
Re: Beginner troubles
December 09, 2011 02:51PM
No I haven't. I did notice that my heat seems to be reversed in that the bed seems to be heating more than the hot end.

I should tell you that yesterday I had made some Sprinter mods that I shouldn't have. I did what was described in the Makergear getting started guide and loaded "sprinter.h" or something like that. Instantly my printer acted real strange and I thought I'd really screwed something up. It seemed like the heat channel was sending to the Z stepper and the X output was sending to the extruder stepper.

I kept seeing something in there about ramps 1.2 and figured out that it had flashed my board for the wrong version. In configuration.h for motherboards, there was a single "3" where I needed a "33" for my ramps 1.3.

Lucky for me the notes are in there in the uncommented sections. That is very helpful to a guy that never goes into a command line.Heck, that's one of my reasons for using SW instead of AutoCAD... command lines, ugh!

Anyways, now I'm wondering if there is something that got messed up in the heating settings. I'm still a little gunshy when it comes to editing those settings, but I will have to get over that because that seems to be acting differently from yesterday.

Prior to loading that sprinter.h stuff, my heating seemed pretty spot on. The Repsnapper settings were:

Nozzle current ~200 Target = 200
Bed Current~ 60-70 Target = 200

The targets were left at the default settings, but the nozzle was heating up very close to the target, where the bed was not.

That made some sense to me since I think the bed shouldn't need to be so hot. Now though, after the firmware changes, I'm seeing the reverse. It seems like the bed is heating closer to the target and the nozzle is nowhere near the target temp.

I'll look at the settings again and see if there is something in uncommented remarks that explains this, but if you have any advice, it will surely be welcomed.

Still trying to figure out Pronterface as well, but it's on the back-burner so-to-speak.
Re: Beginner troubles
December 09, 2011 05:27PM
Well, well, well... I got Pronterface working!! Just in case anybody else has the same problem, I wound up using the "ready to run" version from:


This link is on the wiki site, but since everything I had read said to run everything in order starting with python and ending with the kliment-printrun available at github, and the koti.kapsi ver. is listed as experimental, well, I just skipped over it.

Anyways, its up and running and I'm as happy as a pig in a big stinky hot tub. I hope my experience can be beneficial to others.

Once again, thank you for the help and support. Sometimes in order to find your way, you just need to be told that your on the wrong path.
Re: Beginner troubles
December 09, 2011 05:57PM
More progress! at this rate you're going to end up knowing what you're doing.

I don't remember having to use a special Sprinter.h when I set it up. I'm not saying it's wrong, I just don't remember it. I wonder what MakerGear put in there. Anyhow, give some attention to your thermistor tables before you heat up the nozzle much. If you have the wrong table for your thermistor type, you can accidentally overheat the extruder's hot end and do some damage (depending on the materials in your hot end).

I need to follow that link of yours myself, as my copy of Pronterface is rather dated.
Re: Beginner troubles
April 16, 2012 04:07AM
Hey Skypuppet,

I too have been playing around with computers since the early days. My first computer was a Dick Smith VZ300.

How did u go with your repsnapper install?
I just wasted over 1 hour trying to get a straight answer on repsnapper.IRC.
I couldn't believe the amount of running around I was put through.

I have pronterface, replicatorg and sli3er installed and running but can't seem to get repsnapper to run.

Any help to get this program running would be very welcome.

Thanks in advance.

Sorry, only registered users may post in this forum.

Click here to login