Welcome! Log In Create A New Profile

Advanced

RAMPS 1.4 with TMC2130's giving Overheating error on startup.

Posted by Nicoolai 
RAMPS 1.4 with TMC2130's giving Overheating error on startup.
March 25, 2018 04:04AM
Hi guys,
I'm having somewhat of an issue here.
I just recently replaced my printer board with a ramps 1.4 board so I could utilize the TMC2130 drivers.
So I also got 4 of those, and have wired them according to this guide: [toms3d.org]

I've got Marlin 1.1.8 on it, and did all the changes I believe necessary, to utilize the TMC2130's.

Unfortunately, when I power the printer on, I get the following message:
READ: 00:00: Y driver overtemperature warning! (800mA)

And it then goes into a loop of turning down the current.
READ: Y current decreased to 750
READ: Y current decreased to 700
READ: Y current decreased to 650
READ: Y current decreased to 600

untill I kill it (even goes into negatives..).
It is definitely not overheating. It is immediately after boot and cooler is not warm at all.

I've googled around a bit, and saw some people had success with changing the Y_CS_PIN to 4. I've tried that, but it didn't really help. In fact, after doing that, I now also get the warning for the e0 driver.

So, my big question here is, is there any way I can proper debug this issue?
I'm guessing it could be me who did something wrong or the drivers that are damaged. Can I determine this somehow, without ordering new drivers?
Re: RAMPS 1.4 with TMC2130's giving Overheating error on startup.
March 25, 2018 05:43AM
From [github.com]

most probably you have a wiring issue

Set TMC_DEBUG enabled in Configuration_adv.h recompile and upload.

Send M122 S1 to the machine

any Driver registers that come up FF FF FF FF are not talking correctly

see [marlinfw.org] for more info and eg output

NB Providing photos of how you have it wired and config files will help us a lot....

The default CS pins are as follows for a standard ramps.

#define X_CS_PIN 53
#define Y_CS_PIN 49
#define Z_CS_PIN 40
#define E0_CS_PIN 42
#define E1_CS_PIN 44

You cant use 53,49 if you have a LCD plugged in or even enabled as it conflicts with lcd and SD card

Edited 2 time(s). Last edit at 03/25/2018 06:07AM by Dust.
Re: RAMPS 1.4 with TMC2130's giving Overheating error on startup.
March 25, 2018 07:14AM
Ok, I set debug and used M122 S1.
It returned the following:
READ: X:0 |0b1000| 	Y:255 |0b1111| E	Z:1 |0b1000| 	E:255 |0b1111| E	
READ: X:0 |0b1000| 	Y:255 |0b1111| E	Z:1 |0b1000| 	E:255 |0b1111| E	
SENT: M105
READ: ok T:22.00 /0.00 B:22.00 /0.00 @:0 [email protected]:0
READ: X:0 |0b1000| 	Y:255 |0b1111| E	Z:1 |0b1000| 	E:255 |0b1111| E	
READ: X:0 |0b1000| 	Y:255 |0b1111| E	Z:1 |0b1000| 	E:255 |0b1111| E
Over and over.

Tried M122 without enabling the continious reporting:
READ: Enabled		false	false	false	false
READ: Set current	800	800	800	800
READ: RMS current	795	795	795	795
READ: MAX current	1121	1121	1121	1121
READ: Run current	25/31	25/31	25/31	25/31
READ: Hold current	12/31	12/31	12/31	12/31
READ: CS actual		12/31	31/31	12/31	31/31
READ: PWM scale	0	255	0	255
READ: vsense		1=.18	1=.18	1=.18	1=.18
READ: stealthChop	true	true	true	true
READ: msteps		16	0	16	0
READ: tstep		1048575	4294967295	1048575	4294967295
READ: pwm
READ: threshold		0	0	0	0
READ: [mm/s]		-	-	-	-
READ: OT prewarn	false	true	false	true
READ: OT prewarn has
READ: been triggered	false	true	false	true
READ: off time		5	15	5	15
READ: blank time	24	54	24	54
READ: hysterisis
READ: -end		2	12	2	12
READ: -start		3	8	3	8
READ: Stallguard thrs	8	8	0	0
READ: DRVSTATUS	X	Y	Z	E0
READ: stallguard			X		X
READ: sg_result		0	1023	0	1023
READ: fsactive			X		X
READ: stst		X	X	X	X
READ: olb			X		X
READ: ola			X		X
READ: s2gb			X		X
READ: s2ga			X		X
READ: otpw			X		X
READ: ot			X		X
READ: Driver registers:
READ: 	X = 0x80:0C:00:00
READ: 	Y = 0xFF:FF:FF:FF
READ: 	Z = 0x80:0C:00:00
READ: 	E0 = 0xFF:FF:FF:FF
READ: 
READ: ok

Does that mean anything to any of you?
I don't have any LCD or SD. I am using the default pins, except I changed Y_CS_PIN to 4, as an attempt to fix based on something I read on github.

What files would you like me to upload? My whole configuration and configuration_adv?

I'm guessing this:
READ: 	X = 0x80:0C:00:00
READ: 	Y = 0xFF:FF:FF:FF
READ: 	Z = 0x80:0C:00:00
READ: 	E0 = 0xFF:FF:FF:FF

Makes it seem like Y and E0 aren't communicating correctly, right?
So the CS pin is not connected correctly or there are some issues?

Edited 1 time(s). Last edit at 03/25/2018 07:16AM by Nicoolai.
Re: RAMPS 1.4 with TMC2130's giving Overheating error on startup.
March 25, 2018 08:46AM
READ: PWM scale	0	255	0	255
...
READ: msteps		16	0	16	0
...
READ: OT prewarn	false	true	false	true

There are a few odd readings, but IDK if it's the cause or the result of the steppers miscommunication.
Re: RAMPS 1.4 with TMC2130's giving Overheating error on startup.
March 25, 2018 10:36AM
Ok, so I made new wires for Y and E0. It fixed E0. Y is still acting up.
I will try to switch some drivers around, see if it follows.
Re: RAMPS 1.4 with TMC2130's giving Overheating error on startup.
March 30, 2018 05:59PM
Hello,
I'm building a Prusa i3 MK3 out of parts at the moment and currently waiting for the electronic components to be shipped.
So I'm already reading posts regarding the combination of RAMPS and TMC2130....
Is there any new info yet?
Keep us updated! ;-)
Dave
Sorry, only registered users may post in this forum.

Click here to login