Welcome! Log In Create A New Profile


Z Motors Not Strong Enough?

Posted by ZackRP 
Z Motors Not Strong Enough?
May 10, 2018 08:43PM
Hey everyone, I have a Monoprice Maker Select V2. I just installed a Ramps 1.4 board with an Arduino Mega 2560 and flashed the most updated version of marlin. Originally I was having some Y axis issues so I got another ramps. Now, when I turn it on it homes all axis' fine, moves the Z up and then down to min endstop no problem. But then once I use the scroll wheel on the LCD or Prontedface to issue a command to move the Z axis up, it doesn't do anything. Sometimes it does nothing, sometimes the motors hum or click slightly, but it doesn't ever move when I do this. When I unplug one motor or the other from the ramps board, and try with just one connected, the other works without issue. But when they're both plugged in they don't rise. The firmware thinks they're going up, because when I go back down with the scroll wheel the motors try, and grind because it's already at the min endstop, but it tries like it thinks it's up higher than it is. I tried replacing the stepper driver and that changed nothing, and I enabled Dual Z axis steppers in the firmware, and connected one motor to the E1 port, and the other to the Z motor port, but that also didn't change anything. I've also tried plugging them in both in series to just the E1 port, or the Z motor port, and plugging them in parallel straight into the two Z motor ports on the board, but no combination of these things has helped. When I issue a command to bring the Z axis up, sometimes if I hold a finger under it and support the axis it rises fine. I don't even have to apply pressure really, I just have to take the most insurmountable amount of weight off of it, which leads me to believe the motors just aren't providing the "oomph" during the print, or by manually issuing a move command, which is strange because they move up and down perfectly fine during the homing process. Is there a separate menu in firmware or something to control the power to the Z motors differently for both homing and other movement, or am I missing something else entirely? Thanks for any advice!
Re: Z Motors Not Strong Enough?
May 11, 2018 03:06AM
The default max. Z-feedrate is often too much for the leadscrews. I had to reduce mine from 5mm/s to 2mm/s. ( M5 leadscrews )
Homing works fine, because in Firmware homing speed is lower. In pronterface you can type M203 and see how the firmware is set. Then send M203 Zxx, followed by M500 ( store data in eeprom ) to change that setting and store it permanently.

Another thing you chould check is the drivers Vref adjustment ( current adjustment regulates the oomph winking smiley )
Sorry, only registered users may post in this forum.

Click here to login