Geeetech Prusa I3 Pro
01. January 2017 02:06
Hallo und guten Morgen

Habe zu Weihnachten diesen 3 D Drucker bekommen , alles zusammengebaut und einiges funktioniert auch schon .

Nur leider bekomme ich ihn nicht zum laufen .. WER MIR HELFEN KÖNNTE WÄRE SUPER !! Bitte melden , freue mich über jede Hilfe.

Schreibt mir wann Ihr im Forum zu erreichen seid , dann klappt es besser mit der Konversation .

Bis später dann und vorab schon mal DANKE ...
Re: Geeetech Prusa I3 Pro
01. January 2017 04:54
Vielleicht wäre es besser wenn Du erst mal erläuterst was an dem Drucker nicht funktioniert. Mach mal ein paar Fotos von dem Drucker und erkläre ganz genau welche Funktionen funktionieren und welche nicht. Ansonsten ist das ein riesiges hin und her gerate und es hilft auch nicht wenn wir dann sagen wann wir online sind. Also erst mal erklären was nicht funktioniert dann sehen wir weiter.


Gruß
Stefan
Re: Geeetech Prusa I3 Pro
01. January 2017 05:24
Danke für Antwort , ok mache ich und melde mich ....
Re: Geeetech Prusa I3 Pro
01. January 2017 06:02
Also mein erster Fehler ist das die z Achse sich falsch rum dreht, der Extruder nicht bei seinem eingesteckten Pin läuft aber bei einem anderen Pin läuft er und mein Programm Reptier-Host geht auch nicht mehr (siehe Bild). Bei dem Programm Merlin Firmware kommt nur eine Fehlermeldung (siehe Bild). Wenn ihr mir dabei helfen könntet wäre echt nett.
Das Bild von meinem 3d Drucker hat nicht rein gepasst ich schicke es in der nächsten Nachricht.

Bis später
Anhänge:
Öffnen | Download - Merlin.png (110.6 KB)
Öffnen | Download - reptier problem.png (186.6 KB)
Re: Geeetech Prusa I3 Pro
01. January 2017 06:16
Der 3D Drucker smiling smiley
Anhänge:
Öffnen | Download - Bild1.jpg (240.5 KB)
Öffnen | Download - Bild2.jpg (562.4 KB)
Öffnen | Download - Bild3.jpg (558.7 KB)
Re: Geeetech Prusa I3 Pro
01. January 2017 07:34
Du hast die Original Firmware von Geeetech (Marlin-PI3_Pro_B.zip) drauf oder? Die müsste eigentlich sofort funktionieren. Ich musste bei meinem I3X am Anfang nichts einstellen und es lief. Erst dann hab ich mit dem Feintuning begonnen.
Aber fangen wir ganz von vorne an.

Ob die nun warm werden oder nicht auf die Stepper gehören die mini Kühlkörper die bei der Lieferung dabei waren.

Als erstes schau mal im Display deines Druckers nach was für eine Baudrate eingestellt ist. Die Original Firmware steht auf 250000 Baud. Wenn du die Standard 115200 einstellst, kann das nicht funktionieren.
Wenn das geklärt ist, kannst du die Stepper in der configutration.h invertieren oder du klemmst die beiden Pole am Stecker der beiden Z-Achsen Stepper um. Invertieren geht schneller.

#define INVERT_X_DIR true // for Mendel set to false, for Orca set to true
#define INVERT_Y_DIR true // for Mendel set to true, for Orca set to false
#define INVERT_Z_DIR false // for Mendel set to false, for Orca set to true
#define INVERT_E0_DIR true // for direct drive extruder v9 set to true, for geared extruder set to false
#define INVERT_E1_DIR false // for direct drive extruder v9 set to true, for geared extruder set to false
#define INVERT_E2_DIR false // for direct drive extruder v9 set to true, for geared extruder set to false

In diesem Passus wird die Richtung gedreht. Also einfach den Wert von false zu true und umgekehrt.
Das gleiche gilt für die Endstops wobei es bei den Geeetech Teilen einfacher ist die Polung am Schalter zu drehen.

Was den Extruder angeht, so sind auf dem GT2560 Steckplätze für 2 Extruder. Momentan hast du den Motor bei Extruder 2 eingesteckt. Ist eigentlich egal muss halt nur beim drucken im Repetier entsprechend ausgewählt werden. Und natürlich muss der A4988 Stepper Driver auf dem richtigen Steckplatz sitzen. So wie ich auf dem Bild sehen kann steckt der Treiber jedoch auf dem Steckplatz für Extruder 1. So wird das nix. smoking smiley

Noch vergessen. Du musst natürlich wenn du den Extr. 2 Steckplatz verwendest auch die Heizung an Extr. 2 anschließen, sowie den Sensor. grinning smiley




Probier erstmal aus, ob du soweit kommst das alles läuft. Dann sehen wir weiter.

1-mal bearbeitet. Zuletzt am 01.01.17 07:36.


Gruß
Stefan
Re: Geeetech Prusa I3 Pro
01. January 2017 07:43
Hi ist mir gerade noch wie Schuppen von die Augen gefallen.

Deine Endstops sind falsch gesteckt. Du hast Sie einfach der Reihe nach reingesteckt.
Wenn ich mich richtig erinnere müssten Die aber alle bei

X-MIN
Y-MIN
Z-MIN

gesteckt sein

nicht X-MIN, X-MAX und Y-MIN wie jetzt.


Gruß
Stefan
Re: Geeetech Prusa I3 Pro
01. January 2017 08:32
Danke das du für mich Zeit nimmst,
Ich hab alles gemacht was du gesagt hast, habe deine Datei übernommen und z Achse auf true gestellt aber wenn ich auf datei pfüfen komme kommt folgendes (siehe Datei text) und ich als Anfänger tongue sticking out smiley hab keine ahnung was das bedeutet bzw. was ich machen soll.

Gruß Max

2-mal bearbeitet. Zuletzt am 01.01.17 08:39.
Anhänge:
Öffnen | Download - Fehlermeldung.txt (24.2 KB)
Re: Geeetech Prusa I3 Pro
01. January 2017 09:50
Du hast aber nicht gleichzeitig den Repetier Host laufen oder? Denn dann kannst du das mit dem Programmieren vergessen


Gruß
Stefan
Re: Geeetech Prusa I3 Pro
01. January 2017 09:56
Ne ich hab nur das Merlin Programm offen.
Re: Geeetech Prusa I3 Pro
01. January 2017 10:40
per suchen und ersetzen das "fpos_t" in "fpos" ändern. Du nutzt eine neuere Lib für die SD-Karte die fpos_t intern verwendet deswegen die fehlermeldungen. bitte in Allen TABS ändern
Re: Geeetech Prusa I3 Pro
01. January 2017 11:05
Ok Danke hab ich gemacht und jetzt kommt noch mal eine Fehlermeldung.
Anhänge:
Öffnen | Download - Fehlermeldung.txt (21.8 KB)
Re: Geeetech Prusa I3 Pro
01. January 2017 14:14
schau dir die fehlermeldung mal genau an winking smiley

einen haste vergessen *gg*
Re: Geeetech Prusa I3 Pro
02. January 2017 06:02
Guten Morgen,
Ich hab jetzt die meisten fpos geändert, aber was bedeutet eigentlich das: [ exit status 1
prototype for 'void SdBaseFile::getpos(fpos*)' does not match any in class 'SdBaseFile' ] da hab ich keine Ahnung was ich verändern soll.
Weist du zufällig was man da machen soll ? smiling smiley

Gruß Max
Re: Geeetech Prusa I3 Pro
02. January 2017 06:08
Können wir uns eventuell über skype oder teamspeak 3 unterhalten ?? mit dem Posting dauert es ein bisshen länger.

LG Max
Re: Geeetech Prusa I3 Pro
02. January 2017 14:27
ich häng dir mal meine Marlin Firmware hier an, ist die letzte RCBugFix. Da ist das fpos_t Problem behoben Du musst nur noch die Config.h an deinen Drucker anpassen,da ich den Geeetech Prusa I3 Pro X mit Autobedleveling per Kapazitivem Sensor verwende.
Anhänge:
Öffnen | Download - Geetech.7z (357.5 KB)
Re: Geeetech Prusa I3 Pro
03. January 2017 02:34
Also bezüglich des Extruder, dieser läuft aus Sicherheitsgründen nur, wenn deine Druckdüse auf Temperatur ist. heize mal auf 190 Grad hoch und er sollte dann auch laufen. Falls das Problem noch besteht.
Re: Geeetech Prusa I3 Pro
03. January 2017 07:30
Danke das ist echt nett und ich werde Config_h an meinem Drucker anpassen und probiere es nochmal.
Wie kann ich denn bei Merlin die baud rate ändern oder wird das automatisch eingefügt ?
Re: Geeetech Prusa I3 Pro
03. January 2017 07:35
Weil das komische an der ganzen sache ist das ich immer ein timeout habe. confused smiley
Re: Geeetech Prusa I3 Pro
03. January 2017 07:52
...Marlin

Öffne mal die Config und such nach Baudrate.


Gruß aus dem Tal Kochertal,
Tobias
E-Mail gibts hier

[www.thingiverse.com]

Maschinen
P3sTE MK2 [scheuten.me]
AM8 sobo Version
MPCNC 1,5 KW WaKü
Ender 3 PRO

Re: Geeetech Prusa I3 Pro
03. January 2017 09:22
ich hab es dort geändert aber es hat sich nichts verändert, es blieb bei 115200.
Re: Geeetech Prusa I3 Pro
03. January 2017 16:20
Mal ne bescheidene Frage. wie programmierst du?
Variante 1 : Der Drucker ist aus und das GT2560 wird nur über USB mit Strom versorgt.
Variante 2: Der Drucker ist angeschaltet

Und mach mal bitte in der Arduino Soft unter: Datei - Voreinstellungen einen Haken in
Ausführliche Ausgabe während des Hochladens

Dann schreib mal was er dir beim Upload meldet.


Gruß
Stefan
Re: Geeetech Prusa I3 Pro
04. January 2017 06:37
Guten Morgen,
Also bei Variante1 zeigt er (Fehlermeldung1) und
bei Variante2 zeigt er (Fehlermeldung2).
Ich benutze normal immer Variante1.
Wie man auch sehen kann bleibt er immer auf Baud Rate 115200 obwohl ich die Baud Rate umgestellt habe bei config.h


Gruß Max
Anhänge:
Öffnen | Download - Fehlermeldung1.txt (66 KB)
Öffnen | Download - Fehlermeldung2.txt (66.3 KB)
Re: Geeetech Prusa I3 Pro
04. January 2017 09:59
Moin Max,
hast du in der configuration.h den Com-Port geändert?
Der sollte auf 0 bleiben.
/**
 * Select which serial port on the board will be used for communication with the host.
 * This allows the connection of wireless adapters (for instance) to non-default port pins.
 * Serial port 0 is always used by the Arduino bootloader regardless of this setting.
 *
 * :[0, 1, 2, 3, 4, 5, 6, 7]
 */
#define SERIAL_PORT 0
Im Windows Gerätemanager hast du die Baudrate auch angepasst?


Gruß
Siggi


Gruß
Siggi


Geeetech I3 Pro B 8mm Acryl - Mega 2560 - Ramps 1.4 - TMC2100 - MK42 - E3DV6-Clone 0,4 - SSR 522-1dd60-40 (A-Senco) - Marlin RC8Bugfix 26.12.2016 - Repetier Host - Windows 7 64 Bit
Vulcanus mit Linearschienen
Anycubic i3 Mega

Re: Geeetech Prusa I3 Pro
04. January 2017 14:41
Also ich hab da ganz normal drin stehen 9600 Bits. Dort hab ich noch nie auf die Baudrate des Arduino was geändert drinking smiley


Gruß
Stefan
Re: Geeetech Prusa I3 Pro
05. January 2017 02:59
Ich hab wirklich keine Ahnung mehr, ich hab jetzt alles probiert und nichts hat geholfen weil andauernd ein timeout kommt und wenn man das eventuell bei Arduino ändern könnte würde ich echt gerne wissen wie, das wäre vielleicht noch die letzte Chance das Teil zum laufen zu bringen.

Gruß Max
Re: Geeetech Prusa I3 Pro
05. January 2017 04:21
Die Arduino IDE nutzt meines Wissens die im Gerätemanager eingestellte Baudrate.
In der Firmware sind Port 0 und die richtige Baudrate eingestellt?

1-mal bearbeitet. Zuletzt am 05.01.17 04:23.


Gruß
Siggi


Geeetech I3 Pro B 8mm Acryl - Mega 2560 - Ramps 1.4 - TMC2100 - MK42 - E3DV6-Clone 0,4 - SSR 522-1dd60-40 (A-Senco) - Marlin RC8Bugfix 26.12.2016 - Repetier Host - Windows 7 64 Bit
Vulcanus mit Linearschienen
Anycubic i3 Mega
Re: Geeetech Prusa I3 Pro
05. January 2017 08:13
Also denn Port bei der Config.h steht auf 0 und die Baudrate steht auf 115200 und in Geräte Manager auch auf 115200 aber es kommt trotzdem immer timeout confused smiley
Re: Geeetech Prusa I3 Pro
05. January 2017 15:43
Ist in der geflashten firmware von deiner Steuerplatine ebenfalls 115200 als baudrate drin?
Geetech wirft gerne mal mit 250000 als baudrate um sich.


Ehemalige Drucker: Prusa i3 Hephestos, Prusa i3 rework, Geetech i3 China-Acrylat
Drucker im Besitz: Toolson i3 mk2,
Drucker im umbau: Creality CR-10, Flashforge Finder red
Drucker im bau:
Drucker in Planung: Subject Delta, Prusa i3 Lantia GTI, Trumpf truplast 5300
Re: Geeetech Prusa I3 Pro
05. January 2017 22:53
Moin Max,
oder ist bei dir Repetier-Server oder ähnliches installiert?
Wenn ja, dann musst du den stoppen, weil der den COM-Port blockiert.

Gruß
Siggi


Gruß
Siggi


Geeetech I3 Pro B 8mm Acryl - Mega 2560 - Ramps 1.4 - TMC2100 - MK42 - E3DV6-Clone 0,4 - SSR 522-1dd60-40 (A-Senco) - Marlin RC8Bugfix 26.12.2016 - Repetier Host - Windows 7 64 Bit
Vulcanus mit Linearschienen
Anycubic i3 Mega
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen