Willkommen! Anmelden Ein neues Profil erzeugen

Erweiterte Suche

Hall-Endstops (Endstop-H 3,3-5V) einbauen ?

geschrieben von Schlingel 
Hall-Endstops (Endstop-H 3,3-5V) einbauen ?
15. November 2015 00:43
Hallo zusammen,

ich wollte gestern mal die schon vor einem Jahr gekauften Endstops probieren. Ich habe einen ES an z-min ( bei mir ist das Oben) mit einen 3-adrigen Kabel mit dem Radds 1.1 verbunden.
In Repetier wurde Elekronisch NO (auch NC probiert) eingestellt. Die Diode am Endstop leuchtet immer. M119 wirft L oder H aus. Je nach Einstellung.

egal wie ich den Magneten drehe oder von welcher Seite ich mich nähere, die Diode leuchtet immer.

Wer kann mich mal erleuchten? confused smiley

Danke !!
Re: Hall-Endstops (Endstop-H 3,3-5V) einbauen ?
17. November 2015 05:22
schon mal an dem Poti gedreht?


Der 3D-Druck ist tot, lang lebe der 3D-Druck!

Schreibt mich nicht mehr an, ich hab das drucken an den Nagel gehängt.
Re: Hall-Endstops (Endstop-H 3,3-5V) einbauen ?
17. November 2015 08:25
Wenn er je nach Einstellung L oder H bekommt, kann es ja am Poti nicht liegen. Vielleicht wurde die LED falsch eingelötet.


Einen Sparkcube 1.1XL für größere Objekte, einen Trinus3D im Gehäuse und einen Tantillus R im Bau und einen Qidi Tech Q1 Pro im Zulauf.
Sparkcube: Komplett auf 24V - DDP 8mm + 1,5mm Carbonplatte - Octopus max EZ - EZ2209 - Nema 17/1,7A 0,9 Grad - BL Touch - Filamentsensor - Titan Booster Hotend - Sparklab Extruder - Klipper/Mainsail - HDMI 7 V1.2 Touchscreen - Simplify3D
Re: Hall-Endstops (Endstop-H 3,3-5V) einbauen ?
17. November 2015 09:31
Hi,

Wenn ich am Poti drehe ( 4 Umdrehungen in jede Richtung) passiert nichts. Die Diode leuchtet ständig.
Eingestellt: Elektronik NC -> M119 bringt High

Die Teile habe ich:



Im Netz findet sich gar nichts. Kostet mich jetzt schon wieder 2 Stundenangry smiley
Ist Elektronik NC richtig? Was kann noch falsch sein?

grüße
Re: Hall-Endstops (Endstop-H 3,3-5V) einbauen ?
17. November 2015 09:47
Quote
Boui3D
Wenn er je nach Einstellung L oder H bekommt, kann es ja am Poti nicht liegen. Vielleicht wurde die LED falsch eingelötet.

Er schreibt ja "je nach einstellung" (In der Firmware NC bzw. NO). Also die Diode sollte passen.
M119 sollte zunächst mal 'L' anzeigen, wenn kein Magnet in der Nähe ist.
Wenn das so richtig ist, sollte der Endstop NC sein, da der NO nicht gebrückt ist.
Jetzt ist die Frage, wie du den Endstop genau am RADDS angeschlossen hast?


Triffid Hunter's Calibration Guide --> X <-- Drill for new Monitor Most important Gcode.
Re: Hall-Endstops (Endstop-H 3,3-5V) einbauen ?
17. November 2015 10:31
So ist das Teil angeschlossen:


Re: Hall-Endstops (Endstop-H 3,3-5V) einbauen ?
17. November 2015 10:38
Quote

M119 wirft L oder H aus. Je nach Einstellung.

egal wie ich den Magneten drehe oder von welcher Seite ich mich nähere, die Diode leuchtet immer.

Dann habe ich das falsch interpretiert. Für mich las sich das so, als ob das Signal auf den Magneten regiert, nur die LED ständig leuchtet.

Was haste denn bei Pullup für den Pin eingestellt? winking smiley

1-mal bearbeitet. Zuletzt am 17.11.15 10:39.


Einen Sparkcube 1.1XL für größere Objekte, einen Trinus3D im Gehäuse und einen Tantillus R im Bau und einen Qidi Tech Q1 Pro im Zulauf.
Sparkcube: Komplett auf 24V - DDP 8mm + 1,5mm Carbonplatte - Octopus max EZ - EZ2209 - Nema 17/1,7A 0,9 Grad - BL Touch - Filamentsensor - Titan Booster Hotend - Sparklab Extruder - Klipper/Mainsail - HDMI 7 V1.2 Touchscreen - Simplify3D
Re: Hall-Endstops (Endstop-H 3,3-5V) einbauen ?
17. November 2015 10:48
Hab "false" eingestellt. Dachte der Pullup wäre auf dem Platinchen.
Muss der "true"?

// ################ Endstop configuration #####################

#define ENDSTOP_PULLUP_X_MIN true
#define ENDSTOP_X_MIN_INVERTING false
#define MIN_HARDWARE_ENDSTOP_X true
#define ENDSTOP_PULLUP_Y_MIN true
#define ENDSTOP_Y_MIN_INVERTING false
#define MIN_HARDWARE_ENDSTOP_Y true
#define ENDSTOP_PULLUP_Z_MIN false
#define ENDSTOP_Z_MIN_INVERTING true
#define MIN_HARDWARE_ENDSTOP_Z true
#define ENDSTOP_PULLUP_X_MAX true
#define ENDSTOP_X_MAX_INVERTING false
#define MAX_HARDWARE_ENDSTOP_X false
#define ENDSTOP_PULLUP_Y_MAX true
#define ENDSTOP_Y_MAX_INVERTING false
#define MAX_HARDWARE_ENDSTOP_Y false
#define ENDSTOP_PULLUP_Z_MAX true
#define ENDSTOP_Z_MAX_INVERTING false
#define MAX_HARDWARE_ENDSTOP_Z false
#define max_software_endstop_r true

#define min_software_endstop_x false
#define min_software_endstop_y false
#define min_software_endstop_z false
#define max_software_endstop_x true
#define max_software_endstop_y true
#define max_software_endstop_z true
#define ENDSTOP_X_BACK_MOVE 5
#define ENDSTOP_Y_BACK_MOVE 5
#define ENDSTOP_Z_BACK_MOVE 2
#define ENDSTOP_X_RETEST_REDUCTION_FACTOR 3
#define ENDSTOP_Y_RETEST_REDUCTION_FACTOR 3
#define ENDSTOP_Z_RETEST_REDUCTION_FACTOR 3
#define ENDSTOP_X_BACK_ON_HOME 1
#define ENDSTOP_Y_BACK_ON_HOME 1
#define ENDSTOP_Z_BACK_ON_HOME 0
#define ALWAYS_CHECK_ENDSTOPS 0

// ################# XYZ movements ###################
Re: Hall-Endstops (Endstop-H 3,3-5V) einbauen ?
17. November 2015 11:52
Wenn der Endstop heile ist, müsste es ja egal sein was und ob M119 was einzeigt. Die Diode sollte das ja angeben können.


Triffid Hunter's Calibration Guide --> X <-- Drill for new Monitor Most important Gcode.
Re: Hall-Endstops (Endstop-H 3,3-5V) einbauen ?
17. November 2015 13:39
Ich kenne die Schaltung nicht. Wenn das OC ist, dann benötigst Du den Pullup. Teste es einfach aus. Passiert ja nix.
Allerdings hat das keine Auswirkung auf die LED.

1-mal bearbeitet. Zuletzt am 17.11.15 14:21.


Einen Sparkcube 1.1XL für größere Objekte, einen Trinus3D im Gehäuse und einen Tantillus R im Bau und einen Qidi Tech Q1 Pro im Zulauf.
Sparkcube: Komplett auf 24V - DDP 8mm + 1,5mm Carbonplatte - Octopus max EZ - EZ2209 - Nema 17/1,7A 0,9 Grad - BL Touch - Filamentsensor - Titan Booster Hotend - Sparklab Extruder - Klipper/Mainsail - HDMI 7 V1.2 Touchscreen - Simplify3D
Re: Hall-Endstops (Endstop-H 3,3-5V) einbauen ?
20. November 2015 18:42
Schlingel, du bist nicht allein mit diesem Problem.

Habe die selben Endstops und es leuchtet nur die LED , egal wie der Magnet positioniert wird bzw. egal wie der Poti eingestellt wird. Bist du schon weiter gekommen?
Re: Hall-Endstops (Endstop-H 3,3-5V) einbauen ?
21. November 2015 01:46
Moin,

da das Poti noch nicht mal eine Umdrehung kann, hast du es wohl überdreht und der Schleifer hat keinen Kontakt mehr.

Sascha


Quote
Schlingel
Hi,

Wenn ich am Poti drehe ( 4 Umdrehungen in jede Richtung) passiert nichts. Die Diode leuchtet ständig.
Eingestellt: Elektronik NC -> M119 bringt High

Die Teile habe ich:

[attachment 66047 k-Hall-ES.jpg]

Im Netz findet sich gar nichts. Kostet mich jetzt schon wieder 2 Stundenangry smiley
Ist Elektronik NC richtig? Was kann noch falsch sein?

grüße


3Tripple 290x300x280mm, Raspi3+DUE+RADDS mit TMC2100, micron3dp Doppelextruder, Big Booster, Filaprint, Z-Riemenantrieb

www.wattwetter.de
Re: Hall-Endstops (Endstop-H 3,3-5V) einbauen ?
21. November 2015 02:38
Das Verhalten tritt auch mit den Werkseinstellungen auf und das Poti hat keinen Anschlag.

1-mal bearbeitet. Zuletzt am 21.11.15 04:44.
Re: Hall-Endstops (Endstop-H 3,3-5V) einbauen ?
21. November 2015 13:28
Fehlen da nicht 5V wo man holen muss für die Endstops ?? weil ja nur 3,3V da sind... irgendwas habe ich da noch im Hinterkopf
Re: Hall-Endstops (Endstop-H 3,3-5V) einbauen ?
21. November 2015 13:57
habe grad meine alte radds 1.1 vor mir liegen , man musste die 5V holen sonst gings nicht
Anhänge:
Öffnen | Download - Endstop3.3,5V.jpg (609.7 KB)
Re: Hall-Endstops (Endstop-H 3,3-5V) einbauen ?
21. November 2015 14:01
Hallo Mefiu, die hier beschriebenen ES sind das Zwischenmodel von den alten 5V ES und den aktuell angebotenen 3.3V ES. Sollten also an 3V laufen, ich werde es aber mal an 5V probieren.

Gruß

Edit: du warst schneller :-D ... also habe ich einfach das Label auf der Rückseite falsch interpretiert und es heißt nicht das die Dinger im Spannungsbereich von 3.3V-5V laufen?

Edit 2: Hab die ES gerade auf die 5V - Schiene geklemmt und es tut sich nichts außer das jetzt die LED aus bleibt und nicht auf den Magnet reagiert wird.

3-mal bearbeitet. Zuletzt am 21.11.15 14:37.
Re: Hall-Endstops (Endstop-H 3,3-5V) einbauen ?
21. November 2015 14:58
Die hier sind meine alten also die 1.Version von Angelo . Die liefen nur mit 5V !

Sind doch die gleichen wie deine, sehe keinen Unterschied anhand Schlingels Bild

2-mal bearbeitet. Zuletzt am 21.11.15 15:02.
Anhänge:
Öffnen | Download - Es.jpg (276.2 KB)
Re: Hall-Endstops (Endstop-H 3,3-5V) einbauen ?
21. November 2015 15:53
Stellt sich nur die Frage warum an 3.3 V die LED durchgehend leuchtet und an 5V durchgehend aus ist.

Ich wühle mich nochmal durch die ES - Einstellungen



Edit: Danke Mefiu für deine Hilfe und deine Informationen. Jetzt funktioniert der Endstop.

Fehler bei mir war zum ersten das der ES nur an 5V läuft und zweites war ein schlechtes Kabel für den ES. Jetzt verhält er sich wie folgt, wenn der ES auslöst geht die LED aus und wenn der ES sich dem Magnet entfernt wird die LED aktiviert.

So jetzt aber Boxen schauen , genug 3D Drucker für heute.

1-mal bearbeitet. Zuletzt am 21.11.15 16:55.
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen