Welcome! Log In Create A New Profile


[Solved] Printer not extruding properly at times

Posted by Depaulicious 
[Solved] Printer not extruding properly at times
November 28, 2016 09:10AM
I recently bought a Prusa i3 variant called Anet a8 (link to GearBest). It worked almost fine, but I didn't like its board, display, firmware and features in general, so I decided to replace it with a RAMPS 1.4 that I previously bought.
I adapted all the plugs, but I had issues tuning the stepper drivers: the motors have no labels, no model numbers at all, so I don't know their specs. I ended up tuning them manually, by checking the noise they made and made sure neither the motors or the drivers would get too hot. I set the x and y axes and the extruder to around 0.2V and the Z axis to 0.2/0.3. The axes seem to work just like before (I should probably find some measuring spots on the original board to get the manufacturer voltages; I guess I'll try at some point).
After some googling for the values to use for the steps/mm fields (100 for xy, 95 for extruder and 400 for z, in case anybody needs them - with these values the millimeters reported by the printer correspond almost exactly to the values I measured), I finally got it printing.
What I noticed, though, is that at times, especially when the extruder moves fast, the filament can't catch up with the speed. I tried increasing the voltage with no results. I finally managed to get an acceptable print by setting slic3r's extrusion factor to 1.1, increasing the flow rate to around 150% and reducing the feed rate to around 65%. However it's not perfect: at times, even at slow speeds, it prints almost nothing, and at other times it prints just perfectly. I was looking after it while it was working, to make sure the filament roll didn't get stuck, however at times it would start not to extrude a nice and thick filament, but just little lumps. Sometimes I eventually paused the print, raised Z and pushed the filament in until it extruded properly, other times it would print crappy then start working properly again on its own.
I don't know if it's the filament that's low quality, or if I just did something wrong setting everything up.

In this picture it just started printing the third layer, if I remember correctly, and you can see that in the previous layer there are sections that are just made out of little lumps.

In this picture you can see the first layer after it finished printing. You can see some sections where the extruded filament is particularly thin.

My guesses: either I have not tuned the motor correctly, so it doesn't have enough torque to push the wire into the hot end (by the way - I deeply cleaned the nozzle, just to make sure it wasn't the issue), or the wire is a bit slippery at times so the gear inside the extruder just slips on it without pushing it.
I don't really now how to troubleshoot either, do you guys have any ideas?

I haven't tried the other filament I have (bq brand) after switching boards as I didn't really have much time, I'll try it later today and update the post.

Thank you very much!

Edited 1 time(s). Last edit at 11/28/2016 12:05PM by Depaulicious.
Re: Printer not extruding properly at times
November 28, 2016 12:04PM
Okay, I should have tried the other filament before bothering you guys. It's obviously a filament issue as it's printing perfectly now.
I'll mark this as solved and open a more specific thread.
Thank you!
Sorry, only registered users may post in this forum.

Click here to login