Welcome! Log In Create A New Profile

Advanced

Slic3r 0.5.7

Posted by Sound 
Re: Slic3r 0.5.7
January 07, 2012 11:09AM
Lanthan Wrote:
-------------------------------------------------------
> Still, we'd benefit a lot for having a way to
> visually inspect the layers (apart of printing
> 'em) and might help by accelerating the debug
> cycle.

Most of people (including me) use Pronterface as a good G-code viewer.

Other options include Pleasant3D (for Mac), Repetier-Host, the Blender G-code plugin (which I updated to make it compatible with modern G-code; look for it in my Thingiverse page). I also heard of a new G-code previewer that was released recently, but I can't remember its name or where I read of it.
Re: Slic3r 0.5.7
January 07, 2012 01:04PM
Sound Wrote:
>
> Most of people (including me) use Pronterface as a
> good G-code viewer.

Unfortunately, not the same level of detail and readability (you can check gcode lines for the individual moves with Skeinview, color coded, etc.).





>
> Other options include Pleasant3D (for Mac),

very nice for general views, but short on detail.

Threr's also gcode2vtk, allows using paraview and mapping colors to different properties (build time, speed etc.)

> Repetier-Host,

windows only afaik my wrong, he now has linux and mac. Going to try it.

> the Blender G-code plugin (which I
> updated to make it compatible with modern G-code;
> look for it in my Thingiverse page).

Not yet set a serious foot on blender-land. THX for the link!

> I also heard
> of a new G-code previewer that was released
> recently, but I can't remember its name or where I
> read of it.

Edited 4 time(s). Last edit at 01/08/2012 12:42PM by Lanthan.
Attachments:
open | download - pronterface_shot.png (57.9 KB)
open | download - skeinview_shot.png (43 KB)
Re: Slic3r 0.5.7
January 07, 2012 07:12PM
Hardwarekiller:

I am the guy who modifed SF to be SFACT. I actively use slic3r myself now.


I think that Slic3r is a great piece of software and is covering its shortcomings in an unbelivable pace.
It has missing features and probably some mistakes (have not encountered anything vital so far) but bad dimensional accuracy is not one of them.
I recently printed an extruder and the fit for the bearings (Z-plane) and the fit for M5 nuts was perfect.

I am assuming that you are using the acceleration option in SFACT. That means that you have different (and lower) E-acceleration for your perimeters which will give you better accuracy in critical parts like the belt pulley.

have a look at the picture below:
That is a slic3r piece.

P97999300.jpg
Kimden Actions Prusa

(there also other pictures on picasa)
The most part of that pulley was printed with a E accelaration of 500. (feeds were very high for that part to magnify the difference.. 60mm/s perimeters and 100mm/s fill). Then I sent a command M201 E10 to lower the E acceleration.

See how it changed the looks and actually the dimensions.. The print was not interrupted btw.

So please always consider that if most people have it right and its not working for You that your settings are to blame..

Thanks to Sound(Alex) for the cool work..

Edited 2 time(s). Last edit at 01/07/2012 07:16PM by ahmetcemturan.


www.reprapfordummies.net
IRC: #reprap on freenode.net (Action68)
[github.com]
Re: Slic3r 0.5.7
January 21, 2012 04:06AM
I just used Slic3r for the first time tonight and love it! The only issue im running into is any gcode generated by Slic3r won't show up in Pronterface...

Gcode generated by SF or SFact show up just fine though. It seems like other people are able to view Slic3r gcode in Pronterface, so it's probably something wrong on my end. Any thoughts on what could be causing this?
Re: Slic3r 0.5.7
January 21, 2012 04:50AM
@daufhammer, did you check that the G-code file actually contains something? Remember that 0.5.7 skips thin walls, so if you're printing a thin-walled calibration object your G-code file won't contain anything.
Re: Slic3r 0.5.7
January 21, 2012 02:09PM
Loving Slic3R , what a difference on print quality.

The only issue I have came across is if I am trying to generate Gcode from any STL that has 3D text in it.

For example The Scooby Snack cutter [www.thingiverse.com]

If I load it into Printer Interface, skeinforge slices it up and I can flick through the layers and see it is all fine and prints okay.

If converted with Slic3R it misses letters or starts different letters at different heights?


Any ideas

Cheers

Sean.


******************************
[www.cncdudez.co.uk]
******************************
Re: Slic3r 0.5.7
January 21, 2012 02:16PM
@Sound, yeah there is definitely gcode in there, I printed a nice little mini octopus and it turned out great.

When i open the gcode file in Pronterface it generates all the estimates, but doesn't seem to finish, it leaves off the total duration time at the end...(I haven't integrated Slic3r with Pronterface yet, just using them separately).
It looks like this...

449.243 mm of filament used in this print

the print goes from 63.6 mm to 136.4 mm in X
and is 72.8 mm wide

the print goes from 63.27 mm to 136.66 mm in Y
and is 73.39 mm wide

the print goes from 0.48 mm to 15.28 mm in Z
and is 14.8 mm high

Estimated duration (pessimistic): .... estimating ....
layer z: 0.0 will take: 00:00:02
layer z: 0.48 will take: 00:01:42
layer z: 0.88 will take: 00:00:42
...
layer z: 14.48 will take: 00:00:10
layer z: 14.88 will take: 00:00:10

When i open gcode sliced with SF it finished loading it completley and shows a total duration at the bottom and generates a gcode preview.
like this
...
layer z: 14.48 will take: 00:00:10
layer z: 14.88 will take: 00:00:10
Total Duration:
00:09:35
Re: Slic3r 0.5.7
January 21, 2012 02:57PM
Well, I may have figured out why my Slic3r gcode preview wasn't showing up in Pronterface... I was using the latest experimental version (precompiled) which wasn't showing me the preview of my Slic3r gcode.... I decided to download the latest version right before the experimental one and it seems to work fine... my Slic3r generated gcode shows up just fine!

So i guess it's just some bug with the lastest experimental version of Pronterface, I logged this issue on Kliment's Printrun Github page.

Edit: Kliment replied to the issue I logged and said this problem has been fixed in the current github version, but he just hasn't made a binary of it yet.

Edited 2 time(s). Last edit at 01/21/2012 03:41PM by daufhammer.
Sorry, only registered users may post in this forum.

Click here to login