Welcome! Log In Create A New Profile

Advanced

Hilfe bei Inbetriebnahme

Posted by LAHUWI 
Hilfe bei Inbetriebnahme
July 22, 2011 06:39AM
Hallo Leute,

Unseren 3D Drucker und den Extrunder haben wir selbst entworfen (ein Bild wurde beigelegt) nachdem wir uns über den Reprap Mendel Drucker informiert hatten.Wir versuchten unseren 3D Drucker in Betrieb zu nehmen, den wir mit NEMA 17 Motoren antreiben wollen. Außerdem verwenden wir das Arduino MEGA 2560 Board und das RAMPS 1.3 Board zur Steuerung.

Als wir Testweise einen Motor antreiben wollten tat sich erst mal gar nichts. Dann Drehten wir am Poti das auf dem Regler für den Motor sitzt was dazu führte das unser Aduino board und die Motorsteuerung abrauchten.

Kann uns Jemand von euch sagen ob unsere Motoren und die Steuerung die Wir verwenden kompatibel sind?

Außerdem würden wir uns freuen wenn uns jemand ein geeignetes Programm empfehlen würde. Bisher versuchten wir wir es mit dem Replicator G und dem Repsnapper. Wir haben jeweils die Firmware runtergeladen und auf das Board gespielt.

Würde uns freuen wenn uns jemand helfen könnte.
Danke schon mal für eure Hilfe

Team LAHUWI
Attachments:
open | download - untitled.3.jpg (47.7 KB)
Re: Hilfe bei Inbetriebnahme
July 22, 2011 07:08AM
Quote

Dann Drehten wir am Poti das auf dem Regler für den Motor sitzt was dazu führte das unser Aduino board und die Motorsteuerung abrauchten.

Das sollte eigentlich nicht passieren. Die Motorsteuerung (die "Pololus") haben einen Überhitzungsschutz drin. Der Arduino hat mit dem Motorstrom überhaupt nichts zu tun.

Bleibt die Frage, was genau "abrauchen" denn nun ist. Sind da einfach nur die Stromführungen überhitzt, weil die Motorsteuerung versucht hat, den Motorenstrom über den Arduino zu ziehen? Dann wäre etwas mit dem RAMPS nicht in Ordnung. Die Steuerungs- und Motorstromseite der Pololus ist sauber getrennt.

Quote

Kann uns Jemand von euch sagen ob unsere Motoren und die Steuerung die Wir verwenden kompatibel sind?

Ja, die sind kompatibel.

Auch wenn Du uns noch gar nicht verraten hast, welche Motoren Du denn hast. "NEMA17" ist nur die Grössenbezeichnung. Allerdings sind alle bipolaren Schrittmotoren kompatibel, schlimmstenfalls liefern sie zu wenig Drehmoment. Bipolare Schrittmotoren erkennt man daran, dass sie 4, 6 oder 8 Anschlussdrähte haben. 5 Drähte = unipolar = ungeeignet.


Generation 7 Electronics Teacup Firmware RepRap DIY
     
Re: Hilfe bei Inbetriebnahme
July 22, 2011 07:43AM
@Team LAHUWI: Wie wäre es mit ein echten Bild anstatt ein gerenderte darstellung. eye rolling smiley


Bob Morrison
Wörth am Rhein, Germany
"Luke, use the source!"
BLOG - PHOTOS - Thingiverse
Re: Hilfe bei Inbetriebnahme
July 22, 2011 10:04AM
Wie wärs mal mit einem Foto von der Vorder und der Rückseite eurer Ramps... das wäre mal ne Info...


Mfg
Wolfgang
Aller Anfang war schwer - Wolfstrap Reprap-fab.org Meine Meinung

Erfahrungen kann man leider schlecht weiter geben, die muss man selber machen.
Re: Hilfe bei Inbetriebnahme
July 22, 2011 11:02AM
Hallo Leute,
zuersteinmal danke für eure Ideen und erklärungen.


Ich versuch euch mal n paar infos über unser Problem zu geben:

Abgeraucht ist "nur" der Pololu Stepper Driver.
Ich hab mal mit einem Bild aus dem Internet versucht euch den schaden darzustellen. Den Brandherd habe ich rot eingezeichnet. Auf dem kleinen Baustein konnte man (blau markiert) die verschmorte Leiterbahn erkennen. es war, wenn ich mich nicht täusche sogar eine Flamme zu sehen. Unten an dem kleinen board steht VDD was auch zu dem Chip an die stelle der Verbrennung führt (schätzungsweise Stromversorgung)
Das Arduino Mega 2560 Board ist wohl noch funktionsfähig.

Leider können wir im Moment keine weiteren Bilder zur Verfügung stellen, erst am Montag haben wir wieder die Gelegenheit dazu.... (evtl. schau ich morgen mal vorbei wenn mir die zeit reicht)

Das Problem mit den Motoren ist, das laut dazugehörigem Datenblatt 48V benötigt werden. (genaue Bezeichnung habe ich gerade nicht da)

@Traumflug: unsere Motoren haben 4 Anschlussleitungen genauere Bezeichnung kann ich morgen oder am Montag mal raussuchen. ich weiß nur, das es ein Trinamic QMot Schrittmotor ist.

Lotte (Team LAHUWI)
Attachments:
open | download - pololu.jpg (95.2 KB)
Re: Hilfe bei Inbetriebnahme
July 22, 2011 11:47AM
mit wieviel spannung bist du da drauf gegangen?

meine maschine hier mit nema 17 motoren von grrf und pololus laufen mit 12V....


grüße
Bernhard
------------------------------------------------------------------------------------------------------------------------------
[www.thingiverse.com]
[www.flickr.com]
Re: Hilfe bei Inbetriebnahme
July 22, 2011 12:14PM
Normalerweise sollte die Nennspannung der Motoren unter der Spannung liegen die einem zur Verfügung steht. Bei 12V sollten die so zwischen 3 und 8V liegen. Der Strom wird dann durch die Pololus begrenzt, so das die immer die richtige Spannung ab bekommen.

48V Nennstrom ist eindeutig zu viel.


Mfg
Wolfgang
Aller Anfang war schwer - Wolfstrap Reprap-fab.org Meine Meinung

Erfahrungen kann man leider schlecht weiter geben, die muss man selber machen.
Re: Hilfe bei Inbetriebnahme
July 22, 2011 12:16PM
Desweiteren steht in der Beschreibung der Pololus :
Quote

Der Treiber ist für Spannungen von 8-25V geeignet und kann einen Strom von 2A per Phase ansteuern.

Edit:
Watterott hat sich wohl verschieben, im Datenblatt steht "with an output drive capacity of up to 35 V and ±2 A."

Edited 1 time(s). Last edit at 07/22/2011 12:21PM by Stoffel15.


Mfg
Wolfgang
Aller Anfang war schwer - Wolfstrap Reprap-fab.org Meine Meinung

Erfahrungen kann man leider schlecht weiter geben, die muss man selber machen.
Re: Hilfe bei Inbetriebnahme
July 22, 2011 12:17PM
Quote

Das Problem mit den Motoren ist, das laut dazugehörigem Datenblatt 48V benötigt werden.

Die Pololus halten aber nur 35 Volt aus. Was der RAMPS aushält weiss ich nicht, denn so weit ich weiss, zieht der auch einen Teil der Stromversorgung von der Motorspannung ab.

Bleibt die Frage, ob der Motor wirklich 48 V braucht. Laufen wird er auch mit weniger, dann eben auch mit entsprechend weniger Drehmoment.


Generation 7 Electronics Teacup Firmware RepRap DIY
     
Re: Hilfe bei Inbetriebnahme
July 22, 2011 03:22PM
Vielen dank für eure antworten.

Wenn ich das Jetzt richtig verstehe, können wir die Schrittmotoren die wir derzeit haben, dennoch nutzen (Weniger Spannung -> weniger Drehmoment). Ob der Motor wirklich seine 48V brauch weiß ich hingegen nicht. Schätze aber schon, da sich der Motor mit wenig Spannung nur sehr schwach bewegt hatte.

nun aber noch zu einem Anderen Thema: der Software
wir haben in unserer bislang sehr kurzen Testphase nur den ReplicatorG und den Repsnapper testen können.
Was habt ihr so an software am laufen?
Was könnt ihr uns Empfehlen?
Was gibt es wichtiges zu beachten?
Welche Firmware past dazu?

Vielen Dank!

Lotte (Team LAHUWI)
VDX
Re: Hilfe bei Inbetriebnahme
July 22, 2011 04:37PM
... ichh arbeite mich für den ArduinoMega mit RAMPS gerade in Sprinter und Printrun ein - der GCode wird mit Skeinforge oder dem etwas abgespeckten SFact erstellt ...


Viktor
--------
Aufruf zum Projekt "Müll-freie Meere" - [reprap.org]
Call for the project "garbage-free seas" - [reprap.org]
Re: Hilfe bei Inbetriebnahme
July 23, 2011 01:29AM
Firmware: FiveD
Host: Printrun
Slicer: Skeinforge (SF41)


Bob Morrison
Wörth am Rhein, Germany
"Luke, use the source!"
BLOG - PHOTOS - Thingiverse
Re: Hilfe bei Inbetriebnahme
July 23, 2011 06:06AM
Firmware: FiveD
Host: Printrun
Slicer: Skeinforge (SF30)


Mfg
Wolfgang
Aller Anfang war schwer - Wolfstrap Reprap-fab.org Meine Meinung

Erfahrungen kann man leider schlecht weiter geben, die muss man selber machen.
Re: Hilfe bei Inbetriebnahme
July 27, 2011 04:38AM
Hallo Leute,

Wir haben jetz nochmal ein paar Bilder unseres Druckers für euch. Es ist auch ein Bild der Kleinen Platine dabei die uns durchgeschmort ist.
Außerdem haben wir hier die Motordaten unserer Schrittmotoren:

QMot.eu50-0036
QSH 5718-76-28-189
Lot no: 0945070(1.001)

mit der Frage ob diese Motoren wirklich verwendet werden können.

Team LAHUWI
Attachments:
open | download - IMAG0011.jpg (484.9 KB)
open | download - IMAG0008.jpg (512.9 KB)
open | download - IMAG0012.jpg (577.1 KB)
Re: Hilfe bei Inbetriebnahme
July 27, 2011 05:03AM
Wellen-ø 6.35 mm
Nennstrom 2.8 A
Phasenstrom 2.8 A
Schrittwinkel 1.8 °
Haltemoment 1.89 Nm
Betriebstemperatur -20...+50 °C
Abmessungen L x B x H 76 x 56.4 x 56.4 mm
Betriebsspannung 75 V
Länge Welle 20.6 mm
Flanschmass 57.2 mm (NEMA23)
Baulänge 96.6 mm
Stromaufnahme 2.8 A

Also wenn diese Daten, die ich gegoogelt habe, stimmen sollten. würde ich eher NEIN sagen.
Klar das der Pololu den Löffel ab gegeben hat als ihr den auf gedreht habt. Der kann nur (mit Kühlkörper) bis 2A und bis zu einer Spannung von 35V.
Der war mit dem Motor überfordert. Wenn ihr den zu dreht, bringt der Motor nichts mehr.


Mfg
Wolfgang
Aller Anfang war schwer - Wolfstrap Reprap-fab.org Meine Meinung

Erfahrungen kann man leider schlecht weiter geben, die muss man selber machen.
Re: Hilfe bei Inbetriebnahme
July 27, 2011 05:08AM
Dein RepStrap sieht sehr stabil aus! thumbs up

Motor specification ist HIER zu finden.

Rated phase current A: 2.8
Ph. resistance at 20°C
: 1.13
Ph. inductance (typ.) mH: 3.6
Holding torque (typ.) Ncm: 189
Detent torque Ncm: 6.6
Rotor inertia gcm2: 480
Weight (mass) kg: 1.00
Motor length mm: 76.0

Sieht ganz gut aus.

@Wolfgang: Hab ich ubersehen das er das mit ein Ramps elektronik steuren will...

Edited 1 time(s). Last edit at 07/27/2011 05:11AM by rhmorrison.


Bob Morrison
Wörth am Rhein, Germany
"Luke, use the source!"
BLOG - PHOTOS - Thingiverse
Re: Hilfe bei Inbetriebnahme
July 27, 2011 05:35AM
@Wolfgang: Erstmal vielen dank für die einschätzung. gibt es denn ne möglichkeit die motoren mit einer anderen Steuerung trozdem zu nutzen, oder müssen wir uns neue Motoren beschaffen (wenn ja, welche kannst du uns empfehlen?)

Grüße LaHuWi
Re: Hilfe bei Inbetriebnahme
July 27, 2011 05:53AM
Ich kann dir da keine Empfehlung aussprechen (nachher bin ich es gewesen tongue sticking out smiley )

Du mußt mit der Motorspannung möglichst weit unten bleiben. Aber zumindest unter den 35V die die Pololus verkraften können.
Ihr hab da Nema23 und wir verwenden normalerweise Nema17 und die haben meist unter 2A und etwas zwischen 3 und 8V Motornennspannung.
Die haben aber auch ein anderes Flanschmaß.

Ich würde mal bei ZAPP gucken ob die was Passendes da haben
[www.zappautomation.co.uk]


Mfg
Wolfgang
Aller Anfang war schwer - Wolfstrap Reprap-fab.org Meine Meinung

Erfahrungen kann man leider schlecht weiter geben, die muss man selber machen.
Re: Hilfe bei Inbetriebnahme
July 28, 2011 05:02AM
Auf ebay gibt es immer wieder treibermodule für diese großen Motoren, diese lassen sich auch über eine Ramps ansteuern, wenn die entsprechenden pins mit den steckplätzen, an denen die pololus normalerweise sitzen, verbunden werden. Ich habe das derzeit selber im Test, da mir mal ein Pololu Feuer gefangen hat. Meinen repstrap mit NEMA23 Steppern an X,Y fahre ich mit einer gen6, die Treiber der gen6 können bis 2,5 A. Allerdings brauche ich da einen Lüfter der auf die Kühlkörper der Treiber bläst, sonst gehen die nach ein paar Minuten in einen Thermal Shutdown (die haben einen Überlastschutz)
Die externen Module von denen ich spreche sind ähnlich den folgenden:
[cgi.ebay.at]

Die Spannungsversorgung (Leistungsseite) muß direkt vom Netzteil erfolgen, die 5V, Enable, Step und Dir von der RAMPS oder direkt von einem Arduino.
Sorry, you do not have permission to post/reply in this forum.