Welcome! Log In Create A New Profile

Advanced

X and Y Stepper Motor Noise

Posted by 556duckvader 
X and Y Stepper Motor Noise
April 14, 2017 06:38PM
Ok I am in the process of building my printer and I am having issues locating the source of all the noise while moving the x and y axes. The z axis is quite as well as the extruder is the same style motor as my x and y motors. Below is the video of the noise. Any help would be great.

X and Y Stepper Motor Noise
Re: X and Y Stepper Motor Noise
April 14, 2017 11:53PM
maybe sounds like cheap linear bearing rattling around
Re: X and Y Stepper Motor Noise
April 14, 2017 11:55PM
Sit your printer on some rubber and see if it still makes the noise. You can get some odd sounds that will vibrate though a printer.
Re: X and Y Stepper Motor Noise
April 15, 2017 08:44AM
I have it setting on 4 foam feet. It doesn't make the noise when I move it by hand and the bearing slide freely.
Re: X and Y Stepper Motor Noise
April 15, 2017 11:24AM
You get that sort of stepper motor noise on all 3D printers with low-microstepping drivers. It's caused by the stepper motors moving in discrete microsteps, and made worse by resonances in the printer mechanics. It needn't stop you from printing.

Using drivers with higher microstepping will quieten it.



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: X and Y Stepper Motor Noise
June 12, 2017 10:57PM
Hello,

My name is Sergio and I really need some help, like a lot of help.
I am currently building a Hypercube by Tech2c and I'm having a motion issue
when I hit the home button in pronterface none of my motors move, but that's not it
instead of moving the make this weird high pitched sound and my z-axis motor starts to move then stops.
I thought it was binding so, I took out the lead screw and it
still, does the same thing, also my x and y-axis don't move and make a high pitched
sound, I have a feeling that I'm not doing something right whether it be a Marlin Setting or
something else.

Someone Please Help I really need it
Re: X and Y Stepper Motor Noise
September 11, 2017 06:11PM
@Sergio.Diventura

I have the same issue, did you find a resolution ? Please let me know how did you make it work. Thanks
Re: X and Y Stepper Motor Noise
September 12, 2017 03:23AM
Likely causes are microstepping not set to x16 or higher in the hardware (a common mistake for users of RAMPS), or speeds or accelerations set too high in the firmware configuration.



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Sorry, only registered users may post in this forum.

Click here to login