Welcome! Log In Create A New Profile


Marlin installation problem

Posted by clogs51 
Marlin installation problem
November 26, 2014 12:27AM
Hi guys,I'm trying to install Marlin on my Arduino mega2560 .I got as far as the configuration.h file,but when i tried to upload that ,i got the following error message.

"expected unqualified-id before numeric constant"

And in the window below,this came up:

"In file included from/Marlin.h:22.
from cardreader.ccp:1:
expected unqualified-id before numeric constant."

I have no idea what this means,or what to do about it.
As you can tell,i'm not familiar with programming,and this has me shaking in my boots.
I'd be grateful for any pointers.
Re: Marlin installation problem
November 26, 2014 01:37AM
google tells me you have probably used a comma instead of a full stop in a variable you have changed in configuration.h
Re: Marlin installation problem
November 26, 2014 02:30PM
if you copy and paste the cofig file contents here we can take a look
Re: Marlin installation problem
November 26, 2014 06:32PM
There is probably an error on line 29 of the Configuration.h file.
Compare it to other lines to see if you can figure out what is wrong. They tend to be very simular. Like Dust suggested - possibly a comma or something that shouldn't be there.
Re: Marlin installation problem
November 26, 2014 10:28PM
Thanks guys,but the error was between my earsgrinning smiley.
What I did was remove the // from the description of the motherboard line,rather than the actual #define motherboard line.
Typical newbie mistake.
I now have the Marlin uploaded,but now I'm struggling with the dreaded "maxtemp error"
I've pulled the hotend thermistor out several times,fiddled with the wires,etc.,but no cigar.
When i put the meter on it,it read 93.3K resistance,so does that prove the thermistor is ok,or is that figure meaningless?
The hotend is a new j-head one from hotends.com.
Re: Marlin installation problem
November 27, 2014 03:13AM
I'm not sure on what reading you should get, but make sure you have the correct thermistor setup in Marlin, I dont have my laptop in front of me with my config file on it, but this is from the Jhead website: "Description: While smaller than the EPCOS thermistor, this thermistor will work with all J-Head hot-ends. Please ensure that thermistor table 5 (for Marlin and Sprinter) is selected in your firmware."
thats also your replacement part if you have need a new one, however it should work straight out of the packet unless you have a short somewhere or your config is wrong.
Re: Marlin installation problem
November 27, 2014 03:34AM
Zerker,thanks for that,but I did remember that the hotend was supplied with the Semitec thermistor,which is 5 in the Config.h list.
I'm beginning to wonder if there is another setting in the config.h file related to max. hot-end temperature i might have missed.
The whole shebang is in my workshop,so i can't check it right now.
I also still have a spare thermistor from my old hot end,so,if all else fails,i'll try that one instead.
That is one of the supposedly inferior epcos ones, though it worked well enough with the old setup.
Re: Marlin installation problem
November 27, 2014 02:52PM
jhead stopped using their old one as they are EOL not because they were inferior
Re: Marlin installation problem
November 27, 2014 10:29PM
Well,after a day and a half of frustration,naughty words,and pulling out non-existent hairs,I've found the problem.
When setting the thermistor type,I somehow managed to insert a - symbol.Once I removed this,the printer came online,and i performed the pid test.purficsmoking smiley
But that's thrown another spanner at the grease monkey.See new post.
Sorry, only registered users may post in this forum.

Click here to login