Welcome! Log In Create A New Profile


Loading firmware on PanelDue 1.1

Posted by DADIY 
Loading firmware on PanelDue 1.1
July 21, 2016 11:54AM
I suspect I'm doing something wrong, but this is now driving me nuts.

I made sure the jumper was set to 3.3v and connected the PanelDue to a 7" screen and plugged it into my USB port only. The screen came on but showed funny lines as I expected so thought all I needed to do was load the right firmware.

I pressed and held erase for a couple of seconds and then pressed reset. I now have a black 7" screen with the backlight on.

The issue is the PanelDue just will not get recognised by either Windows 7 or 10 (different laptops) (no USB connection sound or unknown/odd devices in device manager) and also under Linux when connecting no ports are detected when checking dmesg.

I've also tried to connect it without the display attached but that too has the same issue. I also tried two different cables, one that came with the Duet 0.6 which I previously used to flash firmware and one other I had. Same results.

I have also tried holding erase and reset for longer in case the instructions had changed for this 1.1 version but no joy.

DC42 Kossel 330mm x 2meters
My Thingiverse Creations
Re: Loading firmware on PanelDue 1.1
July 21, 2016 12:18PM
The 7" screen needs nearly 700mA current, but most USB ports can only supply 500mA. Try disconnecting the display panel from the PanelDue controller board, then connect the PanelDue controller board to your PC and see if it is recognised. You can program the PanelDue controller without the display being connected.

Bear in mind that if Windows thinks a port is faulty or overloaded, it will turn it off. This is visible in Device Manager. So you may need to reboot Windows (or reset the port in Device Manager) before the port is usable again.

Large delta printer [miscsolutions.wordpress.com], E3D tool changer, Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Loading firmware on PanelDue 1.1 [SOLVED]
July 21, 2016 12:25PM
Well in one last attempt I found an HTC micro usb cable and that just worked. I'm so relieved, I can only guess the other cables couldnt supply the current.

thanks for a prompt response.

DC42 Kossel 330mm x 2meters
My Thingiverse Creations
Sorry, only registered users may post in this forum.

Click here to login