Welcome! Log In Create A New Profile

Advanced

Duet 0.6 Burnt EO Heater Ground Now No Web Control Access

Posted by DRTak 
Duet 0.6 Burnt EO Heater Ground Now No Web Control Access
May 04, 2017 12:23PM
Hello,

My printer was doing great until I smelled burnt electronics. Like a fool I kept printing. The print finished and all looked well. Over the last weekend, I decided to upgrade to Repetier 2.0. But didnt attempt to print anything. Monday I tried printing and I had no web control. I uninstalled Rep 2.0. Did not help me. Removed Rep Server. Did not help. So using my Panel Due, transfering print file via the SD card, I printed successfully as a stand alone unit. NO more burnt electronic smell. I continued to try to connect to the duet via the duet web control (DWC). No luck. I looked on my router and the printer is not even showing up on my network. Plugged the ethernet cable into my PC and it works fine. So it is not the ethernet cable. When I plugged the ethernet cable back into the duet 0.6, I noticed that only the green (I think this is the TX light. Transmitting?) light blinks. Not the orange (recieve) light. So I am not RX any signal? Is this normal?

Took apart the printer to look at the duet directly. The only item slightly brown was the EO HEATER ground. I assume this was the smell of burnt electronics. Nothing else looks burnt. Put the system all back together after retightening all the connections. Sytem turns on fine. Still no DWC access to the printer. Still no printer showing up on my network. What is wrong? Is there some connection between the EO Heater terminal and the ethernet terminal? I like the DWC when I level the bed and calibrate the system.

Was able to connect the printer to my PC via a USB cable and connect via Repetier Host.

INFO:
Mini Kossel
Duet 0.6 Firmware 1.18.1
Panel Due 1.16
DWC Firmware 1.15
Browser Chrome
Power Supply OEM Sintron Mini Kossel version
Hotenend Hexagon
Heated Bed

Edited 2 time(s). Last edit at 05/04/2017 12:27PM by DRTak.
Re: Duet 0.6 Burnt EO Heater Ground Now No Web Control Access
May 04, 2017 07:21PM
There is no E0 heater ground terminal and no connection between the E0 heater terminals and the Ethernet system.

If one of the E0 terminals is discoloured, this probably means that the screw in the terminal worked loose.

The Ethernet issue may be different. On older Duets the soldered connections between the Ethernet PHY chip and the PCB were sometimes less than perfect and could be intermittent. I have repaired several boards by re-soldering or replacing the chip. Later Duet 0.8.5 boards used a different PCB pattern to eliminate the problem.


Delta printer calibration calculator, mini IR Z probe, and colour touch screen control panel: [escher3d.com]

Large delta printer, and other 3D printer blog postings: [miscsolutions.wordpress.com]

Disclosure: I have a financial interest in sales of the Panel Due, Mini IR height sensor, and Duet WiFi/Duet Ethernet.
Re: Duet 0.6 Burnt EO Heater Ground Now No Web Control Access
May 05, 2017 02:17PM
Quote
dc42
There is no E0 heater ground terminal and no connection between the E0 heater terminals and the Ethernet system.

If one of the E0 terminals is discoloured, this probably means that the screw in the terminal worked loose.

The Ethernet issue may be different. On older Duets the soldered connections between the Ethernet PHY chip and the PCB were sometimes less than perfect and could be intermittent. I have repaired several boards by re-soldering or replacing the chip. Later Duet 0.8.5 boards used a different PCB pattern to eliminate the problem.

DC42. I just resoldered the ethernet port and it didnt help me. Is there new g codes that I have to implement in my config.g file since my update from firmware 1.09a?

I have an M552, M553, and M554 command. Do I need to put in an M586 command etc?
Attachments:
open | download - Capture.JPG (34.9 KB)
Re: Duet 0.6 Burnt EO Heater Ground Now No Web Control Access
May 05, 2017 02:23PM
It's not the Ethernet connector that sometimes causes problems, it's the square chip that connects the processor to the Ethernet connector. If that's the problem, it needs hot air soldering equipment and sometimes a new chip to fix it.

You don't need to use M586 to use HTTP protocol, you only need it if you want to use FTP or Telnet.


Delta printer calibration calculator, mini IR Z probe, and colour touch screen control panel: [escher3d.com]

Large delta printer, and other 3D printer blog postings: [miscsolutions.wordpress.com]

Disclosure: I have a financial interest in sales of the Panel Due, Mini IR height sensor, and Duet WiFi/Duet Ethernet.
Re: Duet 0.6 Burnt EO Heater Ground Now No Web Control Access
May 05, 2017 11:47PM
Quote
dc42
It's not the Ethernet connector that sometimes causes problems, it's the square chip that connects the processor to the Ethernet connector. If that's the problem, it needs hot air soldering equipment and sometimes a new chip to fix it.

You don't need to use M586 to use HTTP protocol, you only need it if you want to use FTP or Telnet.

The square chip I believe is the one that says TX next to it? I do not have hot air soldering equipment. So I give up. I just ordered your Duet Ethernet. I hope it is not to hard to get my system up and running once I install the new board when it arrives.

Thanks for all your timely advice. Thats the reason I buy your products.

Edited 1 time(s). Last edit at 05/06/2017 10:14AM by DRTak.
Sorry, only registered users may post in this forum.

Click here to login