Welcome! Log In Create A New Profile


Hangprinter version 3

Posted by tobben 
Re: Hangprinter version 3
September 12, 2018 05:06AM
Nevermind, I forgot few cables... grinning smiley
Re: Hangprinter version 3
September 12, 2018 09:08AM
Hi all, I have finished my holidays and continues with the challenge smileys with beer

I finally boot correctly with HAW . I don't understand why, but now I don't have any problem to upload Mechaduinos . confused smiley I am using the same computer, same port, same wire and now works correctly.

Following the procedure I have calibrate the A motor and the behaviour is correct. the axis seems hard to move and returns to its position, like a spring.

But the rest of motors don't work correctly. When I start the calibration routine the serial port says "Wired backwards" . I check wiring and is ok. The 3 motors B,C,D have the same problem. If I turn the motor wiring I have the same error message.

Any suggestions?
Re: Hangprinter version 3
September 16, 2018 12:15PM
@VictorBarahona: I don't recall it exactly, but I think I had a similar issue while flashing the mechaduinos earlier this year. In my case the problem was, that I had the phases connected the wrong way. Can you post an image of all motors and their connections?

@tobben & all: This week was a breakthrough. I finally got the first prints ready! First of all, I'd like to thank you Tobben for this amazing project!!

In chronological order from right to left. After calibrating the extruder esteps, it already looks promising.

The frame looks currently like this

Up until now I've done only manual calibration on the printer and that proved to be quite difficult because of the elevated print bed. Next week I'm going to try the auto calibration script.
I experienced some issues with marlin killing the process due to heating failures. Since I've used 1 mm2 cables for heater power supply, I hardly believe it's about the cable resistance. Any ideas?

For now I won't print overnight, so what would be the process of pausing and restarting the print again? And how should I re-home the print head after power off since the print head?
Re: Hangprinter version 3
September 18, 2018 06:48AM
You first enable torque mode on all motors. Then move to the origin and issue G96. Then move to random positions. No need to return to [0,0,0] between measurements, just move from one random position to the next.

Glad to hear upload is working!

I've also had that error message a few times. Try stepping a few times back and forth (send for example 's', 's', 'd', 's', 's'). That enabled the motors and solved the error last time I had that error message.

That's a pretty decent looking Benchy already smileys with beer

Heating failures like you describe most often stem from glitching in connectors on one of the thermistor cables. If you can feel heater cables getting warm then it could be heater cables, particularly if you're on 12V. Should be ok though.

Since we're on stock Marlin now, you could try ADVANCED_PAUSE_FEATURE, which is in Configuration_adv.h. I haven't tried it myself (or any of the other pause features in Marlin, I still live like it's 2015 pause-feature-wise).

They way I did pause back in the day was:
  • Pause the printer
  • Issue M114
  • Write down XYZ-coordinates on a piece of paper
  • Lift hot end a few cm and turn off heater
  • Observe where pause blob is on the print
  • When hot end below ca 80 degrees: pull power plug
  • Upon power up next morning: put nozzle on pause blob (using G6 or G95 if you have it), tighten lines, and start heating hot end
  • Send G92 with yesterday's XYZ-position so printer knows where it is
  • Open gcode file and search for yesterday's XYZ-position. Delete that G1-line, and all gcode lines above it.
  • Load the now amputated gcode file in Pronterface/Octoprint.
  • Just press print! (should be a registered trademark and registered slogan of that wonderfully straightforward pause procedure)

Re: Hangprinter version 3
September 18, 2018 09:18AM
Yes, you might be right about the glitching connectors. Since I re-plugged it, the printer seems to run without errors.

Thanks for the pause procedure, I'm trying it today!
Sorry, only registered users may post in this forum.

Click here to login