Welcome! Log In Create A New Profile


Assistance with new build

Posted by Shourisha1 
Assistance with new build
March 31, 2015 04:09AM
I originally placed this post in the thread for the Folger Tech i3 pruza from ebay, but I feel like this may be a more general error, so hear goes.

I was hoping I could be pointed in the right direct. I bought this kit back in october or november, and I am still having issues getting it built and working. Well, the build was easy, but the wiring... Well, not good. Two weeks ago, after finally wiring my PSU, rampsw, motors, etc, I said a little prayer and connected my Arduino(while connected to the ramps, with power on) to my laptop to begin programming(at the time, I thought the arduino had to be mounted to the Ramps in order to function whatsoever -_-). (It might be important to note that at this point, everything is heating up, but not moving--Heated bed and hotend are... hot.) When I did, the laptop immediately shut off. Reset the laptop, plugged in the arduino, reset once more. Upon some research, found that this can happen with USB ports that aren't powered well. This made some sense, so I figured I'd try a newer Asus that I knew worked and worked well. No reset, but my cursor began going mad, and randomly clicking. Confused and defeated, I unplugged the arduino, did more research, and found out that the arduino could be programmed on its own, using usb power(Duh). I attempted to program, but the led would slowly fade out after 30 seconds on the board, and my PC would not recognize. Lo and behold, several chips on the board seem to be fried. Resolving that somewhere, somehow, I've read or watched a poor instruction, I purchased a new ramps, arduino mega, and step sticks.

Today, I review my wiring, findi9ng what I believed to be the issue. My PSU's power cable's Live and Neutral cables were crossed. I also possibly had my endstop switches on incorrectly. I correct the PSU(wich never gave me issues in the first place), rewire the new ramps, hook up and program the new Arduino(Worked!) connect the new arduino, power it all on. Unlike my first boot, nothing really happens. The PSU lights up and the fan spins, the arduinpo lights up, but the ramps doesn't. Unlike the first time, the heated bed does not heat, and the hotend is not... well, hot. Thinking this is due to settings in the programming somehow(At this point I'm truly lost) I connect the arduino to my Asus. I get the same error as before, the cursor jumping wildly, and nothing working. BUT, the arduino hasn't fried itself, so I'm happy there. At this point, I'm beaten. I'd hoped I could come here and beg for some assistance.

At this point, I know only a couple things. First, I'm positive there must be feedback coming from the arduino into the laptop. This seems like a very bad thing. Second, my wiring matched every diagram I've seen. I've attached a couple picks of the new ramps for evidence. I can't figure the beast out. I've built pcs for 15 years, and have never had an ounce of difficulty with electronics in general, but this thing, the entire 3D printer, makes me feel like a dunce, and I can't seem to learn my way out of it. Thanks for any, and all, assistance guys. (Also, this post may be in the wrong place--I just figured this seemed right, since this is the kit I'm using)
open | download - 20150327_162159.jpg (191 KB)
Re: Assistance with new build
March 31, 2015 06:58AM
Hi. Thoughts galore, I whish this may help you.
- Your Ramps quality is not good. Check any soldering problems on the underside.
- Be sure the shield is properly connected to the arduino.
- I can't see one of the negative 12v incoming power. Be sure the power comes at each terminal of the board with a multimeter. Once you have the multimeter in you hand, check the 5v and 12v everywhere on the board (aux, endstops, servo, D2...) if something is wrong with the board, you may find missing output voltages somewhere. Beware to don't make any shorts !
- Be sure tu use insulated connectors for yours thermistors (a thermistor failure blocks the whole program).
- It's surly not a solution for your problem but you should wire your hotend fan to the D2 plug instead of the D9, which is to cool down parts, not the hotend which requires a continuous 12v. Except that points, your wiring looks like ok.

Collective intelligence emerges when a group of people work together effectively. Prusa i3 Folger (A lot of the parts are wrong, boring !)
Re: Assistance with new build
March 31, 2015 04:06PM
I actually forgot to mention, that last negative cable is installed, it just giot twisted while taking the picture.
Re: Assistance with new build
April 02, 2015 05:35PM
Also, try to isolate all cables that you connect.
I believe your thermistor are "naked" and believed or not it
Can short the board.
Hope this helps
Re: Assistance with new build
April 03, 2015 06:45AM
if you remove all the wiring (including power) and connect to PC with only the following plugged in: Arduino, RAMPS, StepStick. Does your laptop go haywire? it should do nothing but assign a Com port to the board.

from there you can load the firmware and then disconect from PC and continue wiring up. Go Here [www.nextdayreprap.co.uk] for a correct wiring guide for the RAMPS board, make sure yours is the same
Sorry, only registered users may post in this forum.

Click here to login