Welcome! Log In Create A New Profile


2nd layer not printing on first

Posted by bbriggstkd 
2nd layer not printing on first
October 12, 2010 07:42AM
I've got what looks to be a bit of odd behavior. I'm Using RepSnapper host software, but my gcode is from skeinforge 31, my firmware is the RepRap firmware from March 8. I finally got the settings down to where I'm actually getting something that resembles what I'm trying to print. I just have a 10mm cube. It prints the raft and the first layer on the raft then the 2nd layer is printed to the side of the raft and not on top of the first layer.

Any ideas? Does this have anything to do with absolute vs relative positioning. I've got it set to absolute at the moment. I wouldn't think it would be the Y axis dropping steps because the 2nd layer is being printed further in the Y direction and is still centered in the X direction.

I've seen this with an older version of the firmware/skeinforge too. I've attached my gcode.

Thank You
open | download - 10mm Cube_export.gcode (45.8 KB)
Re: 2nd layer not printing on first
October 12, 2010 05:38PM
Check your endstops? If the optical endstops are always triggering, then it will think it's homed as soon as it finishes the first layer, and proceed to move to some incorrect place to print the second.
Re: 2nd layer not printing on first
October 12, 2010 09:38PM
This can happen if a stepper motor skips a step. If the head catches on something it can cause the motor to skip a step. There is usually a distinctive noise as it does it. Try holding the top of the extruder (not the top part) to make the motor skip so that you know what it sounds like.

Re: 2nd layer not printing on first
October 13, 2010 09:34AM
I had a similar problem, which turned out to be slipping gears on both the x and y axis.

Try slicing a model in RepSnapper and see if the problem is software related.

I would've preferred to update the firmware to a more recent version as well.

Blog with RepRap Comic
Re: 2nd layer not printing on first
October 13, 2010 11:12PM
Thank you for all the advice. Here is what I have come up with so far.

End stops: They don't appear to be triggering except when they are supposed to. I did notice a little bounce when the flag triggers the end stop on the X and Y directions but this isn't at random places on the build platform.

Missing Steps: I don't think I'm missing any steps but I'm not sure exactly what I'm looking for. The sound from the motors seems to be consistant.

Slipping Gears: I couldn't detect the belts slipping anywhere but there was a little slack to I tightened the X and Y belts some.

RepSnapper Gcode: I tried slicing my stl file with RepSnapper but I can't seemto get any usable gcode. I haven't found much documentation on it so I may be doing something wrong. The head is moving around but the extruder usually just sits there and ticks back and forth with out exturding any material. I can't figure out how to set the temp. It doesn't seem to use the setting on the Print tab but I can't find any other place it is set.

The firmware is what was provided by the board manufacturer. I misspoke earlier. I'm not sure exactly what version of the firmware they modified for the thermocouple I'm using.
Re: 2nd layer not printing on first
October 13, 2010 11:26PM
I tried printing it again and let it go a little longer. It seems to be orbiting arount the object between layers and as it orbits it moves further in the Y direction.

I'll try deactivating the cool section in skeinforge. I noticed it was on. Most of the other section I have turned off.
Re: 2nd layer not printing on first
October 14, 2010 06:38AM
To test if you are missing steps write some g code of your own to test the motion of the system only. Try moving in a square, again and again. Attach a sharpie and write on paper, You will see if things are off.
Missed steps "look" like what you are describing, and have many many causes. Biggest one would be mechanical interference, check all axis for smooth motion with belts disconnected. If you have things set up this way you can swap the x axis driver for the y and see if the problem follows the driver or the axis/motor.
Re: 2nd layer not printing on first
October 15, 2010 01:18PM
All the axis appear to move without interference. Sine I'm new to this, there may be something I'm missing. I'll run the test you suggested and If I results show my square moving around on the build platform, I'll swap my X & Y controller boards and see what happens. I have an extra stepper motor that is the same model as the X and Y so I can swap that out too. The only issue with that is that the gear is pressed on the shaft pretty tight and I don't have an extra one of those. I'll also check to see if maybe the shaft is spinning inside the gear a bit. It is a pretty tight fit but you never know.
Re: 2nd layer not printing on first
October 15, 2010 01:41PM
Missing steps are rarely the result of the motor (assuming it is correctly sized to the application), but you never know winking smiley There are a lot of variables that can cause missed steps, motors not rated to put out the torque needed, being run too fast, poor power supply, bad connections, the list is very long.
The tests I describe will tell you if you are missing steps, swapping the board tells you if the problem follows the specific driver, which may help isolate the problem.
Re: 2nd layer not printing on first
October 15, 2010 05:28PM
When I was setting my lasercut machine up, I had just press-fitted the pulleys on the motors. They felt extremely tight (I used a vice to press fit them). When I tightened the X belt too much however, the X pulley would slip on the motor shaft. If you are getting a bit of slip, that might explain it?
Re: 2nd layer not printing on first
October 19, 2010 11:38PM
I've run some tests now.

It looks like I'm loosing some steps in the Y direction. I printed a 40mm box with a shparpie attached to my tip. I started at Home for the X and Y axis, moved to X30, Y30 then just this X70, Y70, X30, Y30 to do 10 rounds of the square.

I got what looked like a ladder with right at about 5mm seperation between the rungs. I tried both the RepSnapper and the RepRep Host software with the same firmware. The RepRap did a better job, still getting a ladder affect though, but all of a sudden the Y axis went all the say and I had to shut off the printer to stop if from hitting the end.

I marked the end of my pulley and shaft and I'm not getting any slippage there.

Here is what it looked like.

| |
| |
| |
| |
| |
| |
| |

(ok my attempt at a diagram didn't turn out so good. It keeps displaying the right border next to the left if there are no dashes)

It should just be a square.

I seems to hesitate in the Y direction on the rounds where it shifts the border down.

I have not swapped out stepper boards yet. Maybe I can do that tomorrow.

Any Ideas?

Edited 1 time(s). Last edit at 10/19/2010 11:56PM by bbriggstkd.
Re: 2nd layer not printing on first
October 20, 2010 08:25PM
I swapped out the stepper board and got similary results. I'm trying different firmware version.
Re: 2nd layer not printing on first
October 20, 2010 09:02PM
Does the shift follow the motor or the driver? If it's not the driver then look at your mechanicals and motor. If you swap motor cables and the problem stays on the same axis, my first guess would not be software.
Re: 2nd layer not printing on first
October 20, 2010 09:15PM
Koko76 - I'm not sure what you mean by your first statement. "Does the shift follow the motor or the driver?" By driver do you mean the stepper controller board?

Both stepper boards hesitate at time. By that I mean the platform is moving in the Y direction and it just stops for a second or 2. The lights on the board that flash when the step signal is sent stop flashing. It looks to me like the signal is getting stopped. This happens with different host software, and different firmware. That seems to me to be a hardware problem.

I had thought about the cable, I haven't had a chance to try that yet. I'll post again when I know more. I also have a spare motor I can hook up and see if it keeps moving. However, if the stepper board is stopping, then it shouldn't be the motor.
Re: 2nd layer not printing on first
October 20, 2010 09:43PM
I swapped the X and Y axis cables from the motherboard and got the same results. X axis is working fine but I'm loosing steps in the Y axis.
Sorry, only registered users may post in this forum.

Click here to login