Welcome! Log In Create A New Profile


reprap software help

Posted by hazuki 
reprap software help
October 15, 2010 11:44PM
Hi all.

I am using the reprap software with the 5D firmware on the Gen 3 boards. I have everything set up and I am able to move around the axes. However, the extruder stepper does not actuate when I click the Extrude button in the Extruder tab. I am able to see the current temperature and I can turn on the heater just fine. I notice that the program locks up most of the time after I hit the extrude button and I get an error:

ERROR: bufferQueue(): too many retries <4> sending M105

I have tried rolling back to JRE 5 as suggested in the setup guide. However this does not fix the problem. Does anyone know what the problem could be?

Also, I notice that if I click on a button while a command is in the process of being executed (moving an axis) the program will lock up. Is the software supposed to be this buggy?

Re: reprap software help
October 16, 2010 06:55AM
maybe you have done this but to drive a stepper you need two extra cables going from your motherboard to your extruder board, check out the wiring diagram.
Re: reprap software help
October 16, 2010 12:05PM
Ah, I did not notice this! I'll try it out. Thanks!
Re: reprap software help
October 16, 2010 01:23PM
Ok. I've connected a 4-wire cable from the I2C port on the motherboard to the I2C port on the extruder controller. I am still able to get the extruder stepper moving however. I figured out that the java interface only crashes if I hit the extrude button too frequently.
Re: reprap software help
October 16, 2010 06:26PM
I am looking at the schematic here: [objects.reprap.org]

I see that SDL and SDA are connected to D9 and D10 on the extruder controller. On my extruder board, D9 and D10 are two three pin connectors that are apparently Servo connectors. Am I supposed to connect SDL and SDA on the motherboard to these pins? Right now I have SDA connected to SDA on the extruder controller and SDL connected to SDL on the extruder controller.
Re: reprap software help
October 16, 2010 06:56PM
Been there, done that (and many, many more with us), the schematic is correct, yes. SDA/SDL are step/direction OUT pins on both the motherboard and extruder controller. D9 and D10 are the step/direction IN pins to use on the extruder controller.

Blog with RepRap Comic
Re: reprap software help
October 16, 2010 07:51PM
That worked! Thanks!
Sorry, only registered users may post in this forum.

Click here to login