Welcome! Log In Create A New Profile


X axis keeps pausing mid-print, I've tested everything I can think of

Posted by stoof 
X axis keeps pausing mid-print, I've tested everything I can think of
May 10, 2016 08:54PM
This problem has been destroying me from the inside. I'm reposting from a thread I started in Reprappers because I want to try this again.

MendelMax 1.5, 8mm chromed rod pair with self-align bronze bushing x-axis
RAMBO 1.3 electronics
Repetier Firmware 0.92 (same issue when running 1.0 dev version)

X-axis will momentarily pause mid print and lose position. All other axis, such as extruder, continue to function during x-axis pause.
I've only managed to witness the issue happening a handful of times because it does not happen often, but it got progressively worse over time and would happen more often in a given time frame. More on that below.
The pause itself is silent, no grinding from the stepper or any sign of life at all. Then anywhere from 1 - 5 seconds after the motor stops, it resumes as if nothing happened. Always takes at least 30minutes or so before a problem is likely to happen, but it can go 2 hours before a problem happens. No apparent nozzle dragging, catching, axis binding, power failure that I can identify.
NO other motor is displaying any similar problem.

Possibly related background:
In January I pulled my printer out of storage after not using it for a while. I used to run a RAMPS board but switched over to a RAMBO, which has been working fine since January. This issue with the X-axis has only come up within the past 2 weeks and has become very common. Something that is worth noting is my X-axis is extremely noisy! It vibrates like crazy. I have been completely unable to isolate the source of the vibration, is it possible it is coming directly from the stepper? I never had these vibrations on the X-axis before and I have no idea when they started. I can dampen the vibration temporarily by putting some finger pressure on the x-carriage, which dampens maybe 80% of the vibration. Vibration seem to be completely dependent on the speed the motor is rotating at, faster speeds seem to vibrate less than some of the lower speeds, but there definitely seems to be some type of resonance going on. I'm not sure if this is because my bronze bushings have worn out and now vibrate against the rods, but I've ordered replacements to give that a shot. Also, the noise coming out of the stepper almost sounds like it has multiple tones, I've read an underlying low-frequency noise could indicate skipped microsteps? Then again, at some speeds the stepper sounds normal.

Tests and Observations:
-Swapped X-axis with E2 driver via firmware pins, physically switched connection on board. No change, X-axis still sometimes loses position mid-print.

-Added cooling fan to RAMBO drivers. No change.

-Reduced current for X-axis via firmware digipot. Was originally at 55%, was running pretty hot to the touch. Reduced as low as 30%, am not at 40%. Running warm but not burning hot. No noticeable change.

-Swapped X and Y axis via firmware, did not switch connectors on board. X and Y are now effectively swapped. Same motor/axis loses position.

-With X and Y swapped via firmware, I switched the connectors on the board. X and Y are no back to usual configuration, but driven with different drivers. Same motor/axis loses position.

-Wiggled and tugged X-axis board connector to try and make motor cut out, but it did not, so I don't think it was a connector issue. I also added a tiny bit of solder to the crimps just to ensure a good connection.

-Reduced acceleration, Raised acceleration. Tried a whole range of speeds and motion, no noticeable change.

-Tested X-axis alignment by removing the belt and moving axis by hand, movement is very smooth. Replace belt and test by turning stepper by hand (disconnected from board). No noticeable binding.

At this point it was looking like it was a bad stepper motor, since I ruled out a faulty driver IC.

-Replaced X-axis stepper with another one I had lying around. PROBLEM WENT AWAY. For a while. Problem came back after a couple of days. I replaced it a 3rd time with my final spare stepper. Problem went away but only for about a day.

-After one print failed, I reduced the feedrate to 80% in Repetier Host. I was able to finish a couple of prints with a reduced speed, much lower failure rate.

-It's hard to say for sure, but it almost looks like most of the failures are happening on long straight perimeters on the X axis. Suppose I was printing a box with 40mm side walls. It almost seems like the motor is most likely to fail when travelling in the X direction around 60 - 80% towards the end of the perimeter, aka, it would print about 30mm of a perimeter in the X direction then pause and lose position. It also almost seems like it's more likely to fail when travelling in the -X direction. This is kind of speculative because I've only been able to witness the problem first hand a couple of times, but it always leaves a blob of plastic where it pauses because the extruder keeps going like nothing ever happened.

-I was originally running Repetier 1.0 (dev version), so I tried going back to 0.92 (stable). Did not fix the issue.

-I briefly considered if there was any way a bug in the slicing (Slic3r) could cause this, but I don't think it would lose position if this was the case.

What I haven't been able to do is observe the stepper during failure. I'd like to know if it is receiving control signals during failure or if the motor is de-energized. This would be a good bit of effort to set up a rig like this, so I'm trying all of you out first. I'm so frustrated, I could extrude plastic out of my ears. Can anybody chime in as to what might be the most likely source of error? Is this a common trait of stepper failure? Why would the steppers be failing? Could it be related to the vibrations? Is there any chance this could be a firmware issue? Will I ever have a working printer again???
Re: X axis keeps pausing mid-print, I've tested everything I can think of
May 11, 2016 05:31AM
It sounds to me that you have done all the right things and eliminated the most likely causes i.e. overheating or faulty stepper driver. Here are some other possible causes:

1. Slipping motor pulley. If the pulley grub screw isn't tight on the motor shaft, it can lose position. If the motor shaft doesn't have a flat on it, then I suggest filing or grinding one on.

2. Binding in the X axis mechanism. Something (e.g. a motor or a bearing) may be occasionally locking up until the direction is reversed, causing loss of position. Stepper motors can lock up in this way, the usual cause is a piece of swarf in the motor, which you can fix it yourself by dismantling the motor, brushing out any swarf or dust, and reassembling it. But you changed the motor already. I don't know whether bearings can fail in this way too.

3. You say that the X axis has a lot of vibration. Could that vibration be causing the belt to snag on something?

4. I had a similar problem once when printing a long straight edge that had a lot of small horizontal holes in it. So the head had to print a of of short line segments with gaps in between, which was fine. The problem came when the head did a travel move right along the line. The segments had very slight curl up due to the overhang, and the head was catching on those curl ups during the travel move.

I think you need to investigate the vibration in your X axis, because it is probably related. Do you have the correct belt tension? Does the belt tension remain constant as the head moves along the X axis? If you use linear bearings on the X axis, are they a good fit on the smooth rods, and have you tried replacing them?

HTH David

Edited 1 time(s). Last edit at 05/11/2016 07:44AM by dc42.

Large delta printer [miscsolutions.wordpress.com], E3D tool changer, Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: X axis keeps pausing mid-print, I've tested everything I can think of
May 11, 2016 06:36AM
swarf in a lm8uu type bearing can cease a ball or two causing excessive drag and missed steps... and it can be randomly occurring

Edited 1 time(s). Last edit at 05/11/2016 06:40AM by Dust.
Re: X axis keeps pausing mid-print, I've tested everything I can think of
May 12, 2016 05:53PM
The belt is definitely not slipping, set screw is tight. Doesn't seem like the axis is locking up, very smooth movement. Also, I don't have bearings, I'm using bushings.

One thing I realized is I've tightened my belts recently and it seems the tighter belts cause more vibrations to be transfered to the axis. I lowered the tension and the vibrations are much better. I have read about problems with over tensioned belts causing problems, I've tried to find as much info as I can but haven't come up with anything. Does anybody know any info about overtightened belts? Could it possibly cause failure in the stepper?
Re: X axis keeps pausing mid-print, I've tested everything I can think of
May 12, 2016 05:57PM
When all else fails, try reflashing the firmware on the controller board. Many mysterious problems have been solved that way.

Ultra MegaMax Dominator 3D printer: [drmrehorst.blogspot.com]
Re: X axis keeps pausing mid-print, I've tested everything I can think of
May 12, 2016 06:29PM
A curious issue indeed! As DC42 mentions, you have done all the right things so far.

The original MendelMax 1.5 design had some issues with belt setup on both X and Y axis. If belts were too tight they would pull the motor or idler bearings around and away from a parallel path/track. Is the vibration (that reduces with less belt tension) possibly related to this, ie the belt is scuffing/catching the bearing or pulley sidewall.

Overheating driver - possibility, but you have a fan on electronics?!?! - dont discount that you might have so much load that the fan doesnt cool it enough. That the issue occurs after a little while of running, does suggest something to do with heat. I would say there is a possibility that the driver is hitting thermal cutout, cooling off a bit, then kicking back in. A cause of this could well be some sort of excess friction, ie bushings, or belt related friction.

If you increase current further this might offer a clue depending what happens. The increased power might induce a quicker occurance of the issue pointing to thermal cutout - which in turn may point to excessive load due to friction causing problem (thinking aloud).

Do update on progress.
Re: X axis keeps pausing mid-print, I've tested everything I can think of
May 13, 2016 01:31PM
Wow, that's a tough one. As stated above you've done everything I would have done and more to troubleshoot this problem. You have eliminated drivers and steppers seemingly. Is the stepper cable separate or hard wired? If separate have you swapped cables independently from the stepper motor? I only ask because there is no specific mention of changing cables, but with everything else you've done I doubt it's the cable.

How about spurious reads on the X axis end stop? Is the firmware by chance set to read the end stop during a print? (most default to ignore but it's worth a look)

Just for fun you might try moving to Marlin firmware for a test just to rule out a persistent bug in Repetier.

Maybe twisting wires for stepper motors or adding a ferrite to the cable? (shot in the dark)
Re: X axis keeps pausing mid-print, I've tested everything I can think of
May 14, 2016 03:04PM
Mutley- yeah, I've recently realized the issues with MM1.5 X axis, too much leverage on those belts mess with the axis alignment. I had noticed my x belt becoming loose in the past and figured it was two possibilities: crappy MM1.5 rod clamping was slipping or belt clamp on my carriage was slipping. Just to be safe I ordered a set of 8mm rod clamps to act as stops to keep my x ends from sliding in ala . Even with these, I noticed if I push on the x belt my x axis ends start twisting. Dont think this has anything to do with the vibrations, I added those recently and the vibrations started way before. Loosening the belts reduced the vibrations a ton, not sure what that has done to the print quality though. As far as I can see, belt is not dragging or doing anything weird to the pulleys or motor. As for overheating, it's hard to believe that is the issue at this point for so many reasons, I've even stuck a thermocouple on to compare temperatures and it's hotter than any other driver. Recently I tried increasing the current a bunch and thought it miiiight have made the problem worse, but I couldn't be certain and would have needed to try a couple more comparisons to be sure.

Bryan- Steppers are hard wired, plus after 3 motors it's hard to think its the cable. As for the endstop, I'll try and hit it mid print to see if that will do anything. I really do hope it's a problem in Repetier, it would help me be a lot less insane!!!!!!!! I'm going to have to try a switch back to marlin just to be sure.

At this point I'm thinking it is something to do with the over-tightened belts, but I'm trying how that could be causing it. I'm still not 100% sure that it is a motor failure problem, but that seems to be the most probable. So if it IS motor failure, is it mechanical or electrical? Etc, etc.

Now that I've reduced the tension on the belt, I've decided to order one more motor (fml) and see if the problem persists. If it doesn't, it's got to be the belts and I'll just leave it at that. If it's not that, well then, fml.
Re: X axis keeps pausing mid-print, I've tested everything I can think of
May 15, 2016 08:34PM
this happened to me after tensioning the belt during a print got the y axis too tight and things stopped during mid print for about 20 seconds possibly not enough current to the stepper to overcome the added load
Re: X axis keeps pausing mid-print, I've tested everything I can think of
May 15, 2016 09:09PM
I tend to agree that it's not likely to be a stepper, and it is likely to be heat-related. I'd have guessed the driver, but you swapped X & Y over and it still affected the X axis.

Another thought is an almost-broken wire in the X-axis, which only disconnects in a particular X/Y/Z position. I think you've ruled that out too. But anyway, perhaps check for wires flexing, particularly at the X axis motor.

Another thought is the power-supply. If it's marginal, anything could happen.

To save plastic and maybe make the problem happen more often, you could generate G-code to just move in the X axis.

e.g. repeat the following lines a few hundred times...

G0 F9000 X10.000 Y50 Z10.000
G0 F9000 X100.000 Y50 Z10.000
Sorry, only registered users may post in this forum.

Click here to login