Welcome! Log In Create A New Profile

Advanced

Cooling Fans cause print stutter / slow motion

Posted by andy2605 
Cooling Fans cause print stutter / slow motion
July 27, 2016 03:50PM
I am hoping someone might able to help with a strange problem I am having with my Prusa i3 using Arduino Mega and Ramps 1.4.

I have built and connected my version of the MightyFan using INFINEON BSO150N03MD G Dual MOSFET, Dual N Channel, 8 A, 30 V, 0.0125 ohm, 10 V, 2 V. The mightyfan works fine, i wrote a quick test sketch for the Arduino to drive all 4 outputs with PWM from 0 to 255 in 25 steps. The 2 50mm fans i have setup for cooling werent too happy with anything less than 70% ON time, but that is down to the fans.

The problem I have with either Cura or SLic3r / Repetier-host, is that if the fans are set to come on at anything less than 100%, as soon as the fans are triggered by the g code the printer stutters and seems to go in slow motion and only a hard reset / emergency stop gets it working again.

I am trying Cura 15 tonight and had the cooling fans ticked. on the 3rd layer the fans came on at 33% and the print went into slow motion / stutter.

I am using Marlin 1.1.0-RC4.

I am at a loss why less than 100% on a PWM pin is causing this...

Any help greatly appreciated
Re: Cooling Fans cause print stutter / slow motion
July 27, 2016 03:58PM
What size is your powersupply and are you running a heatbed? Just reading your description, it sounds as your powersupply isn't large enough when the fans kick on and so your steppers and controller become under-powered in a brownout state.
Re: Cooling Fans cause print stutter / slow motion
July 27, 2016 03:59PM
I am running a MK3 PCB 12v heatbed and a 33A 12v power supply.

Seems strange that it prints fine with the fans on at 100% but not at anything less?
Re: Cooling Fans cause print stutter / slow motion
July 27, 2016 04:02PM
Could be a processing limit on the PWM, as soon as it's trying to do anything besides full power.
Re: Cooling Fans cause print stutter / slow motion
July 27, 2016 04:07PM
Is there anyway to turn off pwm on that pin? or overcome the processing limit?

or tell Cura only use 100%
Re: Cooling Fans cause print stutter / slow motion
July 27, 2016 04:47PM
0% and 100% would be no PWM or full voltage. Anything in-between would be some cycle load on the processor, so if you told Cura to use 100% fan, then you'd probably be ok as far as running the fan without the slow and stuttering.

One other thing to ask would be what LCD if any do you have on the Ramps / Mega? I've heard of people having processor issues with these graphic displays. You could disable/turn-off a graphic display (if your using one) and then see if you can do something between 0-100% without seeing the stuttering to know for sure your hitting a processing limit.

Edited 2 time(s). Last edit at 07/27/2016 04:49PM by PDBeal.
Re: Cooling Fans cause print stutter / slow motion
July 27, 2016 04:55PM
I have the red PCB reprap discount full graphic display. I will try without it and see if that works. Still have an issue with the SD reader on it but that is another issue to fix.
Re: Cooling Fans cause print stutter / slow motion
July 27, 2016 05:48PM
I have disconnected the full graphic LCD and turned it off in the firmware.

No difference. The only way to get cura to handle the cooling fans is set them to come on at 0.0 height and 100%.

I am running the auto fan for the extruder cooling but that is set to max when it comes on at 50 deg C.
Re: Cooling Fans cause print stutter / slow motion
July 27, 2016 07:33PM
It could be an interference issue, try twisting the fan wires together or running them away from where they are now. A fan at 100% is powered by DC whereas when PWMing the power is being chopped and will introduce high frequency harmonics that can radiate more.
Re: Cooling Fans cause print stutter / slow motion
July 28, 2016 02:34AM
Perhaps the PWM pin you have chosen to use is controlled by a timer that the firmware is already using for stepper motor timing or something else. Try using a different PWM pin.



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Cooling Fans cause print stutter / slow motion [SOLVED]
July 29, 2016 03:23PM
Thanks for all the suggestions and help, I have solved the issue.

in the pins_RAMPS_14.h file I commented out the 3 lines for the servos

//#define SERVO1_PIN 6
//#define SERVO2_PIN 5
//#define SERVO3_PIN 4

and changed the fan pin from 11 to 6.

#elif MB(RAMPS_14_EEF) || MB(RAMPS_14_SF) || MB(RAMPS_13_EEF) || MB(RAMPS_13_SF)
#define FAN_PIN 6
#else
#define FAN_PIN 6 // IO pin. Buffer needed
#endif

the fans now come on and the print continues when using Repetier-host and Cura 15.
Sorry, only registered users may post in this forum.

Click here to login