Welcome! Log In Create A New Profile


print stopping with error message "mintemp triggered"

Posted by mitch25 
print stopping with error message "mintemp triggered"
September 06, 2017 09:55PM
everytime I start a print, after a few hours (almost always after the same amount of time) the print is halted because it says the extruder has triggered the mintemp but right before i get the message that the mintemp has been triggered by the extruder, there are a series of "cold extrusion prevented" until it shuts down. The other weird thing happening, is that sometimes, the extruder temperature drops, and shows in the log two lone "cold extrusion prevented" both registered at the exact same time, and then its back to normal again.
I've changed the thermistor and it still happens, so would anyone have any further insight on this? is my heater cartridge bad?
Re: print stopping with error message "mintemp triggered"
September 06, 2017 09:57PM
what temperature are you printing at and what temp is the min temp warning set to?
Re: print stopping with error message "mintemp triggered"
September 06, 2017 11:31PM
Check the wires to the thermistor... if they flex, the conductor inside can break, even though the insulation is intact. Then, when the hot-end is at a certain X,Y,Z position, the wires will be stretched enough for the conductors to separate at the break. At this point, the control board suddenly sees a zero temperature and aborts the print. I would get the hot-end up to temperature and then move it around with keyboard controls, watching the wires for flexing, and the temperature graph. You could also try pulling/twisting/manipulating the wires to see if you can cause the break to recur. Or you could just replace the thermistor... they're cheap.

Also check that your thermistor is held properly in place in the hot-end. It could be that at a certain X,Y,Z position, the wires to the hot-end are strained a little to pull the thermistor out of its hole.

It could also be your heater cartridge; the same things happen to it. If the temperature drops *suddenly*, it'll be the thermistor; if it drops gradually it will be your heater cartridge.

The long-term solution to all of these is to firmly attach the wires to the hot-end, so that any flexing is done by the whole wire bundle rather than individual wires. Same goes at the other end of the wire bundle.
Re: print stopping with error message "mintemp triggered"
September 07, 2017 02:37AM
I'm printing at 240 C. And my Mintemp is set to 5 in marlin.
Re: print stopping with error message "mintemp triggered"
September 07, 2017 02:41AM
Thank you, will try moving the XYZ axes with the temperature on, and will look for breaks.
But i realized, when i saw that my mintemp was set to 5 in marlin, that it's not possible that it's getting triggered, because room temperature is 35 C. So does this point at there being something wrong on the side of the temperature measurement?
Also, I looked at the log, and in some places, the temperature would drop gradually about 60 degrees, and then go back up to normal. And in other places, the temperature would drop from being fine, to triggering the mintemp error.
Another weird thing, is that, if the temperature was dropping gradually, and my motherboard constantly supplying current to it, without it heating up, there should be a "Heating Failed" error (which works, when i tested it outside of a print) but which doesnt show up! what could be going wrong?
Re: print stopping with error message "mintemp triggered"
September 09, 2017 10:29PM
35C room temp? eye popping smiley I guess you're not in Alaska then!

In that case, a mintemp means (in descending order of probability):
  1. A thermistor wire is broken, or maybe disconnected from the board.
  2. Maybe power supply is too weak, which can cause intermittent issues.
  3. The Or the firmware is screwed?
  4. The controller board itself is broken?
  5. Hell has frozen over grinning smiley
Re: print stopping with error message "mintemp triggered"
December 15, 2017 05:19AM

I am experiencing the exact same issue. Namely, after the printer has been printing for a few hours without any issues when suddenly the nozzle temperature readings become more-and-more unstable (see octoprint screenshot) to the point where after 15 minutes "MINTEMP triggered" error is thrown. The error is fully reproducible and each time occurs around the same time into the print. Otherwise the printer has no issues (and print smaller stuff just fine). The problem seems to be temperature related as after resetting the board, attempting to print cause the same error almost immediately (within minutes). I tried wiggling the temperature sensor cables but i cannot seem to be able to cause any disconnects or false readings.

My printer is an alu extrusion build of ultimaker 2, i am using original ultimaker hotend but with PT100 probe replaced by E3D thermistor cardridge (recently bought from reprap.me) I am running latest Marlin 1.1 on top of MKS GEN 1.4 with DRV8825 drivers. I did previously have issues with PID autotuning and found that i needed to set BANG_MAX to 128 for the autotuning to complete.

open | download - IMG_0065.png (446.2 KB)
open | download - Configuration.h (64.3 KB)
Sorry, only registered users may post in this forum.

Click here to login