Welcome! Log In Create A New Profile


Heated Bed/Power Supply Troubleshooting

Posted by TheDarkGekko 
Heated Bed/Power Supply Troubleshooting
April 02, 2018 07:32PM
Hi all,

First time post, so admins please accept my apologies if this is a) already covered and I just haven’t managed to find it, or b) if I’ve put it in the wrong place.

I’ve got a BQ Hephestos Prusa i3 printer that’s about 3 years old, now running Repetier firmware. It’s equipped with a mk2(a?) heated bed and a 203W Xbox 360 power supply, again both supplied by BQ as part of the original kit. It’s been used regularly, but not intensively, for most of its life, without issue until yesterday when the PSU started showing a fault light when powering the heated bed. The first time it happened it was 5 minutes into a job, but now it cuts out when the bed approaches ~50°C.

I’ve tried heating the extruder on its own, and it can reach and hold 200°C without problem. Likewise running the print job on a dry run (I.e. without extruding or heating the bed) seems to be fine. However heating the bed, either through a GCODE file or a command from Pronterface causes it to cut out.

So far I’ve checked the connections and resistance of the bed and cables (~1.2 ohms), the functioning of the thermistor (good compared to an IR thermometer), the output voltages of the disconnected power supply (~12V at the RAMPS connector) and the continuity of the RAMPS fuses (ok), and nothing appears to be amiss. There’s been no unusual smells, smoke or obvious signs of failure from the electronics, and everything otherwise appears to be functioning normally.

I know the Xbox power supply is at its limits for this setup, but historically it hasn’t given me any problems. Is this just indicative of an ageing power supply giving up the ghost, or is there something potentially wrong elsewhere? Are there any other checks I can do to try and identify the fault before I start buying new power supplies, heated beds etc? Any advice gratefully received!



Edited 1 time(s). Last edit at 04/02/2018 07:35PM by TheDarkGekko.
Re: Heated Bed/Power Supply Troubleshooting
April 02, 2018 08:10PM
The 1.2ohms resistance of the heatbed is the ideal reading for 12v application.
It might be a simple case of Power Supply degradation. It may not be able to output 100% of nominal power (203W) anymore.
Unfortunately I do not know of a simple way of checking Power Supplies.

Proud owner and maker of build from scratch FDM 3D printer [forums.reprap.org]
Re: Heated Bed/Power Supply Troubleshooting
April 07, 2018 04:15AM
Hi Rossos, thanks for getting back to me.

I think you’re right, the PSU just can’t output enough any more. Since my last post I’ve tried powering the heatbed directly, using RAMPS to monitor the temperature, and on its own it can reach 60 without a problem. The MOSFET appears to be fine: again with everything apart from power, USB and thermistors disconnected the MOSFET responds correctly to software commands (LED turns on and off, 12V/0V shown across the heated bed output terminals).

Looks like a new PSU then! From what I’ve read I think it’s time to change to a slightly better specced ATX type. It could probably do with a rebuild too: clean up the wiring and improve some seriously questionable soldering...
Sorry, only registered users may post in this forum.

Click here to login