Welcome! Log In Create A New Profile


Inductive sensor won't stop Z axis

Posted by ChrisLCuddihy 
Inductive sensor won't stop Z axis
April 16, 2018 02:08PM
My newly installed inductive sensor does not control the Z axis.
1. The led illuminates when a steel ruler is place underneath it.
2. It responds to M119 correctly. When no steel ruler, returns OPEN. When steel ruler, returns TRIGGERED.
That tells me that the sensor is working and communicating with the board. (GT2560, rev A +). The issue is the Z axis does not respond to the triggering of the sensor, regardless of the direction the axis is moving. It just keeps going until it crashes into the bed.

Any ideas?
Re: Inductive sensor won't stop Z axis
April 16, 2018 05:26PM
Hi chris

I had the same problem that I didn't got an inductive sensor reliable working with an an aluminum heatbed and a pertinax on top of it.
Tried also an simple optical sensor, the same issue. Some times it worked, sometimes it crashed the nozzle into the bed.

The BLTouch is working reliable and this is what I am using today.

I want to move over to Piezo Disk. There is a longer thread here.
They are installed, but I still need a nozzle whipper/brush. Obviously when you measure with the nozzle you need a clean one.
The BLTouch has a big offset (17mm to the left and 40 mm to the front). What the piezo I can measure with the nozzle with no offset.
Not sure whether it makes a difference, but I will give it a try

Re: Inductive sensor won't stop Z axis
April 17, 2018 01:55AM
There is a difference between Z-endstop and Z-probe in firmware.
Make sure, M119 shows Z-endstop triggered when you intend to home and Z-Probe is triggered when you want to do AutoBedLevel.
You can tell Marlin, that the probe and endstop are the same sensor, but that requires to reflash the firmware.
Sorry, only registered users may post in this forum.

Click here to login