Welcome! Log In Create A New Profile

Advanced

Java problem

Posted by Auzze 
Java problem
November 05, 2010 08:00AM
HI..

I'm running the lastest java on my Win7 64-bit system and I keep getting this problem

C:\Windows\system32>rem Amount of RAM to allow Java VM to use

C:\Windows\system32>set REPRAP_RAM_SIZE=1024M

C:\Windows\system32>rem reprap.jar file and stl file

C:\Windows\system32>set REPRAP_DIR=C:\Program Files\Reprap

C:\Windows\system32>rem Java3D and j3d.org libraries

C:\Windows\system32>rem set JAVA_LIBRARY_DIR=C:\Program Files\Reprap

C:\Windows\system32>rem cd so we can find the reprap-wv.stl file. Can we avoid
this??

C:\Windows\system32>IF NOT EXIST reprap-wv.stl cd "C:\Program Files\Reprap"

C:\Program Files\reprap>java -cp ".\reprap.jar;.\RXTXcomm.jar;.\j3dcore.jar;.\j3
d-org-java3d-all.jar;.\j3dutils.jar;.\swing-layout-1.0.3.jar;.\vecmath.jar;." -X
mx1024M org/reprap/Main
'java' is not recognized as an internal or external command,
operable program or batch file.

C:\Program Files\reprap>if ERRORLEVEL 1 pause
Press any key to continue . . .

Now I run 2 other java programs with no problems but reprap just don't want to run, can anyone help, java is not my cup of tea.

Thanks
Auzze
Re: Java problem
November 05, 2010 08:19AM
This is a DOS (or command) shell message telling you that it could not find a java.(cmd|com|bat|exe) program to run.
This means that java is not in your PATH statement!

Either ADD the java directory to your path OR

Change the batch file to include the full path where java is installed i.e. instead of
java -cp ".\reprap.jar;.\RXTXcomm.jar;.\j3dcore.jar;.\j3
d-org-java3d-all.jar;.\j3dutils.jar;.\swing-layout-1.0.3.jar;.\vecmath.jar;." -X
mx1024M org/reprap/Main
use
"c:\Program Files\Java\jre6\bin\java.exe" -cp ".\reprap.jar;.\RXTXcomm.jar;.\j3dcore.jar;.\j3
d-org-java3d-all.jar;.\j3dutils.jar;.\swing-layout-1.0.3.jar;.\vecmath.jar;." -X
mx1024M org/reprap/Main
Making sure of course that it is the proper path to JAVA on your system.


Bob Morrison
W├Ârth am Rhein, Germany
"Luke, use the source!"
BLOG - PHOTOS - Thingiverse
Re: Java problem
December 06, 2010 01:35AM
This may actually solve a long running issue I have had with the RepRap host and Java 6, just going to try it out now to see if it can run.
Re: Java problem
December 06, 2010 01:42AM
Indeed this works, thanks so much.
Sorry, only registered users may post in this forum.

Click here to login