Welcome! Log In Create A New Profile


Updated: recurring problem heaters on Melzi board not working

Posted by mmt 
Updated: recurring problem heaters on Melzi board not working
October 06, 2012 09:57AM
I have Melzi Ardentissimo controller for my Mendel90.
Have the mid board PWR-SEL jumper set for VREG not USB.
Worked fine at first, a couple of days ago both heater controllers wont heat up, thermistors reporting typically H4 B5 and stay at that. Touched the hotend and bed to check they dont heat up. Checked for loose wires, found & fixed one. Still not working.
remove & put back the PWR-SEL jumper. Things then worked. Maybe coincidence.

Now the problem has recurred, fiddling with the PWR-SEL jumper this time doesnt work, also tried swapping with the other jumper , still not working. No signs of loose wires.

All stepper motors work ok.

Any ideas?

Fixed this. Removed the GND connector for the hotend, the bed heater started to work. Replaced the GND connector now they both work.

Nope , next day same problem recurred, out/in with the GND connector this time no good.

In firmware theres a line min temp 5, set to 0 heaters working again.

Edited 4 time(s). Last edit at 10/07/2012 07:41AM by mmt.
Sorry, only registered users may post in this forum.

Click here to login