Welcome! Log In Create A New Profile



Posted by Cain 
April 21, 2011 02:33AM
I have my gen7 board completely built and working so far, and I believe I just burned the bootloader to it. I'm having trouble with the firmware now, however.

I tried Teacup, but I'm not sure I understand the instructions. I downloaded the .zip of all the teacup files, extracted them, then downloaded the config.h.FiveD_on_Arduino file, but am not sure what to do.

I followed the Teacup instructions and copied config.h.FiveD_on_Arduino to the config.h file (CP config.h.FiveD_on_Arduino config.h), then opened the Teacup Firmware file with the Arduino IDE (It wanted to be put in it's own renamed folder, so I had to move everything else into this folder or the file would be blank when opened).

I tried to compile and upload, but I got an error compiling:
In file included from clock.c:7:
/pinio.h:42:20: error: macro "power_off" passed 1 arguments, but takes just 0

Am I even trying to do this right? Is there any official gen7 firmware that I can just open with the Arduino IDE and upload to my board?

Edited 1 time(s). Last edit at 04/21/2011 02:35AM by Cain.
Re: Firmware...
April 21, 2011 04:10AM
No, there is no firmware specific for Gen7. Teacup and FiveD should work with the pin assignments adjusted.

config.h.FiveD_on_Arduino is out of date, unfortunately. Try the one I attach here, it should be at least sufficient to compile and move the motors.

Generation 7 Electronics Teacup Firmware RepRap DIY
open | download - config.h (19.1 KB)
Re: Firmware...
April 21, 2011 10:51AM
I think it works...

I copied the contents of the file you provided and replaced the contents of config.h.dist using a text editor (This is correct, yes?).

I got an error compiling stating that the config.h file could not be found, so I put the file you provided into the teacup_firmware directory, and it appeared to compile correctly....going to upload shortly...

Edit: Ah, I'm stupid (And sleepy). The config.h file is what is actually used, the rest are presets that need to be copied to config.h

So everything I just did was correct... (right?).

As soon as I can get the drivers for my ftdi to usb breakout board, I'll try uploading to the ATmega.

Oh, another thing I'm unsure about (sorry). The bootloader I uploaded to the board was the "Gen7 with 644p and 20mhz".

But in the Makefile, it states
# CPU clock rate
F_CPU = 16000000L
# F_CPU = 8000000L

Should I change F_CPU = 16000000L to 20000000L? Or is changing anything else unnecessary as long as I have "Gen7 with 644p and 20mhz" selected under the arduino IDE?

Edited 3 time(s). Last edit at 04/21/2011 11:03AM by Cain.
Re: Firmware...
April 21, 2011 06:07PM
Arduino IDE ignores the Makefile, so it doesn't matter what you set there when using the IDE. If you upload with "make program", you should indeed set F_CPU to 20000000L.

Actually, this number should match your crystal. Component Kits delivered by me come with a 20 MHz one, many others use the more standard 16 MHz version.

Generation 7 Electronics Teacup Firmware RepRap DIY
Sorry, only registered users may post in this forum.

Click here to login