Welcome! Log In Create A New Profile


Help with ESP8266 on Serial 1 3 for Creality 10S

Posted by 1Ocelot 
Help with ESP8266 on Serial 1 3 for Creality 10S
May 18, 2018 07:42PM
Hello, I think this is the correct area to ask for some help on this.

The board is an older Creality 10S board, they are based on Ramps 1.4. I was able to get the 8266 Wifi module to work on Serial 0 (Had to solder the missing header) and Serial 2 (Used for the LCD) but I was hoping to connect it on the Serial Ports on Y- and Y+ (RX3/TX3) or Z- and Z+ (RX2/TX2). When I connect the module to those pins no communication happens, tried several things recommended by the ESP3D WIFI developer but nothing worked. I then manually held the RX/TX jumper wires to the Atmega legs for the pins and it worked.

So the issue are the resistors, diodes or whatever in between the end stop connectors and the Atmega chip. I do not know anything related to electronics so I do not know how to proceed to get the Serial Port 1 or 3 working without soldering/desoldering things in the Board. In the following picture I circled the 2 components I think are in between the connector and the Atmega.

I tried flashing Marlin Bugfix, Marlin 2.0, Marlin 1.8. Enabling/Disabling pins, flashing a simple arduino sketch sending a . over serial every 10 seconds. Like I mentioned above Serial 0 and Serial 2 work but Serial 1 and 3 used in the End Stops don't work. I was defeated by those 4 SMD components, one is labeled 01C i think and the other is just brown.

Does anyone have any suggestions on how to proceed to get those Serial Ports working? I do not mind soldering things but I would prefer not to modify the board. Thank you
Re: Help with ESP8266 on Serial 1 3 for Creality 10S
May 19, 2018 02:27AM
I believe, those SMD components are for debouncing the microswitch.
Why do you have to use serial protocol anyway? The ESP8266 really gets alive with SPI or at least i2c protocol. Both ports should be available on the board ( but probably not well supported by Marlin )
Re: Help with ESP8266 on Serial 1 3 for Creality 10S
May 20, 2018 11:40PM
I'm using Serial because that's what this ESP8266 firmware uses ESP3D it supports Marlin and it's really simple to get working on Ramps 1.4 and many other boards. The older Creality boards do not have the AUX 1 header soldered in and I'm trying to find a solderless solution to get ESP3D or any other WiFi solution based on the ESP8266 ESP32.

Is there any way of bypass those SMD components without soldering/desoldering on the board to get Serial 1 or 3 working from the end stop pins?


Edited 1 time(s). Last edit at 05/20/2018 11:40PM by 1Ocelot.
Sorry, only registered users may post in this forum.

Click here to login