Welcome! Log In Create A New Profile


Headed bed thermistor issue

Posted by Trappisto 
Headed bed thermistor issue
November 23, 2014 05:38AM
Hi all,

Done a few searches for this already but can't see the specific issue (and have tried some general advice from what I've found).

I'm just commissioning a mono mendel which I bought about this time last year (long build...), and have an incorrect reading from the bed thermistor. According to prontorface the hot end is 17.9 degrees (probably about right), but the bed is 75.7 degrees (I assume this is incorrect). The bed isn't on so it should just be reading ambient. The thermistor seems to register and increase in temperature fine (holding it in my hand causes it to rise).

I've pulled the thermistor out and resoldered it to new wire but get the same result, and there's not a huge amount to be causing a problem. Connecting the pins on the board with a short bit of wire gives me a reading of -273 degrees, and with nothing connected I get -41.4 degrees.

Any ideas what the problem might be?

Any help greatly appreciated!
Re: Headed bed thermistor issue
November 23, 2014 02:05PM
You may have the wrong bed thermistor listed in your firmware. There are several to choose from, each with different tables to identify temperature from resistance. Having the wrong one selected will show the wrong temperature.

MakerFarm 8" Prusa i3v
0.4mm E3D v6 for 1.75mm
Re: Headed bed thermistor issue
November 23, 2014 06:29PM
Check the soldering to conecting for the thermistor on the PCB.
On my PCB the solder had released from the brazing pin.
My PCBs are delivered last summer. Maybe you can have the same error.

Re: Headed bed thermistor issue
November 23, 2014 06:43PM
Also, have you removed the thermistor plug from the board and measured the thermistors resistance at the plug?

Waitaki 3D Printer
Re: Headed bed thermistor issue
November 24, 2014 08:44AM
Cheers for the replies, I'll have a look at it again tonight.

Going to check that firmware first, as it looks like it could be some sort of calibration issue, then will check the board itself. Will let you know how I get on.
Re: Headed bed thermistor issue
November 25, 2014 03:31PM
Update and success:

I switched the two thermistors over where they wire in to the Melzi and got the same readings, only reversed. Spoke to Tech Support and they suggested that the board might have Huxley firmware rather than Mendel, as the Huxley uses two 100k thermistors rather than one 10k one and one 100k one (which would explain the readings being swapped in that last test). Updated the stored thermistor settings via Prontorface, and works fine.

Another effect of the incorrect firmware is that the bed size is off too. Also fixed that in the interface software, although looks like I should re-flash the firmware to make sure everything is correct.

Edited 1 time(s). Last edit at 11/25/2014 03:32PM by Trappisto.
Sorry, only registered users may post in this forum.

Click here to login