Welcome! Log In Create A New Profile


New in the sports heed help.

Posted by Gaou 
New in the sports heed help.
June 19, 2015 10:21AM
Guys Hi . I am Pavlos from Greece and i am a new owner of a reprappro mendel which i cant finish and get to my first build.

Through the whole setup i did had some problems but now i am on the printing and calibrating point where i am dealing big problems with Z probe and the extruder....!

So to get to the point. I cannot probe the z axis and point as i should be . My problem is that the sensor that came with the printer is sitting far from the table so at the point the hot end is touching the bed i am getting low resistance readings (<200).

I got a soultion on there lowering the sensor ( it had two holes for attaching on the acrylic) i lowered it down and used only one screw to attach it . That kind of fixed the problem but i would like to know what is the proper way to attach the sensor? The proximity sensor works ok but it cant get down enough to get reading more than 400.

Also i had my bad times with the hot end and the extruder but now it seems they are working. But when i am sending the 150x150 calibration file then every now and then the extruder kicks some tooth back (ccw) . It seems it trying to extrude some pla but it cant.

Upon that when i am extruding through the software all seems pretty ok. So do you have any clue of what it might be the problem there.

3rd question . Guys i am getting two values when i am sending a G31 command . Which one do i have to trust and use ?

Nice being among this community guys and i hope soon enough to able to print my own prints.

Any tips guys would be very much appreciated.
Re: New in the sports heed help.
June 19, 2015 02:43PM
Things are sorted out from Mr Ian. But after a firmware update i cant set the hot end temp as it keeps respong "no tool selected" Any idea ?

ok i have send T0 and it is ok now. DO i have to add the T0 to the config file ?

Edited 1 time(s). Last edit at 06/19/2015 03:44PM by Gaou.
First prints poor quality
June 26, 2015 06:27AM
ok guys i have printed my first prints but i am getting poor quality at the bottom ( first layers ) . i am attaching some photos .

I also have a problem with the hottend as i am getting "no tool selected" after my last update to firmware. I have to set T0 but the problem is that i have put it in the config file and still i have to send T0. I think that writing this down to the config would solve the problem but it didn't.

Also i getting the pla warping at the ends . WHat would be the cause for that . Is there any solution ?
open | download - IMG_1444 (1).JPG (127 KB)
open | download - IMG_1445 (1).JPG (76.3 KB)
open | download - IMG_1446 (1).JPG (87.3 KB)
open | download - IMG_1447 (1).JPG (107.9 KB)
open | download - IMG_1448 (1).JPG (112 KB)
Re: New in the sports heed help.
July 01, 2015 06:50AM
Hi Pavlos

Adding T0 to your config.g may, or may not, help. It depends what tools numbers are specified! If you have updated your SD card with the SD Image supplied with the firmware (and you ALWAYS should use the same SD Image AND firmware version), the first hot end is defined as T0. However, if you are using your old config.g, the first hot end may be defined as T1. You need to understand how to define tools and set this correctly; see this section in commissioning: [reprappro.com]

Ideally, you shouldn't put a tool change in your config.g; the technical reason for this is because if there are any macros (other commands that happen) that run on tool changes, these are ignored if the hot end is called in the config.g.

If you are starting a print, and it says 'no tool selected', you probably have the incorrect tool defined, or the gcode does not set the correct tool. Check your config.g as above, then check the gcode. If you are using our Slic3r profiles (see point 4 below), it should select T0 in the first 20 or 30 lines of the gcode (open it in a text editor - all gcode files are text files). If you are using old profiles, it may put in T1, or if you are not using our profiles, it may not put any 'T' command in at all.

Regarding your prints, I would say they are good, for the first attempt! There are a couple of points, though.
1. We print the extruder gear with a 0.3mm nozzle, for higher resolution and better teeth. I think you're using a 0.5mm nozzle, and this will cause the teeth to be less well defined.
2. On the other printed parts, it looks like you are printing VERY close to the bed, so the first few layers are getting squashed a lot. Additionally, the bed may not be very level. You can manually level the bed mechanically, or use the G32 automatic bed plane compensation (see [reprappro.com] ).
Adjust the height of the Z homing as described here: [reprappro.com]
Also, you can adjust the Z height on-the-fly, during the first layer of the print. Once the nozzle moves parallel with the build surface, home Z. Start a print. Then watch the first layer. You can adjust the Z height by turning the Z leadscrews, while the printer is running, to get the first layer height correct. Always turn them the same amount, though, or the X axis will be out of level! If extrusion appears thin, and connects poorly to the bed, the nozzle is probably too high; turn the Z leadscrews anticlockwise. A quarter turn is 0.125mm. If the nozzle is too close to the bed, and is ploughing through the filament (or barely extruding at all), turn the Z leadscrew clockwise. You can do this even if the Z axis is moving, you'll just overpower the Z motor, making it jump to the next full step. This will not damage the motor. With a little experience, you can do this as soon as the print starts, and it draws the first loop outside the printed parts, to get the first layer spot on. You can also feed this back to the Z homing setting (paragraph above), so you don't need to do it any more.
3. It also looks like the extruder stops extruding at some points, leaving gaps in the perimeter. Check the hobbed insert is clean; if it is not, it may be slipping on the filament at certain points.
4. The extra blobs on the side of your print are usually due to retraction problems. Are you using our Slic3r profiles? See: [reprappro.com]

Let me know if that helps. Email me a reminder to look at this thread if you reply!

RepRapPro tech support
Re: New in the sports heed help.
July 01, 2015 09:14AM
Ian first of all thanks for ur reply.

Concerning the T0 command i dont have a problem when a print gets printed but i have problem when i want to extrude some filament by my own through the software. The prints are ok ( i dont get any message ) .

I add it to the config but it didn't help. Every time i want to extrude some filament i have to send T0 manually and then get temps and extrude filament. In my sd i have the newest files . I only kept the config.g the bed.g and the home files .

About the prints. Bassically during the previous week i did some printings. These ( in the photos ) are the best of them. Yes i have a problem with the bed level which i am not able to solve. I did do it mechanically and i did run the g32 command. But it doesn't seem to gets better with that.

Yesterday i print in another point of the bed and the first layers were as good as the last ones. So i confirmed that this is a bed leveling problem. But i thought that G32 would solve the problem. So am running the G32 after the G28 command that exists in every drawing. But this doesn't seem to help either.
i also did some work on the mendel trying to get the axis orthogonal. i ll try to get the nozzle aligning parallel to the bed and i ll get back

ps : forgot to answer.

yes i am running slic3r with the congiguration made up for mendel.

Edited 1 time(s). Last edit at 07/01/2015 09:16AM by Gaou.
Re: New in the sports heed help.
July 03, 2015 11:42AM
When you turn the printer on, by default, no tool is selected. Send T0, and then that tool is selected. In normal operation, you cannot extrude if the temperature is under 160C; this is a safety measure, to stop damage to the extruder and hot end. You can override 'cold extrusion prevention' by sending M302 P1 (assuming you are using firmware version v1.09); this is explained in the commissioning instructions here: [reprappro.com]

Most gcode will turn off the hot end at the end of the print, so you generally need to send T0 again afterwards. You can tell if the hot end is enabled or disabled: in Pronterface, if you see no temperature after 'T:' in the temperature response, no hot end is enabled; in the Web Interface, it says under the tool number if it's enabled or disabled.

Finally, if you're having problems enabling the tool, there may be a fault. If the reported temperature is below -10C or above 300C, the firmware regards this as a temperature fault and will disable the heater until it is fixed.

For bed levelling and G32 problems, see: [reprappro.com]

RepRepPro tech support
Sorry, only registered users may post in this forum.

Click here to login