Welcome! Log In Create A New Profile


Sanguinololu 1.3a – X, Y and Z motors won't move - "SOLVED"

Posted by Mastif_7 
Sanguinololu 1.3a – X, Y and Z motors won't move - "SOLVED"
May 12, 2012 05:43PM
Hi all

This is my first time Reprap build. Everything to date has gone really well, but I have hit a brick wall with the electronics.

The Setup:

- Reprap Prusa Mendel with frame constructed and motors mounted.
- Sanguinololu 1.3a kit with the FTDI chip pre-soldered and an ATMEGA 644P microprocessor loaded with the bootloader and the latest version of Sprinter firmware.
- A4988 Pololus drivers with current limits set to 0.47v to suit the motors.
- Brand new 400W ATX PSU - bought after suspecting the supply I was initially using was faulty.
- Pronterface installed on Windows 7 with Python and dependencies installed.

The Problem:

After connecting the motors, endstops, power supply and laptop the X,Y and Z motors will not move. After running some tests on the board this is what I have found:

- The extruder motor works with no problems
- Endstops measure 5 volts
- Hotend and hotbed pins read 12 volts
- Thermistor pins measure 5 volts

With the help of the kit supplier and his colleagues I have done some tests on the Pololu boards and found the following:

- VMOT is a constant 12 volts
- VDD (motors disabled) is 5v for the extruder motor but only 0.36v for X, Y and Z
- VDD (motors enabled) is 5v for the extruder motor but only 0.18v for X, Y and Z
- EN (motors disabled) is 5v for the extruder, X, Y and Z motors
- EN (motors enabled) is 0v for the extruder, X and Y motors but 5v for and Z

The X, Y and Z motors give no resistance when enabled and turned by hand.

I have been asked to trace back the VDD lines and see if there is anything that is stopping this getting to the drivers. In looking at the board and the schematic, with my limited electronics skills, I have hit another roadblock. The kit suppliers colleague has helped me get to this point, but I feel uncomfortable asking for so much of his time.

Has anybody come across anything similar to this or have an idea of what I can do from here?

Any help pointing me in the right direction will be much appreciated.

Edited 1 time(s). Last edit at 05/13/2012 04:56AM by Mastif_7.
Re: Sanguinololu 1.3a – X, Y and Z motors won't move
May 12, 2012 06:25PM
The VDD pins should all be connected together. If they have different voltages then they aren't, so it must be bad solder joints or broken tracks, etc.

Re: Sanguinololu 1.3a – X, Y and Z motors won't move
May 13, 2012 04:55AM
Thanks nophead

Sure enough, there was a broken track between the extruder jumper pins and Z axis jumper pins. Soldering a bit of hookup wire between the two groups of pins has solved the problem.

Thanks again for your help
Sorry, only registered users may post in this forum.

Click here to login