Welcome! Log In Create A New Profile


Clunking steppers at end of move command DRV8825

Posted by alan richard 
Clunking steppers at end of move command DRV8825
March 20, 2015 08:34AM

I have an issue with X & Y movement on a coreXY machine.
I'd previously had no problem with A4988 drivers at the same speed.
I (embarrased) fried my RAMPS board and steppers and replaced them with DRV8825 steppers, set at 1/32 step

If I issue a pronterface 100mm move command, Feedrate at anything over 7500mm/m -it travels fine, but at the end of its travel it makes a nasty kind of 'clunk' and travels on another 2 or 3 mm. Maybe one motor stops and the other does not.

I've swapped the stepper drivers several times with the same effect. I don't think its a dodgy driver. I've tuned and tuned.

I tried to switch it from 1/32 to 1/6 stepping but was not able. Using the jumpers as suggested doesn't give me the correct stepping.

(I had asked in RAMPS about setting 1/16 RAMPS)

Saying that, even 1/8 stepping was giving me the same result

Here's a brief movie YouTube that doesn't really convey the true nasty crunch of it

If anyone has any suggestions please comment.


Sorry, only registered users may post in this forum.

Click here to login