Welcome! Log In Create A New Profile


Arg! Can't get these suckers to step!

Posted by attrezzopox 
Arg! Can't get these suckers to step!
August 31, 2011 06:58PM
I attached a datasheet the stepper motors I'm trying to use on my reprap.

First things frist, the model number is 17pm-k005-k28vs. You may notice that they're not in the datasheet I attached, that's probably because they're custom pulls. I measured the resistance between unipolar and bypolar configured coils and they are 2.3 and 4.6ohms respectively.

I'm trying to control them with a RAMPS 1.2 setup, and I loaded up the rectangular spiral test from this page [reprap.org]

I assume that 1a and 1b represent one coil and 2a and 2b represent another coil. When I connect them like that and touch a metal screwdriver to the adjustment pot I hear a radio station through the motor.... whoa. I started at 12v even though in the datasheet the graphs seems to suggest they were designed to run at 24v. Anyway even turning up the pot all the way renders no movement on multiple motors, x and y and multiple driver boards.

;-( I tried pushing it back to single stepping rather than 1/16th steps. Same result.

Then, I brought home a 24v supply and tried again, same result only the motors held much stronger! yey!
Then I figured, maybe I got the coils all wrong, I tried grouping (1a/2a) and (1b/2b) This time no radio station, but still no movement.


Things I have done correctly (I assume).

-I've removed the diode so that 24v isn't blowing up my arduino, so the atmel chip is being powered directly via usb right now
-I've tried 1/16 steps and full steps to the same result with the 1ab and 2ab coil grouping. Haven't tried with 12a and 12b coil grouping.
-I've tried 12v and 24v
-I've ALWAYS started tests with the pot turned all the way down and slowly turned it up during the test.
-Drivers are heatsinked

With enough current @25%-40% the steppers will hold very well, but I haven't felt them get hot in any way even at full current, same with the pololu driver heatsink.

I have checked for shorts but I could go after it again with a multimeter. If so where should I start?
Could it be wiring? I had tried reversing the wires. Motors turn freely in both directions when not powered so I assume they don't have some braking system in them.
Is there a way to manually test the Sprinter firmware rather than using the rectangular test?
Is there some other firmware I should be using?

Here's a video showing my issues...

What should I do next?
open | download - 17PM-K.pdf (203.1 KB)
Re: Arg! Can't get these suckers to step!
September 01, 2011 06:23AM
First, you can find out what the coils are with a multimeter. To do so, measure resistance between wire pairs. Wires of different coils have no connection, wires of the same coil have a few ohms. If your stepper is a 6 wire like the one in the data sheet, you'll end up with 3 wires for each coil.

Now compare resistance of these pairs. You should find two pairs of low resistance and one pair with resistance of the other two together. This one pair with the higher resistance is the one you want. Ignore the third wire of this coil.

One coil goes into the left two pins of the motor connector, the other coil goes into the right two pins. Polarity doesn't matter so far. If the motors turn out to turn the wrong direction, swap the pins of one pair. This will reverse the motor's direction.

Now, if your motors don't turn at all, it might be the Pololu drivers don't get step pulses or the Enable pin isn't pulled low. Usually this means a firmware misconfiguration. See config.h or configuration.h, depending on your choice of firmware.

Generation 7 Electronics Teacup Firmware RepRap DIY
Re: Arg! Can't get these suckers to step!
September 01, 2011 09:27AM
I have identified the coils.

Thanks for the description btw, after looking at the pololu datasheet and reading your reply I realize I had them plugged in correctly. You should be able to see that in the youtube, they're plugged in correctly in that video.

Moving on, I noticed the rectangle test was based on another arduino board so the pinouts were wrong. I thought I had it figured out when I changed the pin numbers to the correct pins.

Still no avail, same exact symptoms. I believe the stepper driver is enabled because the motor won't turn if I turn the current up a bit (that and I hear the radio through it When I touch my adjustment screwdriver to the pot on the driver ;-P ) but it won't step. In any direction.

So I'm getting no movement whatsoever. BUT something you said may have been it! The enable needs to be pulled LOW! I'll check that when I get home.

If that doesn't work, I think the next thing I'm going to try is to plug it up to a logic analyzer and run 5v through the driver to see if I can catch it stepping. That'll at least tell me if it's the driver or not. That and I'm going to grab a stepper I pulled out of a dot matrix printer and see if I can drive it.

Assuming it's not the driver, is there any way to objectively tell if a motor is "burned up". I assumed that burning up a coil would mean you created a short in it or otherwise burned it up in a way that broke the winding so it wasn't connected. Thing that's weird is I get a consistent 4.3ohms on my multimeter, I guess the impedance is screwy because the resistance fluctuates UP, but never more than an ohm or two and it's never below 4.3.

So the coils aren't shorted... I have some resistance. And they aren't broken, I don't have a crazy multi megaohm resistance. So I'm working under the idea that the motors are good. Could this be wrong?

And what the heck is with the radio coming through when I touch the pot!?

Edited 2 time(s). Last edit at 09/01/2011 09:36AM by attrezzopox.
Re: Arg! Can't get these suckers to step!
September 01, 2011 03:59PM
I doubt there is anything wrong with your motors. If you can spin them with the power off and not with the power on and all the coils are the right resistance they should be OK.

If there is holding current then the controllers must be enabled. As the motor appears to make no attempt to move at all I think the driver is not getting a step pulse. Probably the firmware does match the pin out.

Odd that you get more torque with a higher voltage. The drivers are constant current, so increasing the voltage should have no effect on the torque when stationary. All it should do is increase the torque at high speed.

Odd that you cannot make the motors and drivers overheat when you turn the current up. Pololus get hot at 1A and overheat and shut down not much above that. The motor should get warm with 1A as well but you would need to leave it for a few minutes to notice that. If you measure the voltage on the wiper and set it to 400mV that will give 1A which is a good starting point.

The wiper of the pot is connected to the vref pin of the chip without any decoupling. You must live in a strong reception area and be modulating the vref voltage which gets amplified by the chip and fed to the coils of the motor.

Re: Arg! Can't get these suckers to step!
September 01, 2011 04:22PM
At least there's that then...

The torque in the motors lead me to believe they were enabled as well. I thought I corrected the code I was using but I'll double check. I KNOW I set the enable pin for the axis I'm using to high assuming that was enabled. Is there a pin that enables all of the drivers? The rectangle firmware seems to suggest in at least one arduino revision there was.

I'll likely end up writing a new arduino firmware that's mind-numbingly simple so you can troubleshoot this step a little more cleanly. The side effect for me is a way to wear in the bushings I used on the straight rods. Give em a little work out for a few hours so they operate smoothly on a print. ;-)

I didn't leave them at a high current any longer than it took to realize it wasn't working so that's probably why the motors weren't getting hot. The drivers would get hot to the touch, but that freaked me out so I'd immediately turn them off. (Hopefully I haven't damaged them).

On the note about the radio, all I know is that I can CLEARLY hear the radio through my stepper when I touch the pot. heh maybe I'll make a better video and upload it. Kinda funny.
Re: Arg! Can't get these suckers to step!
September 19, 2013 12:15PM
Your problem sounds a lot like mine. I have the Minebea 17PM-K307-05VS motors. I can't get them turning and I am also getting the weird static when I touch the trimpot. First time I heard it I thought I blew something for sure. But ya I only touched the trimpot with one multimeter lead and it made that noise. And the noise was coming from the stepper lol. I am using a 12V supply, but now that you mention it I see the graphs in the datasheet and they do say supply voltage 24V. My motors are custom made so I can't find my exact datasheet. Have you had any more luck?
Sorry, only registered users may post in this forum.

Click here to login