Welcome! Log In Create A New Profile


New to 3d printing, Marlin 1.1.9 compilation error, I need help !!!

Posted by Glx463 
New to 3d printing, Marlin 1.1.9 compilation error, I need help !!!
March 01, 2021 07:41PM
Hi everyone, I hope you're doing well !!

As mentioned in the title, I'm new to the world of 3d printing. In the following, I'll list the part I used to build my delta printer (if it help you to help me). In the mean time, here is the problem I face that I can't resolve... —-SOLVED—-

I fully assembled the delta printer and 3x checked my connections. For now, no smoke, so it's good sign!! lol Them come the installation of Marlin 1.1.9 Firmware. I've tried many different configuration for Delta from different sources on the internet, but nothing worked... All my hardware are ON, no smoke, everything brand new. I strongly believe the problem is from my side and my inability to properly setup the firmware.

I end up downloading the "original v1.1.9" from Marlin website and tried to setup my config.h properly, but even after a good upload on the board, nothing... The LCD is ON, but only the 1st and 3rd line are "active"/colored square.

I tried to open Repetier Host and connect... Nothing move, the LCD has the same symptom, but I can see both my thermistor reading at the bottom of the screen software, which is a good sign I guess.

I read somewhere that the saintsmart LCD need a file to work, so I tried to add ithe "liquidcrystal_I2C library to my file and I "uncomment" the #define LCD_SAINTSMART_I2C_2004 in the config.h. Now, when I try to upload, I get that error message:
In file included from sketch\MarlinConfig.h:42:0,
from sketch\ultralcd.cpp:23:
SanityCheck.h:1485:4: error: #error "Please select no more than one LCD controller option."
#error "Please select no more than one LCD controller option."
In file included from sketch\ultralcd.cpp:100:0:
ultralcd_impl_HD44780.h:137:12: fatal error: LCD.h: No such file or directory
compilation terminated.
exit status 1
#error "Please select no more than one LCD controller option."

I'm completely stock here and can't figure it out. I tried many different way to "firmware config marlin 1.1.9" from youtube videos, and it, most of the time, resolve around setting the good dimensions and upload and it work... As far as I'm concerned, I feel like the more I try, the worst it get sad smiley

Anyone have a link for a complete configuration that I can refer too or any tips that could help me to figure out the problem I have ? Your help would be greatly appreciated, sincerely !

Here is my part list:
Saintsmart Atmega2560
Saintsmart Ramps1.4
Saintsmart MK2 dual power heatbed
Saintsmart 20x4 LCD Controller with Adapter for RepRap RAMPs 1.4 **the exact model is this one, except my screen is green/black
: [www.sainsmart.com]

Polulu4988 (x,y,z + extractor)
NEMA17 stepper everywhere
Vantskitt Heatbed Power Module Mosfet for Rampes 1.4
AllenKey with microswitch for auto leveling

PSU 120V to 12VDC 30A

Edited 2 time(s). Last edit at 03/03/2021 12:33AM by Glx463.
Re: New to 3d printing, Marlin 1.1.9 compilation error, I need help !!!
March 01, 2021 09:18PM
Here is the change I did in the configuration.h, now the LCD is working. If you want to suggest me better setting feel free to add an input !

line#..... variable......input

125 BAUDRATE 250000
234 #define POWER_SUPPLY 1

---Thermal settings---
306 #define TEMPS_SENSOR_0 11
311 #define TEMPS_SENSOR_BED 11

---PID>Bed Temp. Control---

---Delta settings----
498 #define DELTA
542 DELTA_HEIGHT 217 <--to fine tune

---Endstop Settings----
571 #define USE_ZMIN_PLUG // a Z probe
572 #define USE_XMAN_PLUG
573 #define USE_YMAN_PLUG
574 #define USE_ZMAN_PLUG

**Endstop inverting is "false" everywhere and connected accordingly.
**Driver type are all A4988 for X,Y,Z and E0 and uncommented

---Movement Settings----
686 DEFAULT_MAX_FEEDRATE { 500, 500, 500, 25 } <--- shouldn't be (200,200,200,25) because I use a 8bits Atmega2560, with an LCD?
694 DEFAULT_MAX_ACCELERATION { 9000, 9000, 9000, 10000 } <-- shouldn't be 4000 instead of 9000 ?

---Z Probe Options---
870 #define Z_PROBE_ALLEN_KEY
973 #define INVERT_E0_DIR true <---because it's not a geared extruder

---Bed Leveling----
1218 //#define LCD_BED_LEVELING <-- I keep it commented since my LCD show nothing at the moment :\

---Additional Features---

---LCD and CD Support---
no change here

---LCD / Controller Selection (character-based LCDs)----
1648 #define REPRAP_DISCOUNT_SMART_CONTROLLER <--I uncommented it
1664 //#define PANEL_ONE <--I Commented it

---LCD / Controller Selection (I2C and Shift-Register LCDs)----
1724 //#define LCD_SAINSMART_I2C_2004 <--I Commented it
Re: New to 3d printing, Marlin 1.1.9 compilation error, I need help !!!
March 02, 2021 10:39PM
Hi everyone,

I made good progress since my last post.

I manually leveled my bed and realize something wrong. My bed is a flat sheet of glass but when I manually probe the Z_MIN, it's like if my bed was convexe on xy, xz and yz. Same as if my bed was a bowl. The difference is minimal, it’s 0,15 but it enough for a sheet of paper to be low-friction in the each corner, hard friction on axis and impossible to move when the nozzle is centered.

Some yputube video ralk about modifying the DELTA_SMOOTH_ROD_OFFSET, but I don,t have that offset in my config.h . Any advice on how to fix convexe/concave, please? I,m using the kossel mini config.h from Marlin 1.1.9.

Since the Z probe is a AllenKey-microswitch connected in the Z_MIN and wired as NC, I inverted the logic

Also, to go around my problem, I tried to add the auto bed leveling, but when i G33, i get the error: Z-Probe failed

Anyone could help, please?
Re: New to 3d printing, Marlin 1.1.9 compilation error, I need help !!!
March 03, 2021 12:30PM
You will need to adjust DELTA_RADIUS to fix a concave/convex bed but auto calibrate (G33) should do that for you.
Have you verified all your endstops are working with M119?
If you manually trigger the z probe with your hand about half way down during G33, does it stop or just keep going?
Re: New to 3d printing, Marlin 1.1.9 compilation error, I need help !!!
March 04, 2021 07:21PM
Hi thehankinator,

thanks for the reply. Yes, I did changed the DELTA_RADIUS after I acquired all the data from an auto leveling. <-Height, Ex, Ey, Ez, DELTA_RADIUS, Tx, Ty, Tz, DIAG_ROD)

The problem persist tho. I still have a 0,12-ish difference, even after an auto calibration session.

By the way, When I auto calibrate, the probe offset isn't considered, do you know why ? In all case scenarios, I'm between 0 and 0,15mm everywhere, which should be "ok" of My first layer is ar 0,2mm (nozzle to bed) with a first layer height of 0,3mm in the slicer to overfeed and squish the plastic between the nozzle and the bed for better adherence. Or I'm wrong ?

I did a test print yesterday and was able to eject some plastic. Unfortunately, for an unknown reason, the Z_MIN was lower than the bed itself so the nozzle was scrubbing everything off right after the deposit...

Then I tried to recalibrate and had a issue with the probe (Allen key setup). I disassembled it, modified it and recalibrate everything this afternoon, but my print session did not went well... The extruder stepper sounded like it was skipping( a rapid Ta-ta-ta-ta-ta...), the same as if the wire is stock and the motor can't push further... I even tried to help the motor and pushed the wire with the motor, but it didn't help. NOTE: plastic was coming out, but very slowly and instead of sticking on the bed, it was creating a blob of plastic around the nozzle... I didn't figured out why yet.

I though it was caused by a glock of PLA in the 0,3mm nozzle so I tried to drill it then broke the small drill bit inside it... (thanks to my shaking hands!!)
Re: New to 3d printing, Marlin 1.1.9 compilation error, I need help !!!
March 04, 2021 08:24PM
How are you changing the probe offset? (config file, gcode, etc..) If you change it in the Marlin config file, you will need to do a "load defaults" (or something similar, I've forgotten the exact text) otherwise it just uses whatever was stored in EEPROM.

If you can't even help the motor, it seems like it would either be some kind of obstruction or not hot enough. If it's an all metal hotend, PLA can cool in the heat break and cause a jam. Otherwise maybe the thermistor isn't configured proplerly and the hotend isn't hot enough?
Re: New to 3d printing, Marlin 1.1.9 compilation error, I need help !!!
March 05, 2021 04:42PM
Hi again,

Yes, after multiple tried and error, I finally get everything clean and square. And to answer your question, Yes, after every modifications I did in the config.h I had to "initialize EEPROM" from the LCD screen and "load", but I think that by initializing, it delete the over-ride and push the new data at the same time, so maybe loading after initializing may be useless... Anyway, problem solved concerning the concave/convex problem I had.

Concerning the obstruction, I used the first generation of nozzle (1 single aluminium piece) and it clog because the hot end fan does not run when printing. I did changed my hot end for a newer model (heat sink + threaded insert + heat block + nozzle) and it seem to work pretty well. I already had to "un-gloc" it. I face the same issue about the cooling... My hot end fan is connected on D9 and it does not start when the hot end is hot, which lead to a clog every time I start a print...

Actually, I print for 2-3 secondes and the clog happen right away.

I tried to make those change:

E0_AUTO_FAN_PIN 9 (changed from -1)

#define RAMPS_D9_PIN -1 (changed from 9)

it seem to work for other, but it didn't work for me... I always get an error when compiling.

Maybe you have an idea how to get my fan to run when the hot end reach 50c to avoid the filament to melt inside and avoid obstruction ?
Re: New to 3d printing, Marlin 1.1.9 compilation error, I need help !!!
March 24, 2021 06:58PM
125 BAUDRATE 250000
most of the time 115200 is better, less trouble

do you have a print area of 246mm diameter ?
I have a kossel k800xl and mine is 280 mm diameter
remove bed leveling linear
delta use G33 for this.
Re: New to 3d printing, Marlin 1.1.9 compilation error, I need help !!!
August 04, 2021 05:02PM
I realize this is a bit late, but here and here are guides I use to do manual calibration and bed leveling.
Re: New to 3d printing, Marlin 1.1.9 compilation error, I need help !!!
August 08, 2021 06:13AM
"By the way, When I auto calibrate, the probe offset isn't considered, do you know why "

XY-offset : I've done this on purpose because you are calibrating the nozzle, not the probe. winking smiley
Z-offset : depends on the Marlin version, I had a big dispute with the Marlin team on this and it took them more then a year to fix it. (from memory V1.1.6 to V1.1.8 have the bug / get the latest version V1.1.9.1 or V2.0.9.1)

"but when i G33, i get the error: Z-Probe failed"

This happens when your initial values (delta height, z_offset, diag_rod, delta_radius) are to much off; the routine calibrates (fine tune) but does not setup the printer.
Sorry, only registered users may post in this forum.

Click here to login