Welcome! Log In Create A New Profile


Gen7 v1.5 1284P Bootloader Fubar'd?

Posted by MeMadMax 
Gen7 v1.5 1284P Bootloader Fubar'd?
November 10, 2013 05:14AM
So, the 1284p chip was fresh from mouser with no bootloader.

Followed the directions here: "http://reprap.org/wiki/Gen7_Arduino_IDE_Support" for uploading the bootloader using dapa.
Right off the bat, avrdude didn't like the chip ID number.
Did the -F command override to force it.
Continued following instructions listed in link above.
Went on to try and install teacup, marlin, nothing happens.
MCP2200 chip is healthy.

Now I can't get do anything with the 1284p thru either the dapa or mcp2200 chip.
Avrdude returns 0x000102 on chip ID.
All attempts to change fuses returns "## has changed back to 00".
avrdude can send a bootloader but when it reads back can't verify, but it keeps saying the same locations/numbers over and over, so I don't think it's a communication issue with the dapa.

So, best way to erase everything and start all over?
Re: Gen7 v1.5 1284P Bootloader Fubar'd?
November 10, 2013 05:17AM
Also, I would also like to mention that when avrdude went thru the very first time programming the 1284p's fuses and upping the bootloader it had no other errors except for the chip ID number.
Re: Gen7 v1.5 1284P Bootloader Fubar'd?
November 11, 2013 06:32AM

Did the -F command override to force it.

Not a good idea. If the ID doesn't match, you should find the right Gen7 variant instead and choose it in Arduino IDE / on the command line. -p atmega1284p should be the right flag.

Generation 7 Electronics Teacup Firmware RepRap DIY
Re: Gen7 v1.5 1284P Bootloader Fubar'd?
November 11, 2013 02:59PM
Thanks Traumflug.
I have since ordered a new chip and a "real" AVR programmer lol.
Re: Gen7 v1.5 1284P Bootloader Fubar'd?
November 15, 2013 04:43AM
Quick update.
Got the new programmer and a second 1284p today.
Hooked up the AVR programmer(pololu brand) to the first chip and it was alive and well.
Turns out the dapa connection failed after setting fuses(too fast comm speed?)
Anyways, thats it, everything loaded and fine.

Have a good one.
Re: Gen7 v1.5 1284P Bootloader Fubar'd?
December 29, 2013 03:52PM
I just wanted to post here, because I ran into the same exact problem as MeMadMax. I was using an arduino to put the bootloader on an atmega1284p and using the ICSP header on a gen7 1.5. The atmega1284p would report an incorrect ID, and forcing the command to write to the fuses would result in a incorrect result (whatever you try to write, the fuse would report 0x00, then luckily revert to the default value).

To troubleshoot I ended up pulling the 20mhz crystal and the 22pF capacitors off the board and isolating the atmega1284p on a breadboard.

Of course, after doing that I received the same result and it became apparent that it was not an issue with the components or the circuity.

For me it came down to the configuration of the arduino. So I think I will say for anyone having this exact problem, look to your arduino: what sketch is loaded, and quadruple check your connections and which pins you are using. I had it just correct enough to give this strange error, but not wrong enough to simply not work.
Sorry, only registered users may post in this forum.

Click here to login