Welcome! Log In Create A New Profile


Printer "hangs" sometimes mid-print

Posted by Skunky 
Printer "hangs" sometimes mid-print
April 06, 2013 08:02AM

My printer sometimes "hangs" mid-print, making the printer unresponsive. I'ts completely random where or if it happens, but when it does, Pronterface writes a "0" without the quotes, in the command field.

What could cause this problem ?

I'm running my printer at baud 115200, with a Taurino Power and Ramps 1.4.

Using Sprinter and Pronterface as software
Re: Printer "hangs" sometimes mid-print
April 06, 2013 01:05PM
Does your board support printing from an SD card? If so, try performing a print that way and see if the issue persists. There are loads of posts that indicate USB communication is often a cause of interrupted prints. The communication isn't necessary when printing directly from an SD card. If the problem persists via SD card, I would be inclined to think you may have power issues.
Re: Printer "hangs" sometimes mid-print
April 07, 2013 05:08PM
You are right about the network issue.

Used to have big problems with checksum_mismatch errors with Baud 25000, wich i reduced greatly with switching to Baud 115200.

I would still get that error now and then, but it didn't use to be a problem.

Now i dont get those checksum_mismatch errors, it just stops working.

I can say that I've changed from a "normal" arduino 2560mega to a Taurino Power. Could that have something to do with it not being able to work through these errors ? and if yes, is the only solution using a SD card ?
Re: Printer "hangs" sometimes mid-print
April 09, 2013 11:03AM
skunky, i have the same board as you using marlin firmware, taurino power and ramps 1.4, a4988 stepper drivers all rom reprapdiscounts, randomly stops at midprint and pronterface produced an "o". set the baudrate to 250000.

still trying to figure why getting annoying as i have to monitor the prints all the time so i can recover quickly. i didnt get the sdcard reader. wonder if there any guides to this.

Re: Printer "hangs" sometimes mid-print
April 09, 2013 11:45AM
hey n9ghtfury.

For me the SDcardreader helpt solve the problem.

Btw, you know you can use a "normal" sdcard reader from ebay, you dont need to use the SDRamps.

The normal reader is just 2£ instead of 12£^^
Re: Printer "hangs" sometimes mid-print
April 10, 2013 11:44AM
ok, borrowed sdramps from a friend. still the same. what else could it be. this is making me nuts. tried ferrite core on the usb doesnt work, change the driver to arduino 2560 certified driver, problem still persist.

thinking of changing the power supply to server type psu. wonder if that helps.
Re: Printer "hangs" sometimes mid-print
April 10, 2013 04:01PM
I'm using a Server PSU. they are imba.

Well my problem got solved with the SDramps. I just move the g-code files i want to print to the card directly, and then i go into pronterface in "sd" and start what ever print from there. I dont even load the file into pronterface smiling smiley
Re: Printer "hangs" sometimes mid-print
April 14, 2013 10:53AM
i solved mine by replacing and relocating some wires connected to the ramps board. doesn't halt printing anymore for last 3 days...
Re: Printer "hangs" sometimes mid-print
April 27, 2013 09:06AM
Shunky, have you still this problem?
I also got it and it makes me nuts sad smiley
Re: Printer "hangs" sometimes mid-print
January 14, 2015 03:53PM
i solved mine by replacing and relocating some wires connected to the ramps board. doesn't halt printing anymore for last 3 days...

what wires did you relocate and where did you relocate them to? Pics?
Re: Printer "hangs" sometimes mid-print
October 23, 2015 04:10AM
Hi ni9htfury....

I just started having this issue about a week ago. I started using Cura both as a host and to dump code from on to an SD card (also tried it from Slic3r with the same result). Then I replaced the fan in my PSU and started having this issue. I swapped out the PSU for another I had also replaced the fan in and had the same issue. I'm pretty sure the fan replacement wasn't it, but I am going to reseat and possible reroute the spaghetti on top of my RAMPS 1.4 and see if that helps.

Any chance you knew which cables caused the issue?

Re: Printer "hangs" sometimes mid-print
February 17, 2016 12:45PM
After two months of printing printer starts halting after 15-30min of printing. Prints from SDcard.
Arduino+RAMPS+RRD_SmartController. Refleshing fireware does not help.
We grounds everything.
Dieing voltage regulator? Or PSU output is bad?
Re: Printer "hangs" sometimes mid-print
February 17, 2016 02:09PM


That combination is pretty much guaranteed to overheat the voltage regulator, unless you supply external 5V power either directly or by via the USB connector,

Large delta printer [miscsolutions.wordpress.com], E3D tool changer, Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Printer "hangs" sometimes mid-print
November 03, 2016 01:16PM
Its probably a power issue.
1. if it always stops at same place then check your gcode, perhaps your file is truncated.
2. Check your d1 diode,
3. Check your 5V and 12V rails and pins with a volt meter, and you may need to provide power to the barrel connector. it may help
4. If you have a working diode d1 then cut the +5v vcc red wire in your usb data cable. I have octoprint running on rasp pi and it was pulling power from the arduino mega board. Once i cut the +5V wire on the usb data everything worked like magic and no more failed prints.

Note. I feel its always important to have a 12V fan always running on your ramps board.

Edited 2 time(s). Last edit at 11/03/2016 01:18PM by edgeconsults.
Sorry, only registered users may post in this forum.

Click here to login