Welcome! Log In Create A New Profile


Stepper motors move too far,too fast

Posted by timekiller 
Stepper motors move too far,too fast
October 18, 2015 01:52PM
I am trying to get my RAMPS 1.4 setup on a Printrbot Simple Metal. I am 90% there, the only problem I am having is with the motors. From reading other posts, that seems to be pretty common, but my problem not that my motors won't move, it's that they move too much!

I have a RAMPS 1.4 and 4 A4988 driver boards. The Printrbot uses Nema 17 stepper motors. The Printrbot was working perfectly until my board died, so I'm trying to get it working again with RAMPS.

I have all the A4988 pots dialed to about 0.6v which is the lowest I can go and still have the motors move in both directions. The pots give me anything from 0.4v to 1.2v, and I've tried the whole range without much difference.

I tried the RepRap Testcode.pde and everything works, but the motors move way to much and too fast. I actually had to reduce the "on" time on the motors because they were travelling past the end of the bed. I changed this line:

if (millis() %10000 <5000) {

to this:

if (millis() %1000 <500) {

And this is what it looks like when it runs:


I compared this to other videos and my motors are WAY faster and I don't know why.

I tried printing a simple 40mmx40mm test print and this is what I got:


I have verified the settings I should be using for STEPS_PER_UNIT:

#define DEFAULT_AXIS_STEPS_PER_UNIT {80.00,80.00,2020.00,96.00}

This is according to Printrbot's specs: (Simple 1403) [docs.google.com]

I'm stuck. The hotend works, the thermister works. Heatbed, endstops - all good. Why are my motors acting like this?

Any help is appreciated.
Re: Stepper motors move too far,too fast
October 18, 2015 02:08PM
Maybe wrong microstepping settings (jumpers below stepper drivers)?
Re: Stepper motors move too far,too fast
October 18, 2015 02:29PM
YUP! Right after I posted this I found a video describing the jumpers. I didn't know about them, so everything was running at full step. I went to 1/4 step and things look much better now. Now I think I just have to dial in my Z probe and I can do a test print!
Re: Stepper motors move too far,too fast
October 19, 2015 05:39AM
1/16 is common microstep-setting for most a4988 based printers.
Re: Stepper motors move too far,too fast
October 21, 2015 10:26AM
Yeah, I didn't even know about the microstep setting until I saw a video where it was mentioned. Once I put the jumpers on, everything pretty much just worked!

Video of my first successful RAMPS print:

Next I'll be doing an X,Y, and Z upgrade, a heated bed, and a second extruder!
Sorry, only registered users may post in this forum.

Click here to login