Welcome! Log In Create A New Profile


Ramps 1.4 not receiving power from PSU

Posted by raspberrypi33 
Ramps 1.4 not receiving power from PSU
March 29, 2019 12:56AM

I am in the process of building a FT-2020 i3, and am on the electronics phase. Unfortunately, I ran into a major problem in which the RAMPS board only turns on when its connected to arduino and the arduino is getting power from USB. This problem occurs when the PSU is plugged in and unplugged. I am trying to run 24v to make my wires a bit thinner and tidier, and in doing so, have properly removed D1 from the board in order to separately power the arduino from USB. I have unplugged the RAMPS, and power it on individually, but it does not receive power from the 24v PSU. Although, while plugged in via USB, the PCD and rRAMPS work fine, but of course, only endstops work, so I can't move anything. Can anyone help b/c I have searched everywhere for an answer, and tried lots of things, but I have not been able to solve this. Is my RAMPS defective? I know its not the arduino b/c all lights are proper and I can flash firmware and nothing is blown there. Thanks in advance for any help!!!

Just some notes on the build if you need it:

FT-2020 Prusa i3
Arduino MEGA 2560 + RAMPS 1.4 + Full graphic LCD + 5x A4988
24V PSU (in marlin, psu option is "0", meaning not an ATX or XBOX)
Marlin 1.1.0 or whatever is latest

Edited 1 time(s). Last edit at 03/29/2019 12:59AM by raspberrypi33.
Re: Ramps 1.4 not receiving power from PSU
March 29, 2019 01:36AM
The normal operation the RAMPS 12v is feed via D1 to the 12v to 5v voltage regulator on the mega, this provides 5v to the system. If this is not powered it will take 5v from USB.
Without the MEGA or D1 there is no on-board way to generate 5v.

You have removed D1, which you need to do on a 24v system in order not to kill the 12v to 5v regulator.

With D1 removed you need to supply the mega DC power jack with a voltage from 7 - 12 volts somehow.

How is up to you.

Even then you will have issues as the RAMPS + the GLCD is the worst combination for power. The Voltage regulator on the mega is not up to the task.
I would also look into a separate 5v for the GLCD, eg a standard 7805 from your 7 - 12v mega supply to the GLCD

you should take a look at RAMPS_24v for some other options

Edited 3 time(s). Last edit at 03/29/2019 01:50AM by Dust.
Re: Ramps 1.4 not receiving power from PSU
March 29, 2019 01:51AM
Thanks so much for your help! So what you are saying is that the RAMPS gets its power from the 5V from the arduino which gets it from the RAMPS D1? Then is there a way to verify that the RAMPS is able to use the 24v for the extruder, motors, heat bed, etc? I am confused because from the wiki (https://reprap.org/wiki/RAMPS_24v), it says "Remove D1, and power mega2560 via the USB cable. You must leave whatever its connected to on or the mega will power down.". I will try what you said and get back to you.
Re: Ramps 1.4 not receiving power from PSU
March 29, 2019 02:11AM
Please learn to paragraph!!

"First step is to work out how you are going to power the mega2560. There are several options."

There are several options to power the mega..
With D1 removed, leaving the USB plugged in and powering your external power supply is one option.

Edited 2 time(s). Last edit at 03/29/2019 02:13AM by Dust.
Sorry, only registered users may post in this forum.

Click here to login