Willkommen! Anmelden Ein neues Profil erzeugen

Erweiterte Suche

Stromverbrauch Ramps + ATMega2560 + LCD12864

geschrieben von BeSpace 
Stromverbrauch Ramps + ATMega2560 + LCD12864
05. June 2020 20:29
Hallo zusammen

Weiß jemand zufällig wie viel Strom die untere Kombination bei 12V braucht und ob der AMS1117 5 Volt Regler auf dem ATmega Board dabei heiß wird?
Ich brauche irgendeine Referenz oder eine fachkundige Einschätzung um einen Fehler auszuschließen.
  • ATmega2560-16AU Board
  • Ramps 1.6plus (China-Bord von BIQU)
  • LCD12864 (aus dem Anet A6)
  • 4 TMC2130 Modulen aufgesteckt
  • alle anderen Kabel abgesteckt
Mir ist vor einiger Zeit der AMS1117 5V Spannungsregler auf den ATmega Board abgeraucht, weil ich Plus und Minus am LCD Display verwechselt habe.
Ersatz von Ebay draufgelötet und alles war gut. Gestern, nach längerer Zeit, den Drucker wieder eingeschaltet und der Regler raucht nach etwa 10 Sekunden wieder ab.

Ich habe ein wenig rumgemessen, finde aber keine Fehler. Lediglich 2 Haare vom Hund und etwas Staub auf den Platinen, sowie eine unterbrochene GND-Brücke zum USB Port. (Die mußte ich schon beim letzten Mal setzen, da eine Leiterbahn verschmort war. Die kann aber auch beim Ausbau abgegangen sein. Sie war vorher aber auch nicht so lang wie jetzt auf dem Foto, sondern nur etwa 2cm.)

Die Brücke und der Regler sind jetzt wieder ersetzt, mir fällt aber auf, dass er ziemlich heiß wird. Nach ein paar Minuten kann man sich, an der Rückseite der Platine, die Finger schön wärmen.
Jetzt stellt sich mir die Frage ob eine der Platinen einen Defekt hat oder die e-Bay Regler gefälscht sind und deshalb so heiß werden.

Meine kleine Stromversorgung zeigt folgende Werte bei 12V an:
  • ATmega alleine etwa 25mA
  • Atmega + Ramps 80mA
  • Atmega + Ramps + LCD 140mA
Wenn ich das richtig sehe sind das etwa 1,7 Watt für den kleinen Regler. Ist das einfach zu viel und ich muss weiter nach einem Fehler suchen oder ist der Regler zu schwach oder zu schlecht gekühlt?
Die Leitungen zu den Motoren etc. werde ich mir auch noch vornehmen, allerdings sind die hier erstmal gar nicht dran gesteckt.



2-mal bearbeitet. Zuletzt am 05.06.20 20:35.
Re: Stromverbrauch Ramps + ATMega2560 + LCD12864
06. June 2020 01:56
Teste mal hier die Temperatur. Der verträgt keine 12V.
Eine durchgebrannte Leiterbahn einfach mal zu überbrücken ist auch nicht so sinnvoll.

Herzl. Grüße
Anhänge:
Öffnen | Download - 4b2x.jpg (368 KB)
Re: Stromverbrauch Ramps + ATMega2560 + LCD12864
06. June 2020 05:27
Hallo BeSpace,

Der Spannungswandler auf deinem Board packt das LCD Display nicht, hatte das Selbe Problem. Ich habe das Problem mit einem zus. 5V Netzteil gelöst und die 5V direkt auf die 5V pins vom Board gelegt. Das Board also mit Ext. 5V versorgt. Auch mein Raspi wird aus dem selben Netzteil versorgt. Der Drucker läuft seitdem ohne Probleme. Mein Spannungswandler auf dem Board ist übrigens auch heute noch defekt ist aber durch die ext. 5V egalspinning smiley sticking its tongue out

Achte unbedingt darauf alle GND´s aller Netzteile zu erden, sonst kann es passieren dass du bei der USB Verbindung mit dem Rechner (5V Über Rechner USB und paralel 5V vom Netzteil) dein USB Controller im PC killst.
Ich gehe da immer auf Nummer sicher und versorge beim Flashen mit dem PC den Drucker einzig und allein über USB 5V. Der Drucker selbst ist da nicht am Netz! Druckaufträge laufen bei mir nur über Octoprint und nicht über PC&USB. (evtl. liegt auch hier dein Problem mit der Leiterbahn bei USB PC Verbindung)

3-mal bearbeitet. Zuletzt am 06.06.20 05:38.
Re: Stromverbrauch Ramps + ATMega2560 + LCD12864
06. June 2020 06:19
Quote
3dSchrauber
Hallo BeSpace,

Der Spannungswandler auf deinem Board packt das LCD Display nicht, hatte das Selbe Problem. Ich habe das Problem mit einem zus. 5V Netzteil gelöst und die 5V direkt auf die 5V pins vom Board gelegt. Das Board also mit Ext. 5V versorgt. Auch mein Raspi wird aus dem selben Netzteil versorgt. Der Drucker läuft seitdem ohne Probleme. Mein Spannungswandler auf dem Board ist übrigens auch heute noch defekt ist aber durch die ext. 5V egalspinning smiley sticking its tongue out

Achte unbedingt darauf alle GND´s aller Netzteile zu erden, sonst kann es passieren dass du bei der USB Verbindung mit dem Rechner (5V Über Rechner USB und paralel 5V vom Netzteil) dein USB Controller im PC killst.
Ich gehe da immer auf Nummer sicher und versorge beim Flashen mit dem PC den Drucker einzig und allein über USB 5V. Der Drucker selbst ist da nicht am Netz! Druckaufträge laufen bei mir nur über Octoprint und nicht über PC&USB. (evtl. liegt auch hier dein Problem mit der Leiterbahn bei USB PC Verbindung)
Ich hoffe, Du meinst mit Erden alle GND untereinander gut sternförmig verbinden. GND an Erde zB Stromnetz killt den PC und andere Teile.


Liebe Grüße aus Henstedt-Ulzburg.
Frithjof
Meine Seite
[www.facebook.com]
Re: Stromverbrauch Ramps + ATMega2560 + LCD12864
06. June 2020 08:20
Quote
AlterBastler
Teste mal hier die Temperatur. Der verträgt keine 12V.
Eine durchgebrannte Leiterbahn einfach mal zu überbrücken ist auch nicht so sinnvoll.

Herzl. Grüße

Was würdest du erwarten? Zusammengesteckt wird das etwas schwierig werden. Dazu müsste ich den winzigen Temperatursensor vom Messgerät mit Heißkleber auf den IC festmachen und hoffen dass er hält. Der scheint aber aus Metall zu sein (*bange*).

Ich habe einen kleinen Kühlkörper auf den Regler geklebt (.9x.9x.4mm). Die Temperatur ohne RAMPS (also bei [email protected]) beträgt nach ein paar Minuten etwa 40°C. Der kleine IC daneben hat 32°C. Das scheint aber auch etwa die Temperatur der Platine an dieser Stelle zu sein.

Was mich wundert ist, dass der Regler so heiß wird und dass er schon beim Einschalten durchgebrannt ist. Laut Datenblatt soll er doch bis zu 1A können (wobei ich diese Angabe nur aus dem erstbesten Datenblatt habe).
Ich muss mir den Stromverbrauch noch einmal ansehen wenn alle Teile eingesteckt gesteckt sind. Ist es möglich, dass beim Einschalten irgendwie viel mehr Strom fließt?

Viele Grüße
Re: Stromverbrauch Ramps + ATMega2560 + LCD12864
06. June 2020 08:31
Schau mal hier, besonders wegen der USB-Schnittstelle


Gruß
Peter

Meine Drucker:
2x P3steel - toolson edition - MK1 und MK2 mit Repetier Firmware
1x Tantillus R (gelb)
1x Tantillus R (grün)
Re: Stromverbrauch Ramps + ATMega2560 + LCD12864
06. June 2020 08:34
Quote
3dSchrauber
Hallo BeSpace,

Der Spannungswandler auf deinem Board packt das LCD Display nicht, hatte das Selbe Problem. Ich habe das Problem mit einem zus. 5V Netzteil gelöst und die 5V direkt auf die 5V pins vom Board gelegt. Das Board also mit Ext. 5V versorgt. Auch mein Raspi wird aus dem selben Netzteil versorgt. Der Drucker läuft seitdem ohne Probleme. Mein Spannungswandler auf dem Board ist übrigens auch heute noch defekt ist aber durch die ext. 5V egalspinning smiley sticking its tongue out

Achte unbedingt darauf alle GND´s aller Netzteile zu erden, sonst kann es passieren dass du bei der USB Verbindung mit dem Rechner (5V Über Rechner USB und paralel 5V vom Netzteil) dein USB Controller im PC killst.
Ich gehe da immer auf Nummer sicher und versorge beim Flashen mit dem PC den Drucker einzig und allein über USB 5V. Der Drucker selbst ist da nicht am Netz! Druckaufträge laufen bei mir nur über Octoprint und nicht über PC&USB. (evtl. liegt auch hier dein Problem mit der Leiterbahn bei USB PC Verbindung)

Du hast mich auf eine Idee gebracht. Ich habe noch ein paar Step-Down Konverter herumliegen. Leider haben die aber nur max. 2A Dauerstrom, sonst würde ich doch glatt gleich den Pi3B+ dranhängen. Aber: Versuch macht klug (oder kaputt moody smiley)
Ansonsten müsste ich mir eh ein neues Netzteil für den PI besorgen. Dann kann ich das ja auch für das Board mitbenutzen.
Re: Stromverbrauch Ramps + ATMega2560 + LCD12864
06. June 2020 09:00
Quote
Peter1956
Schau mal hier, besonders wegen der USB-Schnittstelle

Danke für den Link. Sehr interessanter Artikel. Also ist es doch zu viel für den NoName Regler gewesen.

Verstehe ich die Möglichkeit Nr. 4 richtig. Wenn man irgendwo direkt 5V einspeist (z.B. per Step-Dow-Konverter oder Netzteil), dann sollte man dafür sorgen, dass nichts über den VIN Pin vom RMAPS Board kommt?
Auf meinem ATmega ist kein sichtbare Sicherung am 5V Pin. Wäre es möglich den VIN Pin einfach abzuklemmen oder ist es dies hier nicht mehr notwendig (wie im Beispiel vom 3d Schrauber)?

Ich frage mich auch, ob nicht der Raspberry die gesamte 5V Versorgung über USB übernehmen könnte, wenn man den VIN Pin von Ramps abklemmt. Das wäre dann Möglichkeit Nr. 2 oder?
Re: Stromverbrauch Ramps + ATMega2560 + LCD12864 thumbs up
06. June 2020 19:49
Der Drucker läuft wieder!

Es lag tatsächlich am überlasteten 5V Regler auf dem ATmega Board. Den Ersatzregler habe ich wieder vom Board entfernt, so dass die Stromversorgung jetzt exklusiv vom Raspberry PI per USB übernommen wird.

Vielen Dank an alle, die Tipps waren genau richtig.
In diesem Forum dürfen leider nur registrierte Teilnehmer schreiben.

Klicke hier, um Dich einzuloggen