Stumped, need help.
August 27, 2012 02:34PM
I am using pronterface with slic3r 0.9.1 and I can not get even my first layer to print correctly. I have a level print surface and I am printing on glass covered with kapton. I have a j type head with a 5mm nozzle and 2.9 mm grey filiment that I am extruding at 220 degrees and my printbed at 110 degrees. At first my majoir issue was the first layer printing with way too muck filiment, it was oozing everywhere and my nozzle would just push it around but I have calibrated my wades extruder so that when I tell it to extrude 100mm it extrudes 102mm. I adjusted the E feedrate in pronterface way down to 75 and that has helped but I still get a messy surface. Also I adjusted my infill down to .05. I have played with layer height and feel like the issue is definitely too much or too wide an extrude so that the connecting lines end up with too much abs on the surface.

But now I am also having a wierd thing happening, now after my printer prints the first layer of the print my printer then seems to offset diagonally up to the right about an inch and then starts printing the same object again which of course is overlapping onto the previous print thus destroying everything, this seemed to start happening after I updated slic3r from an old version that came with pronterface that I downloaded. Any help would be much appreciated, after 3 days of failed printing I am feeling pretty much defeated.
Re: Stumped, need help.
August 27, 2012 02:53PM
You have at least 2 issue, the offset printing is most likely a mechanical or stepper driver calibration issue.
What's likely happening is that after the axis rises at the end of the first layer, you are losing steps as the printhead moves to the start of the second layer.

We are going to need to know more about your printer to be of very much more help.
The most common causes are speed set too high for transition moves
Acceleration set too aggressively in the firmware for X and/or Y
Pot on the stepper driver set too high or too low
something mechanical, (rubbing belt slipping pulley etc etc)

What sort of printer do you have?
What electronics?
Have you adjusted the stepper pots?

On the first layer issue, what sort of plastic are you printing, I am assuming it's ABS?
Re: Stumped, need help.
August 27, 2012 04:39PM
Thanks for the help, I have a Mendal Prusa with Ramps 1.4 and atmega 2650 and pololu 1498 stepper drivers. And yes I am printing with ABS. I actually did atempt to adjust the pots, I initially did not have them adjusted and then I was following a calibration guide and they talked about adjusting the pots so I did because my stepper motors were getting pretty hot and thought maybe they were drawing too much current, anyway I turned them counterclockwise till they barely responded to thier respective move commands and then turned them clockwise approximately 1/8 of a turn at a time untill they seemed to work well without any jerking or noise. However I noticed that no matter how far I turned the X axis pot the motor would never really change much. Do you have to use a nonconductive material to adjust the pots with or is it ok to use a jeweler screwdriver that has a plastic handle? Also as far as my X axis belt is concerned the spot at which the belt attaches the extruder carriage is not in line with the stepper motor either, it did not seem to be binding though when I tested the motion with no power to the stepper motor, do you think this could be an issue as well. I will attach an image of how the belt is positioned, at any rate there is no way of adjusting this short of building something that would extend out the mounting area on the carriage in order to get proper allignment which I actually was going to print out just such an item once I got my printer built.
open | download - 01.jpg (280.9 KB)
open | download - 02.jpg (268.7 KB)
open | download - 03.jpg (195.6 KB)
Re: Stumped, need help.
August 27, 2012 06:20PM
What firmware are you using?
What acceleration setting do you have set?
What speeds do you have set for the print in the Slicer?
Re: Stumped, need help.
August 27, 2012 08:06PM
I am using Marlin.

perimeters 30
small perimeters 30
infill 60
top solid infill 50
bridges 60
travel 130
first layer speed 30%

printer settings:
I set my nozzle to .4 even though I a 5mm nozzle
perimeters 3
solid layers 3
fill density .4
layer height .3
first layer height 100%
Re: Stumped, need help.
August 27, 2012 09:00PM
I would try to determine if the problem is in the GCode generation or machine. Design a 20mm square with a .5 wall thickness. Something that would just travel in a square and advance up. Look carefully at the gcode and see that its does what you expect it to do. Next try dry running the machine. No filiment. Is it traveling in a square patten then up each time around. If the code looks correct and the machine doesn't follow that pattern then its in the way the steppers are connected or possibly the firmware (most likely the hardware). if that all works then add the filiment.
If something is complicated then try breaking it into as many components as you can test. Prove or disprove that each one works as expected. When everything proves out then dial in the settings. Try the one setting at a time. Save the parts and lay them out on a large peice of paper with the settings you tried. You can then visually see the effects of your settings.
Re: Stumped, need help(Solved)
September 10, 2012 12:09PM
So the problem turned out to be a short in one of the wires running from the stepper motor, it took me awhile to find the issue but it is fixed now, thanks for all the help.

Edited 1 time(s). Last edit at 09/10/2012 10:16PM by cmiller.
Sorry, only registered users may post in this forum.

Click here to login