Welcome! Log In Create A New Profile

Advanced

after changing baudrate....cannot connect printer ANYMOREsad smiley

Posted by romeo2die 
after changing baudrate....cannot connect printer ANYMOREsad smiley
March 19, 2015 10:00AM
First of all my printer description:
1) Reprap Melzi 2.0: Processor: ATMEGA1284P (Sanguino compatible)
2) Repetier Host with Slic3r
3) Firmware EEPROM

I have been using my printer to print out stuff, using baud rate setting of 115200, THE PROBLEM STARTED when I tried different BAUD RATE setting in FIRMWARE EEPROM configuration to 230400....whenever I tried to connect the printer:
- it connects only for 2-3 seconds then disconnected by itself
- I have changed the baud rate in both my FT232 USB to 230400 and repetier printer setting to 230400 as well....the previous problem still happened

Then I decided to use ARDUINO, have succesfully connected my printer with the software, downloaded all the necessary configuration change from the repetier website (cant post URL here)
but when I tried to upload the file:

"Third-party platform.txt does not define compiler.path. Please report this to the third-party hardware maintainer.
Error while uploading: missing 'recipe.cpp.o.pattern' configuration parameter"

Can anyone please help me solve this? ive been struggling with this thing for a looooong time


Regards
Re: after changing baudrate....cannot connect printer ANYMOREsad smiley
March 19, 2015 11:09AM
Hi,

You need to set the same baud rate in the firmware and host configuration.

The standard baud rates are subject to significant error on a 16MHz processor as used on the Melzi. You will have more luck running at 250,000 baud.

I run my Melzi-based Mendel90 at this baud rate all the time.

Regards,
Neil Darlow


I try to write with consideration for all nationalities. Please let me know if something is unclear.
Printing with Mendel90 from fedora 25 using Cura, FreeCAD, MeshLab, OpenSCAD, Skeinforge and Slic3r tools.
Re: after changing baudrate....cannot connect printer ANYMOREsad smiley
March 19, 2015 12:25PM
thanks for the reply,

after I changed the baudrate via FIRMWARE EEPROM configuration (repetier-host), I cannot open the configuration window anymore (ALT+E).
the option in config - FIRMWARE EEPROM config is always greyed out....I cannot click it anymore
Re: after changing baudrate....cannot connect printer ANYMOREsad smiley
March 19, 2015 12:35PM
Hi,

I assume you must be using Repetier firmware as I am not aware that Marlin stores baud rate in EEPROM. Perhaps there is a method to perform a factory reset on the firmware to load defaults.

Regards,
Neil Darlow


I try to write with consideration for all nationalities. Please let me know if something is unclear.
Printing with Mendel90 from fedora 25 using Cura, FreeCAD, MeshLab, OpenSCAD, Skeinforge and Slic3r tools.
Re: after changing baudrate....cannot connect printer ANYMOREsad smiley
March 19, 2015 12:43PM
You are correct - in Marlin (at least in the version I am using), the baud rate is in the source code, not in EEPROM. The only way to change it is to modify the source code, rebuild, and re-deploy.
Re: after changing baudrate....cannot connect printer ANYMOREsad smiley
March 21, 2015 11:26PM
so I just need to play around with arduino right? thanks for the early reply btw
Re: after changing baudrate....cannot connect printer ANYMOREsad smiley
March 21, 2015 11:29PM
thx for the early reply btw....

the BAUDRATE will affect only the controller board? am i right?
Re: after changing baudrate....cannot connect printer ANYMOREsad smiley
March 22, 2015 08:05AM
You need to set the baudrate in the Repetier Host setting to the same value as you did in the Marlin config.

So, you don't set it in 'EEPROM Settings' in Repetier, but in the 'Printer Settings'.

If the baudrates both match, firmware and software, you can connect and it works.


http://www.marinusdebeer.nl/
Re: after changing baudrate....cannot connect printer ANYMOREsad smiley
March 22, 2015 10:57AM
Yes, I have matched both the printer setting and device manager baudrate value to both 230400 and 115200, but still cannot connect.

PREVIOUS CONDITION:
(I was using baudrate of 115200) - EEPROM, Printer setting, device manager setting, and it was working perfectly fine.)

When I changed the baudrate in EEPROM, I started to get this problem.

CURRENT CONDITION:
1) EEPROM setting still in 230400 ( I cannot change it back, cos the option in repetier host cannot be selected, whether or not I connect the printer
2) I have tried to change both printer manager and device manager baudrate to match current EEPROM baudrate value to 230400, but still not working


Btw, thanks for the previous reply, greatly appreciated
Re: after changing baudrate....cannot connect printer ANYMOREsad smiley
March 22, 2015 07:11PM
It sounds like you can still connect to the board using Arduino software but just can't recompile the firmware, is that correct?

How did you get the firmware on the board in the first place? -- Was it using the Arduino software or some other method?

If you have a way to reinstall the firmware on the device, I recommend clearing the eeprom -- you can do this from the command line with AVRDUDE (etc.) if you're familiar with the toolchain, or you can upload a new program to the Arduino that when executed (i.e. when you reset the board) it will clear the EEPROM. But then after you do that, you need to reupload the original Marlin firmware back onto the board.

Here's an example: http://arduino.cc/en/Tutorial/EEPROMClear
Re: after changing baudrate....cannot connect printer ANYMOREsad smiley
March 22, 2015 07:18PM
Yes, that is true, I can still connect to my printer using arduino, but having trouble uploading the script.

the firmware was there in the board when I first purchased the parts (when I install repetierhost, I could access the firmware EEPROM settings)
Re: after changing baudrate....cannot connect printer ANYMOREsad smiley
March 23, 2015 08:27AM
Btw, try baudrate 250000. It's what worked best for me.


http://www.marinusdebeer.nl/
Re: after changing baudrate....cannot connect printer ANYMOREsad smiley
March 23, 2015 08:52AM
But in my device manager setting (when u right click computer, device manager), there is no "250000" baudrate option
Re: after changing baudrate....cannot connect printer ANYMOREsad smiley
March 23, 2015 09:53AM
It is a "Virtual" COM port! You set the baudrate in the firmware AND the Host program - NOT the device manager!


Bob Morrison
W├Ârth am Rhein, Germany
"Luke, use the source!"
BLOG - PHOTOS - Thingiverse
Re: after changing baudrate....cannot connect printer ANYMOREsad smiley
March 24, 2015 09:31AM
use arduino 1.0.6 got this error

In file included from D:\Arduino\libraries\SPI\/SPI.h:15,
from D:\Arduino\libraries\SPI\SPI.cpp:12:
D:\Arduino\hardware\Sanguino\cores\arduino/pins_arduino.h:72: error: previous declaration of 'const uint16_t port_to_mode_PGM []' with 'C++' linkage
D:\Arduino\hardware\Sanguino\cores\arduino/Arduino.h:127: error: conflicts with new declaration with 'C' linkage
D:\Arduino\hardware\Sanguino\cores\arduino/pins_arduino.h:73: error: previous declaration of 'const uint16_t port_to_input_PGM []' with 'C++' linkage
D:\Arduino\hardware\Sanguino\cores\arduino/Arduino.h:128: error: conflicts with new declaration with 'C' linkage
D:\Arduino\hardware\Sanguino\cores\arduino/pins_arduino.h:74: error: previous declaration of 'const uint16_t port_to_output_PGM []' with 'C++' linkage
D:\Arduino\hardware\Sanguino\cores\arduino/Arduino.h:129: error: conflicts with new declaration with 'C' linkage
D:\Arduino\hardware\Sanguino\cores\arduino/pins_arduino.h:76: error: previous declaration of 'const uint8_t digital_pin_to_port_PGM []' with 'C++' linkage
D:\Arduino\hardware\Sanguino\cores\arduino/Arduino.h:131: error: conflicts with new declaration with 'C' linkage
D:\Arduino\hardware\Sanguino\cores\arduino/pins_arduino.h:78: error: previous declaration of 'const uint8_t digital_pin_to_bit_mask_PGM []' with 'C++' linkage
D:\Arduino\hardware\Sanguino\cores\arduino/Arduino.h:133: error: conflicts with new declaration with 'C' linkage
D:\Arduino\hardware\Sanguino\cores\arduino/pins_arduino.h:79: error: previous declaration of 'const uint8_t digital_pin_to_timer_PGM []' with 'C++' linkage
D:\Arduino\hardware\Sanguino\cores\arduino/Arduino.h:134: error: conflicts with new declaration with 'C' linkage
Re: after changing baudrate....cannot connect printer ANYMOREsad smiley
March 24, 2015 04:12PM
Seems like you may have included a header file twice -- what are you trying to compile? -- A specific firmware, or the eeprom eraser I linked to? If it's the eeprom eraser, I have to ask, it's the only file in your sketch right?

Also, keep in mind -- the Arduino board can only hold one program at a time -- if you upload the EEPROM eraser -- then you'll have to let it run until the light blinks on -- and then you'll have to recompile your firmware and reupload it as well.

Also, why are you running such an old version of the Arduino software? Update to 1.6. -- You should be able to compile Repetier firmware without issues from a fresh install of the latest Arduino environment.

Edited 1 time(s). Last edit at 03/24/2015 04:12PM by BrainSlugs83.
Re: after changing baudrate....cannot connect printer ANYMOREsad smiley
March 25, 2015 05:34AM
I get the feeling you are not exactly telling us what you are doing.

Please be as clear as possible!


http://www.marinusdebeer.nl/
Sorry, only registered users may post in this forum.

Click here to login