Welcome! Log In Create A New Profile


Gadget3D - Extruder Issues

Posted by ianch 
Gadget3D - Extruder Issues
June 25, 2021 06:44AM
What am I doing wrong?

I have a Gadget3D Printer based on the Prusa printer.

I have put the latest MarlinFW 2.0.9 on it. Previously running 2.0.7 with the same issue.

I have calibrated the X,Y and Z as per all the well known published KB articles on the web.
Likewise I have calibrated the E.

All of which set on the printer with E92 followed by E500.

I have also reflected the values in the MarlinFW configuration.h file and uploaded the firmware to the Arduino Mega board with RAMPS1.4

I have also calibrated the pots on the RAMPS board as per KB articles and also the assembly instructions for the Gadget3D

Some lines from the configuration.h file that are noteworthy

#define X_DRIVER_TYPE  A4988   // Assuming these are the correct motors on the Gadget3D???
#define Y_DRIVER_TYPE  A4988
#define Z_DRIVER_TYPE  A4988
#define E0_DRIVER_TYPE A4988
#define DEFAULT_AXIS_STEPS_PER_UNIT   { 80, 80, 2000, 711 }    // M92
#define DEFAULT_MAX_FEEDRATE          { 400, 400, 3, 10 }    // M203
#define DEFAULT_MAX_ACCELERATION      { 5000, 5000, 25, 1000 }    // M201
#define DEFAULT_ACCELERATION          2000    // M204
#define DEFAULT_XJERK 10.0    // M205
#define DEFAULT_YJERK 10.0
#define DEFAULT_ZJERK 0.3
#define DEFAULT_EJERK    3.0
#define G3D_PANEL

With PLA loaded, measured 1.74mm and the HotEnd heated by to 200C

I can issue the G1 E100 F100 command

and then extruder prints out exactly 100mm of PLA.

YAY!! So far so good.

However if I try extruding more and even try printing the PLA eventually gets jammed in the extruder (See photo)

In my Slicer I have the following settings

Nozzle Diamete = 0.40
Extrusion Mulitipler = 1 (I have tried 0.9 as well)
Extrusion Width = 0.40mm
Layer Height = 0.25mm
FeedRate 100 (I have tried lower)

Everything starts off ok, but after a few layers of printing the extruder jams, just as if the motor is trying to push the PLA through the heater quicker than the heater can melt the PLA. As side note the Extruder Fan is off.

What am I doing wrong?

Is there a way to slow the motor down, so its not forcing PLA to give it enough time to melt?

Any ideas??
open | download - PXL_20210624_201831879 (Small).jpg (105.1 KB)
Re: Gadget3D - Extruder Issues
June 25, 2021 07:23AM
"I can issue the G1 E100 F100 command and then extruder prints out exactly 100mm of PLA."

That's not right, but might be a bad description...

G1 E100 F100 means take in 100mm of filament, you should get a lot longer piece out as you going from 1.75 down to .4 ie 437.5 mm out

You normally measure the length of filament taken in to the extruder.

Edited 1 time(s). Last edit at 06/25/2021 07:24AM by Dust.
Re: Gadget3D - Extruder Issues
June 28, 2021 06:35AM
Sorry, yes, bad wording...

You're correct. In fact I mark the PLA with a marker at 100mm and 120mm in the inlet side.
Then extrude 100mm and take measurements as a delta to the 120mm so I can calibrate M92 Exxx
Sorry, only registered users may post in this forum.

Click here to login