Welcome! Log In Create A New Profile


Slic3r 1.0.0RC1

Posted by Sound 
Slic3r 1.0.0RC1
November 19, 2013 06:26AM

First off, sorry for not being very present in this forum. I try to read everything and work on the issues, but I rarely have time to answer and partecipate in the threads. I'm very focused on the documented issues that are reported through the GitHub issue tracker. Still, thank you for your testing and reporting work, it's very valuable.

A new version is out, with lots of new features that you can read at [slic3r.org]
Re: Slic3r 1.0.0RC1
November 19, 2013 09:24AM
I install the new version on windows.
But it says the modul for the opengl is missing and need to install that.
But where do I find that?
Re: Slic3r 1.0.0RC1
November 19, 2013 12:51PM
Same problem here with 64 bit download..
I have Windows 7 64 bit and Nvidia with latest driverupdate.
Slic3R says when 3dview is pressed that another built with OpenGL is needed.

However if I download and run 32 bit version (x86) it looks like it is working at least with 3d view, I have not seriously tested otherwise.

Edited 2 time(s). Last edit at 11/19/2013 01:38PM by justcurious.
Re: Slic3r 1.0.0RC1
November 19, 2013 04:18PM

Hope it will be fixed soon then :-)
Re: Slic3r 1.0.0RC1
November 20, 2013 08:07AM
Have you tried with a fresh install (deleted your old slic3r config folder)? My slic3r x64 always crashed on win7 64bit while 32bit version worked. After I deleted (actually I renamed it) the folder with the old .ini-files it worked.
Re: Slic3r 1.0.0RC1
November 20, 2013 08:21AM
re Noob..
ver 9.10b was working fine with Win7/64 and so does ver 1.0.RC, the only thing found sofar, was the above mentionend when view button was pressed, which of course is a dum thing for a new feature.
Otherwise very fine program and lots of new things to verify, so 3d view is maybe not the big thing in present form.
Thankyou to all developers for still making progress.thumbs up
Re: Slic3r 1.0.0RC1
November 20, 2013 12:43PM
Hi for W7 X64 opengl issue download this files : [files.transmissionzero.co.uk] take the freeglut-MinGW-2.8.1-1.mp.zip
See Here
Extract, go to folder : bin > X64
Copy freeglut.dll
Go in slic3r folder > dll
And replace the freeglut.dll

Works for me.....

Edited 3 time(s). Last edit at 11/20/2013 01:19PM by Djamuka.
Re: Slic3r 1.0.0RC1
November 20, 2013 12:51PM
I get this : 403 - Forbidden
when I try that link.
Re: Slic3r 1.0.0RC1
November 20, 2013 12:54PM
I edit the link...it's ok?
Re: Slic3r 1.0.0RC1
November 20, 2013 01:17PM
No I can see the folder, but the file is not there ;-)
Re: Slic3r 1.0.0RC1
November 20, 2013 01:23PM
Thanks.. I can see the file now and I download it :-)
Re: Slic3r 1.0.0RC1
November 20, 2013 04:16PM
That did the trick, thankyou so much thumbs up
Re: Slic3r 1.0.0RC1
November 20, 2013 11:38PM
Hey there, I am having this same problem, But when I click the link, I get the 403 - Forbidden error.
Re: Slic3r 1.0.0RC1
November 21, 2013 03:07AM
Hi, don't know why the link give a 403 error, or why the file is delete...
See here for DL the zip file "freeglut 2.8.1 MinGW Package" [www.transmissionzero.co.uk]

or take the freeglut.dll in this post

Edited 1 time(s). Last edit at 11/21/2013 03:10AM by Djamuka.
open | download - freeglut.dll (242 KB)
Re: Slic3r 1.0.0RC1
November 21, 2013 03:19AM
Try to update browserwindow (F5) with no typograhics set (show type), and files at GLUT link may appear ,at least they did for me after several attemps. Don't ask me why :-).

-------------------------------------------------------------------------------- Parent Directory -
older/ 11-May-2013 13:32 -
checksums.txt 11-May-2013 13:32 553
freeglut-MinGW-2.8.1-1.mp.zip 11-May-2013 13:32 405K
freeglut-MSVC-2.8.1-1.mp.zip 11-May-2013 13:32 186K
GLUT-MinGW-3.7.6-6.mp.zip 15-Jan-2012 16:18 79K
GLUT-MSVC-3.7.6-6.mp.zip 15-Jan-2012 16:18 81K
Readme.txt 15-Jan-2012 16:18 1.0K
Re: Slic3r 1.0.0RC1
November 21, 2013 07:14AM
Djamuka's link works

Edited 1 time(s). Last edit at 11/21/2013 07:15AM by spaceman.
Re: Slic3r 1.0.0RC1
November 21, 2013 11:13AM
at the end it work !

but it is only to see the STL file, not realy useful ! i thought it was a way to look at the gcode paths
Re: Slic3r 1.0.0RC1
December 14, 2013 03:11PM
My thanks to djamuka.

Simply replacing his freeglut.dll in the dll folder got the view option to work

FYI I am using an AMD FirePro V4900 with a Windows 7 Pro system
Re: Slic3r 1.0.0RC1
December 23, 2013 04:46AM
Hi, I also had the same problem and have now been dealt with this download: freeglut.dll_242 KB from Djamuka, thank you.

Edited 1 time(s). Last edit at 12/23/2013 04:46AM by herisuprapto.
Re: Slic3r 1.0.0RC1
January 05, 2014 06:34AM
I can't get the raft to work on this new version. Hos something been changed or a new way to select raft?

"Experience is the mother of all knowledge." --Leonardo da Vinci
Re: Slic3r 1.0.0RC1
January 13, 2014 03:43PM
I moved over to RC1 and then RC2 to fix other issues I was having only to find that they have introduced problems that make Slic3r useless to me. I find that If I print big things the slic3r gets confused and thinks that holes are things and turns the object inside out. From the commits, I can see that these issues have been observed and fixed but I can't build slic3r from github to try this out. I've rasied an issue and others have raised their own and linked them to mine but I can't see Sound working them. How is he building and delivering RC1 and RC2 when we can't build from github stable or master?

I'm getting a little frustrated as I don't understand cpan and it appears that this is where the build issues are as it's downloading and building stuff from cpan but the tests fail. Am I just using the wrong version of cpan? is that likely?

Using ABSPrusa Mendel Zaphod with Pronterface and slic3r 1.3.0. Printing well with 3mm PLA and ABS through 2 x J Head Mk IV b and Wade Geared Exruders. Controlled using RAMPS1.4 board running Marlin_v1.1.9
Sorry, only registered users may post in this forum.

Click here to login