Welcome! Log In Create A New Profile


Slicer closing/crashing

Posted by sfinke 
Re: Slicer closing/crashing
December 17, 2015 08:35PM
I used to have all sorts of weird behavior from Slic3r. It would crash, ignore changes made to printer, filament, and print configurations, etc. Then I reduced the number of threads to 1 and it seems to have fixed all the problems. I read somewhere that with multiple threads it copies the STL to memory multiple times and even in my quad core desktop with 12 GB of RAM, it didn't seem to be enough. 1.2.9 has been working pretty reliably for me, so when I used to switch back and forth between Slic3r and Cura, now I mainly run Slic3r.

Ultra MegaMax Dominator 3D printer: [drmrehorst.blogspot.com]
Re: Slicer closing/crashing
December 17, 2015 10:20PM
Well I jinxed it or the upgrade to Mint 17.3 screwed something up because now I can't slice a model I was able to slice before with 1.2.9
Re: Slicer closing/crashing
December 21, 2015 08:11AM
My 1.2.9 almost never crashes on XP with 500meg ram. Only when I try to re-load a big model several times, maybe.
Re: Slicer closing/crashing
December 22, 2015 01:07AM
I just spent all morning trying to get a particular part sliced, with no luck as it kept on crashing. It's not a particularly large part, only 14mm x 14mm x 10mm, and not all that complex.

I even went as far as trying to compile slic3r, gosh what a mission that was... and it was eventually unsuccessful.

However there is a ray of hope, I discovered that the perimeters setting was causing the crash. Set this to 3 caused a crash, setting it to 2 let it slice perfectly.

I've no idea what this is about, but I hope it helps someone.

Re: Slicer closing/crashing
December 23, 2015 01:25PM
I feel sad, I am also giving up on Sli3r confused smiley
Life's too short and I spend enough time already messing with my Mini Kossel.
Too many problems as discussed in this thread.

I will try Cura for a while, and research Simplify3D.


Julian S.

T3DP3D Mini Kossel, E3D V6 hot end, 0.4mm nozzle, 200mm diameter Ali heated bed, Duet v0.8.5 & dc42 rep rap v1.18. DWC v1.15, PanelDue-7-1.16 DC42 IR Z Probe, 2 X MAX31855 &Thermocouples, PID heated enclosure, SolidWorks 2017, slic3r
Re: Slicer closing/crashing
December 23, 2015 06:11PM
On the whole I find S3D very good, although I prefer the way that slic3r handles multiple printers. In the light of the competition it has, I think it should cost £50 instead of £100.

Large delta printer [miscsolutions.wordpress.com], E3D tool changer, Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Slicer closing/crashing
January 05, 2016 12:03PM
Apart from this crashing issue, I like Slic3r, however I'm now probably going to be using Craftware.

I'd downloaded CW early on, along with various alternatives, but couldn't get any easily dialled in on the Velleman K8200 I have at work.

Thanks to having downloaded Craftware, I got an email from Craftunique anouncing a competition to win a Craftbot+ (the usual Facebook kind of thing).

I won and wanting to try the printer out, downloaded Slic3r for my win7-64 machine at home (quad xeon). The result was the same as here at work, crashing all the time, so I downloaded Craftware.

Obviously it's Craftunique's own software, so should work well with their printer. I'd asked for a roll of ABS, rather than PLA, so selected those defaults and sliced the Crafty Robot file that's pre-loaded. Slicing is very fast, so fast that you question if anything even happened after using Slic3r. The result was an alost perfect print.
Re: Slicer closing/crashing
January 06, 2016 04:13AM
@compton, have you tried running slic3r 32-bit instead of 64-bit? I've been meaning to try that since I read that it solved the crashing problems that some people were having. Although now I've got use to S3D instead.

EDIT: forget that, I just installed the 32-bit version of slic3r. Same behaviour - crashes a few seconds after I select a filament type and load an object.

Edited 1 time(s). Last edit at 01/06/2016 04:18AM by dc42.

Large delta printer [miscsolutions.wordpress.com], E3D tool changer, Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Slicer closing/crashing
March 08, 2016 08:32PM
As a temporary solution, I use the [File ... Quick Slice].
I can't rorate, rescale or whatever, but it does slice the model without freezing.

If this can help, problems started when my NVidia Graphical card has updated her drivers.
And since, Slic3r freeze everytime I try to add an object to my platter.

I didn't try to reinstall everything, but I had a weird bug :
I keep a clone of my disk, and I tried a clone of Slic3r 1.2.9 of before my drivers update, and it worked.
Then, I run the after update version, and it worked for a while, but whenever it freezes one time, I will always freeze after.

Is there any way to reports some infos to the programmers ?
Re: Slicer closing/crashing
June 08, 2016 10:10AM
I had this problem, The only way to fix it is to go into user/"username"/AppData/Roaming/ and delete the Slic3r folder. Then reinstall and go through the setup problem, this also applies to the programmed exiting Perl with unfinished threads problem.

The problem is Slic3er saves settings to that location, you can remove and reinstall slic3r wherever and as many times as you like but without deleting that folder, with the corrupted file it will never be fixed.

Perhaps the owner of slic3r should fix the balls up and save many headaches.
Sorry, only registered users may post in this forum.

Click here to login