'Smudged' prints in Slic3r 1.2.9
July 07, 2015 10:46AM
Over the weekend I updated to slicer 1.2.9, and I'm experiencing a new issue as a result.

This is a print of this part off of thingiverse. Printed using the settings recommended on the instructions tab.

a was sliced using 1.1.7. The settings worked great, everything was nice and smooth.

b was sliced using 1.2.9 using the exact same config file as I had used in 1.1.7. Nothing changed on the printer, or in the settings.

c was sliced using 1.2.9 with detect thin walls turned off -- I thought it might have something to do with the adjustment to thin wall logic made that is mentioned on the changelog for Slic3r 1.2.9, so I turned off "detect thin walls"

I also discovered this thread on Git, which describes a very similar problem (I think): [github.com]

Is this "Gap Fill" problem the culprit, or does anyone else have any other ideas?
open | download - slic3r_thin_wall.jpg (256.8 KB)
Re: 'Smudged' prints in Slic3r 1.2.9
July 08, 2015 08:47AM
The symptoms look to me like the effect of having too much play (backlash) in the X or Y direction. Typically caused by a slightly loose belt. The effect this has will vary depending on the position that the outer perimeter is started, which could be the reason for the difference seen in different Slic3r versions (one version may change the starting position when reaching the indents, the other not). If the perimeter of every layer is approached from the same direction and starts at the same place you will not see any ridging at all (the circle will be slightly oval but as it is the same all the way up it is not noticeable). You could try rotating the print 90 degrees on the build plate which might get rid of the symptom, but the real fix is to tighten the belt of the offending axis.

Re: 'Smudged' prints in Slic3r 1.2.9
July 08, 2015 12:58PM

Thanks for the information and the advice. I will try to tighten up the belts and see if this doesn't solve the problem.
Re: 'Smudged' prints in Slic3r 1.2.9
July 10, 2015 06:07PM
Hi, had to revert to the V1.1.7, something is crippled in V1.2.9 stable. All my walls look like if flow rate is wrong.
As soon as I changed Ver. all is well.

Re: 'Smudged' prints in Slic3r 1.2.9
July 10, 2015 06:42PM
arejay: I came to the same conclusion early, but I was determined to figure out what exactly was causing the problem. I have since made a lot of test prints and carefully studied exactly what happened and I'm quite sure that I have found the problem.

This is the issue that joecarpita linked to in his first post - [github.com]

I think this is the cause for most of the quality problems you see in 1.2.9. If I remember correctly, the quality problems started around version 1.2.6.

Alessandro has confirmed that the gap fill calculation was very rough. Worst case it will fill a gap with 10 times the desired amount, which will cause a lot of problems. Even if you do, you will probably see a lot of overflow, which will cause really ugly prints in some cases, and in others it will cause incorrect measurements. I have seen some cases where a 2 mm wall becomes 2.5 mm.

Another problem with 1.2.9 vs earlier versions is that the gap fill can cause some pretty wide extrusions. These could be an order of magnitude wider than any extrusions produced by earlier versions. This of course means that you have to compensate the speed and temperature to be able to print it well.

If disable "detect thin walls" it removes the gap fill, but it also prints overlapping perimeters, which will be equally bad as having gap fill enabled, or even worse, so there isn't really a way to get good results from 1.2.9 in a lot of cases.

If you believe that you see the same problem (check the g-code preview carefully to be certain), please leave a message in the bug report. I really think that this isse is hurting slic3r's reputation badly right now.

Edited 2 time(s). Last edit at 07/10/2015 06:45PM by teppic.
Re: 'Smudged' prints in Slic3r 1.2.9
July 13, 2015 08:32AM
teppic: Thanks for the info. & links. I agree, reputation is unbalanced, bad news spread faster than good ones. I really don't understand how this issue with V1.2.9 went unnoticed because it really is a serious one. Anyhow I don't think it will take long for the Sli3er team to correct this.
Re: 'Smudged' prints in Slic3r 1.2.9
July 29, 2015 03:03PM
I've had this issue since switching to 1.2.9. I've adopted each incremental update and seen some nice changes, but with this version I've had some crappy prints (hit or miss).
It seemed to be dependent on the wall width but I couldn't figure out exactly why. It looks like when it's just the right width, the infill is considered "gap" infill and the gap calculation causes overextrusion?
It's present as many open issues on github [github.com] (as well as your topic)
Switching back to 1.2.7 definitely brought back quality prints. I'm also looking into turning "off" gap fill (set speed to 0, fills with default infill density). Anyone else have thoughts on temporary fixes or if there's something else going on here?
Re: 'Smudged' prints in Slic3r 1.2.9
July 30, 2015 11:06PM
1. Is there a typical modeling situation that causes this in 1.2.9 ?

2. Where is 1.2.7 found, and what functions does it not have compared to 1.2.9 ?
Re: 'Smudged' prints in Slic3r 1.2.9
July 31, 2015 12:45AM

Pick your platform, and when you get to the next screen, hit "old" and everything since the dawn of time should be there . . .

I know that ooze prevention and volumetric extrusion came into being between 1.2.7 and 1.2.9, as well as some routing algorithm changes. Release notes are on the site linked above if you want more details, but for "non exotic" use, you probably wouldn't notice a difference.

- Tim
Re: 'Smudged' prints in Slic3r 1.2.9
August 29, 2015 02:33PM
I posted this to Slic3r issue #2960 today, but thought it might be of interest to people here.

I ran an interesting test this morning which I believe is relevant. I slic3d a rather large and complex thin-wall model with gap fill on in slic3r 1.1.7, 1.2.6, and 1.2.9 using the same settings exported from 1.1.7 in all three. Then I looked at the total extrusion length. The results for 1.75mm filament:

Slic3r 1.1.7: 64422.53mm
Slic3r 1.2.6: 56872.62mm
Slic3r 1.2.9: 77011.22mm

Additionally, with similar settings:

Simplify3D 3.0: 65117.37mm (15% infill overlap)
Cura 14.12.1: 64230.95mm

The raw volume of the part is 153951.51 mm^3, which would imply a total required extrusion length of 64005.60 mm

This would imply that something is a little off with the Slic3r 1.2 family's extrusion rate calculators.

Just to be clear, this was using 100% infill and 0% infill overlap. Simplify3D was run with 15% infill overlap because it seems to have some issues with dropping infill when the overlap gets low. Wall thickness was nominally 3.2mm and I was set up for a 0.6mm nozzle.

Edited 1 time(s). Last edit at 08/29/2015 02:35PM by wfcook.
Sorry, only registered users may post in this forum.

Click here to login