Welcome! Log In Create A New Profile

Advanced

Slic3r setting 7800 feedrate for Z movements. Stumped

Posted by ansiomatic 
Slic3r setting 7800 feedrate for Z movements. Stumped
April 10, 2018 05:40PM
so. everything i slice comes with 7800 feedrate for the z axis, which is way too much for my motors.
I've looked at similar posts in the forums but i couldn't find an answer to this, and i've searched the slic3r configs without any luck.

Recently i've opened the marlin code loaded in my printer and searched 7800 in all sketch tabs but found 0 coincidences...

i'm really stumped.. thinking about writing a script to modify every line manually, but i'd like to fix it for good tho..

any ideas?
Attachments:
open | download - Configuration.h (62.6 KB)
Re: Slic3r setting 7800 feedrate for Z movements. Stumped
April 10, 2018 05:49PM
Slicers assume that you have configured suitable movement speed limits in your firmware, so they often command high speed travel moves knowing that your fimware will limit it to a speed that your machine can manage.

However, I've not used slic3r for a while, so maybe now it has a separate setting for the speed of Z moves.

Edited 2 time(s). Last edit at 04/10/2018 05:52PM by dc42.


Delta printer calibration calculator, mini IR Z probe, and colour touch screen control panel: [escher3d.com]

Large delta printer, and other 3D printer blog postings: [miscsolutions.wordpress.com]

Disclosure: I have a financial interest in sales of the Panel Due, Mini IR height sensor, and Duet WiFi/Duet Ethernet [www.duet3d.com].
Re: Slic3r setting 7800 feedrate for Z movements. Stumped
April 10, 2018 07:38PM
maybe that's the problem, cause i had been printing fine until i started messing around with the firmware to install a z probe.

is there an option in the printer to enforce this limit?

thanks for the reply
Re: Slic3r setting 7800 feedrate for Z movements. Stumped
April 10, 2018 07:48PM
[github.com]

in the link i've found the problem.
In the config file i have to treat the default acceleration limits as units/sec2 and not mm/sec2. I had that setting way too high for this units. I'm playing with it but i can now safely run the command that was messing my gccode (namely, g1 Z## F7800)
Re: Slic3r setting 7800 feedrate for Z movements. Stumped
April 11, 2018 12:01PM
Quote
#define DEFAULT_MAX_FEEDRATE { 300, 300, 5, 25 }

With Z steps/mm set at 4000 the 5(z max feedrate) is way too high, change the 5 to a 2 or possibly 3.
Sorry, only registered users may post in this forum.

Click here to login