Welcome! Log In Create A New Profile


Extuder issue on Foldarap

Posted by Foldarap85 
Extuder issue on Foldarap
December 29, 2013 07:19PM
Hello everyone,

I have some issues with my brand new Foldarap 85 and I believe I am not the fist one to have them so I'm hoping sombody can help me.

The fist and biggest one is about the extruder, the motor seems to be missing steps and the printed parts are missing a lot of material (see in the picture)
I thing I have configured it well, I have the Melzi board and 5 Nema14 motors, I changed the Vref to 0,45 for this one as explaned in the manual : [reprap.org] (I also inverted 2 wires to invert the direction of some of the motors, I didn't change the firmware of the board mostly because I don't know what configuration to change in invert the motors...)
I am printing at 220°C and I have tried at 260° it doesn't change anything, for the sicing I am using Sli3r and the configuration provided by Emmanuel for 0.5 in github

I have an issu with small items to print the nozzle maks it all melt... but I believe this is beacause I don't have active cooling for the moment and also because the speed which is too low...

I have an other small issue, on the Z axes, when I ask Printrun to go to the home of the Z axes the motors it blocks, when I am moving manualy it is working.... but it is much slower and I don't know how to tell Printrun to slow down...

If somebody can help me with this I will be very grateful !

Have all good holydays.
open | download - IMG_20131230_003122 (Medium).jpg (225.5 KB)
open | download - IMG_20131230_003315 (Medium).jpg (109 KB)
Re: Extuder issue on Foldarap
December 30, 2013 04:35PM
Hi FoldaRap85,

I do recognize the problems you describe AND may have some advice for you, hope so...
The latest batch has not the 0.5mm but the 0.3mm, thus you should let Slic3r use this file github : Slic3r 0.3.ini. Helped for me and stopped missing extruder steps.

PLA temperature here is set at 195°C not higher. Nice blue color you have got, looks a lot like mine.

Firmware direction switches are easy to set, if you need help just let me know. I even added a display and rotary encoder, allows printing without pc. Google+ FoldaRap 072 pictures

Active cooling is needed for smaller parts! Print the 40x40x10 fanholder and use it. Connect the fan on the fan output of the Melzi. Don't forget to check the polarity.

To prevent the blocking, my advice is to adapt (bend a little) the microswitch to stop a bit higher and you should raise your Y-baseplate equally (level bed again a bit higher then before!). Slowing down is also possible, but from my point of view it is not your real problem.

Hope this may help you

Edited 2 time(s). Last edit at 12/30/2013 04:47PM by ggaljoen.
Re: Extuder issue on Foldarap
January 02, 2014 05:30PM
Hello Ggaljoen,

Thank you for your answers, I will try again with the 0.3 file you pointed out and also lowering the temperature...
I got the blue color directly for Emmanuel, not really hard to find ^^

I think I will keep my firmware as it is but your solution for puging in the motors is interresting and the display seems very interessting, where did you learn to do this ? and what do you mean by rotary encoder ?

I have the fanholder, and I used it by also I pinted this active cooling part [www.thingiverse.com] that I sill try shortly

About my problem on the Z axes I believe my explanation is not clear, in fact the motors are blocking because of the "x-end" parts and mostly because the threaded shaft that are not right in the axes of the motor. So when I tries to move fast it block in the middel of the axis..

What is the thing that you added in this picture ? [plus.google.com]

Re: Extuder issue on Foldarap
January 03, 2014 01:28AM
Hi FoldaRap85,

Hope you can make it print by the changing your Slic3r settings to 0.3mm.

These motor plugins were just for testing purpose but I can understand it would simplify a lot the electronics. Emmanuel solved this for the first 2014 kits with a new controller board. This Minitronics is plug and play!

The display knowledge is a long story and goes decades back in time by trail and error. With main stops at Arduino and Teensy. A rotary encoder, sure you know, is a by example the volume knob of a car radio (endless turning left-right and push to switch on-off). Firmware tuning was also needed to activate the display software-hardware setup link. => meanwhile made even some custom menu entry/command to enter FOLD position: X 50 Y 145 Z 145

About my problem on the Z axes I believe my explanation is not clear, in fact the motors are blocking because of the "x-end" parts and mostly because the threaded shaft that are not right in the axes of the motor. So when I tries to move fast it block in the middel of the axis..

Can you make a (many pictures) to point out this issue? One picture can say more then 1000 words...

What is the thing that you added in this picture ?

The attachement is showing the load sensor to measure the nozzle extrusion pressure. It is still in early beta. More to come (soon... ?). You can read about Airtrippers project pages. I am adapting his setup to be an add-on. For the moment there is to many interference between loadcell and bowdentube (movement). There is room for improvement but the readout graph gives a good view on the filament flow (picture attached)!


Edited 1 time(s). Last edit at 01/03/2014 01:30AM by ggaljoen.
open | download - load sensor.jpg (361.8 KB)
open | download - filament flow.jpg (33.4 KB)
Re: Extuder issue on Foldarap
January 03, 2014 10:53AM
EDIT : Rule number 1 with Melzi board with Foldarap, UPDATE THE FIRMWARE with the one provided by Emmanuel [github.com]

Then, I have no more issues...

I will update the wiki to add this important point !

It seems that I have other issues that I did not saw before.

I tried to print at 195° and with the 0.3 configuration it is better, but still not perfect but it might be related to the next issue.

I printed a part that should be 15*10mm and it is 12*17,5 mm .... all the part that I print have the same issue, on the Z axis I have no issue...
Also, I centered the part in Slic3r (configued in 140x140 centered in 70x70) it is not centered in Pronterface (also configured in 140x140....) and it is clearly not in the center of the bed as you can see in the picture

This is probably due to the size of the pulley with is not right in the firmware. It believe I will have to change the firmware of the board but I don't know which configuration to take... Maybe this one ? [github.com]

An other issue, the Z axis does not go to the top, only to 10.5 cm...

Video of the other issue on the Z axis : [plus.google.com]
Video of the issue of the extruder : (coming later...)

Edited 1 time(s). Last edit at 01/03/2014 04:08PM by Foldarap85.
open | download - Pronterface_2014-01-03_13-07-02.png (205.9 KB)
open | download - 2014 - 4.jpg (32.3 KB)
open | download - IMG_20140103_144903.jpg (223.3 KB)
Re: Extuder issue on Foldarap
January 03, 2014 04:14PM
Ok! Problem solved. I would have suggested the same solution, knowing that the Melzi's are preloaded with general reprap test firmware not suitable for a FoldaRap.
Re: Extuder issue on Foldarap
January 03, 2014 06:18PM
I spoke too quickly... after 2 hours of working fine my heating bed is not responding any more... It stoped working it seems broken (no issue on the wires...)
I might have something to do with the firmware I updated...
To be continued
Sorry, only registered users may post in this forum.

Click here to login