Welcome! Log In Create A New Profile

Advanced

DC42 Diff Sensor X Homing

Posted by veryevil 
DC42 Diff Sensor X Homing
December 15, 2014 06:08AM
Hi, I have just installed DC42's diff sensor board to my Ormerod 2 and flashed the duet to RepRapFirmware-078y-dc42.bin. Currently I'm having trouble homing the X-Axis as it doesn't stop when it gets to the sensor pad.

I can manually move the X-axis along and it gets to the sensor pad and the light comes on as it should. It only just makes it so I guess it could be a bit longer. Temporarily I put some card on it to make it bigger but that doesn't help either. The X-Axis keeps trying to move and makes a horrible noise so I have to kill the power.

I believe it all wired up correctly as the reading seems to come through on the web interface for the sensor and I have also made the changes to the files on the sd card as listed here:

Quote

Note: if you have an Ormerod 2 then you will need to modify the homex.g and homeall.g files. Open each of these files in a text editor, locate the “M558 P2 lines, comment them out by putting a semicolon at the start of the line, and save the file. Also change M558 P2 in your config.g file to M558 P1. The board must always be run in differential LED mode (P1) or simple modulated mode (P3). If you select P2 then the board will be asked to switch rapidly between modes and you will not get a sensible reading.

I am also a bit confused as to which files I should be using on the SD card now as there are two different repos for the web interface (https://github.com/dc42/RepRapFirmware/tree/dev/SD-image) and (https://github.com/dc42/OrmerodWebControl/tree/master)

Do I need to update the system files as well for DC's firmware?

Any ideas how to get my x-axis working?

Thanks
Re: DC42 Diff Sensor X Homing
December 15, 2014 07:24AM
Hi, ignore the master branch in my repository, it's very old. Use the dev branch only.

With my 0.78y firmware, you can use the same config and homing files that you used with the RRP 0.78c firmware, except for the following changes:

1. You need to use M558 P1 all the time with my board. So replace M558 P2 in config.g with M558 P1. In homex.g and homeall.g (and homez.g if it is there), comment out the M558 P2 lines.

2. In your G31 line in config.g, you must use a P value of 500. This affects X homing as well as Z homing.

If the red LED is on but the axis is not stopping, then:

1. Check that the P value is 500 in your G31 command in config.g.

2. Check the Z probe reading while it is homing. You can temporarily reduce the X motor current to a low value to be kinder to the machine if it isn't stopping. When the sensor is over the pad and the red LED is on, if you see a Z probe reading of the form "10 (535)" then it means you are using M558 P2 at that point, which won't work with my board. You reading should just be of the form "535". The only readings you should get from my board are about 0, about 465, about 535, and about 1023. The red LED is on when the reading is about 535 or about 1023. You won't see the 1023 reading unless the sensor is saturated by very strong light.



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: DC42 Diff Sensor X Homing
December 15, 2014 07:37AM
Hey, thanks it was the P500 setting in config.g that seems to have fixed it.

Just to check then which web interface should I be using as I have just put on the one from the Master rep of OrmerodWebControl?
Re: DC42 Diff Sensor X Homing
December 15, 2014 10:36AM
Quote
veryevil
Just to check then which web interface should I be using as I have just put on the one from the Master rep of OrmerodWebControl?

Yes, that version (1.03) is good. I intend to do a minor update to it shortly, to stop it turning the heaters off when you do Pause and then Reset,



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: DC42 Diff Sensor X Homing
December 15, 2014 10:46AM
I had the same problem but I am using a MS for the X axis home. I then realized that I needed to turn off the sensor before homing the X axis. There was a discussion here where Ian mentioned the following...

Quote
droftarts
How about changing the firmware so you can define the axes that use the probe? Something along the lines of 'M558 P1 X0 Y0 Z1', so keep P0/1/2 for off and whatever probe type, then define axes on and off. Default off uses the microswitch. Just a crazy, late night idea!

If this sounds like a good idea, I'll add it to the firmware issues page as a feature request, which is the official way of asking for it: [github.com]

Did this not get implemented?

Regards,

Les


Pointy's Things
Pointy's Blog
Sorry, only registered users may post in this forum.

Click here to login