Welcome! Log In Create A New Profile

Advanced

Proximity sensor LED doesnt turn on...

Posted by gmh39 
Proximity sensor LED doesnt turn on...
March 15, 2016 09:55PM
I just finished up getting my Ormerod moving and leveled, and went to move the whole printer to position a spool of filament and now the proximity sensor (e-stop) LED doesn't light up and I can no longer connect to the Web Interface. Nothing has changed. I have checked and re-checked the wiring. I even wired everything just to make sure.

I am running dc42 1.09r firmware. I've tried multiple Duets, different proximity wires, multiple proximity sensors. No luck. I Reflashed each Duet with the firmware just to make sure. Here is my config.g file in case it helps:

Quote

; Ormerod 2 config file for dc42 Duet firmware
M111 S0 ; Debug off
M550 POrmerod 1 ; Machine name (can be anything you like)
;M551 POrmerod 1 ; Machine password (currently not used)
M540 P0xBE:0xEF:0xDE:0xAD:0xFE:0xED ; MAC Address
;*** Adjust the IP address and gateway in the following 2 lines to suit your network
M552 P192.168.0.110 ; IP address (0 = use DHCP)
M554 P192.168.0.1 ; Gateway
M553 P255.255.255.0 ; Netmask
M555 P2 ; Set output to look like Marlin
M575 P1 B57600 S1 ; Comms parameters for PanelDue

G21 ; Work in millimetres
G90 ; Send absolute coordinates...
M83 ; ...but relative extruder moves
M574 X0 Y1 Z0 S1 ; set endstop configuration (Y endstop only, at low end, active high)
M906 X800 Y1000 Z800 E800 ; Set motor currents (mA)
M563 P0 D0 H1 ; Define tool 0
G10 P0 S0 R0 ; Set tool 0 operating and standby temperatures
M92 E420 ; Set extruder steps per mm (single nozzle)
;*** If you have a dual-nozzle build, remove or comment out the previous line, and un-comment the following 3 lines
;M563 P1 D1 H2 ; Define tool 1
;G10 P1 S0 R0 ; Set tool 1 operating and standby temperatures
;M92 E420:420 ; Set extruder steps/mm (dual nozzle)
;*** If you have a modulated IR probe with on-board microcontroller, change P2 to P1 in the following
M558 P2 ; Use a simple modulated Z probe (change to P1 for an intelligent Z probe)
G31 Z2.5 P175 ; Set the probe height and threshold (put your own values here)
;*** If you have a Duet board with 1K thermistor series resistors, change R4700 to R1000 to the following M305 commands
M305 P0 R1000 H0 L0 ; Put your own H and/or L values here to set the bed thermistor ADC correction
M305 P1 R1000 H0 L0 ; Put your own H and/or L values here to set the first nozzle thermistor ADC correction
M305 P2 R1000 H0 L0 ; Put your own H and/or L values here to set the second nozzle thermistor ADC correction
;*** Adjust the XY coordinates in the following M557 commands to suit your build and the position of the IR sensor
M557 P0 X55 Y5 ; Four...
M557 P1 X55 Y187 ; ...probe points...
M557 P2 X217 Y187 ; ...for bed...
M557 P3 X217 Y5 ; ...levelling
;M557 P4 X110 Y105 ; 5th probe point for levelling (un-comment this if you are using a dc42 differential IR probe)
;*** if you are using axis compensation, put the figures in the following command
M556 S78 X0 Y0 Z0 ; Axis compensation here
M201 X800 Y800 Z15 E1000 ; Accelerations (mm/s^2)
M203 X15000 Y15000 Z100 E3600 ; Maximum speeds (mm/min)
M566 X600 Y600 Z30 E20 ; Minimum speeds mm/minute
M208 X220 Y210 Z200 ; set axis maxima (adjust to suit your machine)
M208 X-8 Y0 Z-1 S1 ; set axis minimum (adjust to make X=0 the edge of the bed)
;
T0 ; select first hot end

Edited 1 time(s). Last edit at 03/15/2016 09:57PM by gmh39.


greghoge.com

HUGE 3D PRINTER PARTS SALE!!!
Re: Proximity sensor LED doesnt turn on...
March 16, 2016 03:41AM
The E stop led isn't meant to light up when you have the standard IR proximity sensor connected correctly. Use the G31 command to check that you are getting correct readings from it.

If the web interface doesn't work on more than one Duet, that sounds like a problem with the cable or the IP address configuration. Do the LEDS in the Ethernet socket illuminate?



Large delta printer [miscsolutions.wordpress.com], Robotdigg SCARA printer, Crane Quad and Ormerod

Disclosure: I design Duet electronics and work on RepRapFirmware, [duet3d.com].
Re: Proximity sensor LED doesnt turn on...
March 16, 2016 09:04AM
Quote
dc42
The E stop led isn't meant to light up when you have the standard IR proximity sensor connected correctly. Use the G31 command to check that you are getting correct readings from it.

If the web interface doesn't work on more than one Duet, that sounds like a problem with the cable or the IP address configuration. Do the LEDS in the Ethernet socket illuminate?

Ok, it works now. I had to switch out the Duet. I dont know what was going on the first time around, but it works now. The readings I am getting are in the 2-400 range. I dont think that is correct...


greghoge.com

HUGE 3D PRINTER PARTS SALE!!!
Sorry, only registered users may post in this forum.

Click here to login