Welcome! Log In Create A New Profile


Has my Arduino board died?

Posted by Ecologgia 
Has my Arduino board died?
April 22, 2016 12:05PM
I'm still trying to get to grips with a Geeetech Prusa i3. I was using Pronterface and Slic3r reasonably well, although print quality was a bit rough. So I decided to try out Repetier instead. I then tried uploading Repetier firmware, which simply didn't work. I then re-uploaded the original Marlin firmware from the Geeetech website - so far so good.


Now I can connect to the printer and I can extrude filament, but the X, Y, and Z steppers aren't moving at all. There is a humming noise coming from the machine (I think it may be from the Arduino, but I'm not sure) whenever I send a command to move one of the axes.

Does anyone know what's going on?

Thanks confused smiley
Re: Has my Arduino board died?
April 22, 2016 09:19PM
That sounds like something is up with the stepper drivers, most likely not enough current. Have you tuned their current?
Re: Has my Arduino board died?
April 23, 2016 11:36AM
I don't know how to do that.

It was working fine before I reinstalled the firmware.

Any guidance would be helpful :-)
Re: Has my Arduino board died?
April 23, 2016 11:49AM
Try re-installing it again. Serial <-> USB protocol is not the most robust. It's possible for a corruption in data during the tansfer.
Re: Has my Arduino board died?
April 26, 2016 12:41PM
Although the extruder is working OK, I can't get a reading from any of the boards, including the extruder board. Does anyone have a clue what's going on - I'm completely ignorant about electronics.
Re: Has my Arduino board died?
April 26, 2016 12:42PM
I tried reinstalling the firmware but it made no difference.

Edited 1 time(s). Last edit at 04/26/2016 12:43PM by Ecologgia.
Re: Has my Arduino board died?
April 26, 2016 05:39PM
I suspect that this isn't an electronics problem but a software configuration problem. The fact that you can talk to the printer to the extent of extruding suggests that the processor itself is fine.

What do you mean by "can't get a reading from any of the boards"? I guess you must be at least getting a valid temperature from the extruder, and able to control the extruder heater, otherwise you wouldn't be able to extrude at all. Can you confirm that that's correct?

What boards do you have? I guess it's not a Mega2560 plus RAMPS, since you mention an "extruder board"? A photo would be helpful.

Can you please provide a link to the Marlin software you downloaded? Do you know what pins it expects to find the X,Y,Z stepper motors at?
Re: Has my Arduino board died?
April 27, 2016 06:57AM
Thanks for your comment. The board I'm using is a Geeetech Printer controller board - [www.geeetech.com], with 4 stepper driver modules: [www.geeetech.com].

According to Geeetech I'm supposed to check the voltage of the motor driver according to this link: [www.geeetech.com], however when I try this the multimeter doesn't return a reading.

I am able to control the temperature and extrude filament, but when I swapped the connection from the motor driver the motors weren't moving - i.e. I tried the z axis motor on the filament driver and nothing happened.

The driver came from this link: [www.geeetech.com]
Re: Has my Arduino board died?
April 27, 2016 06:10PM
Good call to swap the Z axis motor to the extruder connector. I was going to suggest that next smiling smiley

When you say "I tried the z axis motor on the filament driver and nothing happened", did *absolutely* nothing happen? No click or buzz? Remember that the software prevents cold extrusion, so you need to warm your extruder up to about 180 degrees before any extruder motion happens.

It would also be helpful to look at the output from Marlin... I don't know what software you're using on your computer to talk to the printer (Repetier Host? Pronterface? OctoPrint?), so I can't advise how to do that. But hopefully you can find it yourself. Look for something like "Log" or "Terminal" or something like that.

If absolutely nothing happens, and the nozzle is heated up, and there's nothing in the log, that means that the wiring to the Z axis motor is definitely wrong. Maybe there's a short between two of the wires. Or maybe they're connected to the wrong pins on the connector. Or maybe a couple of wires aren't connected. Disconnect your Z stepper from the board, and try a multimeter across the red and blue wires at the connector... you should find that there is low resistance. Similarly low resistance between the green/black (or green/yellow) wires. There should be no connection between red/green, red/black, blue/green, or blue/black.

If there's a buzz or hum, it can be either because the wires aren't connected in the right order, or because there's not enough current to the motor. But since the extruder motor works, we know that there's enough current, so make sure that the wires on the connector are in the right order... compare the Z motor wiring with how the extruder motor is wired.

Also check the X & Y motors by plugging them into the extruder connection... it may be that you have different problems in those from the Z.

Also try your extruder motor (after removing filament from it) in each of the X,Y, Z-axis connections on the board. Does an X,Y, or Z command make it move? Try movement in both directions in all axes for each of the connections, because the software may prevent movement in one direction if it thinks the axis is at the limit in that direction.

Going back to your first post, you say there's a "hum" when you issue X, Y, Z commands. That's unlikely to be coming from the Arduino board itself. Much more likely is that it's coming from one of the motors. Can you check that out too please?
Sorry, only registered users may post in this forum.

Click here to login