Welcome! Log In Create A New Profile


Cannot stop the extrusion cleanly [Solved]

Posted by Lionel 
Cannot stop the extrusion cleanly [Solved]
November 29, 2010 06:48AM
I have an issue with the extruder: when I control it from the reprap console ( by pushing the "Extrude" button in the extruder tab), the extruder stepper starts and turns correctly. But when I press again to stop it, it keeps turning and the software freezes momentarily. The stepper eventually stops after 5-6 seconds and the software responds again, but after that it keeps stepping randomly at an average pace of about 1 step/sec. If I reset the extruder board, this parasitic movement stops but it starts again every time I re-use the extruder.

Anyone has an idea about the cause or this problem?

For info, I am using the Gen3 electronics and I have reproduced this problem with both the 2010-03-08 and the 2010-08-06 versions of the software (upgrading the firmware to the boards too).

Edited 1 time(s). Last edit at 12/02/2010 11:55AM by Lionel.
Re: Cannot stop the extrusion cleanly
November 29, 2010 01:23PM
The "extrude" button sounds like it's working as well as it ever does; after you reset the extruder. are the stepper coils not energized? It could be that you're picking up noise on the step wire to the extruder controller, but you don't notice it until the coils are energized. Try routing the step and dir wires a different way, away from any motor or power wires; is this on a Mendel, or something else? I had similar problems running the 5D firmware on a Darwin, due to the long distance between the extruder board and motherboard.

Re: Cannot stop the extrusion cleanly
November 29, 2010 03:14PM
Thanks for the answer, Wade.
You're right, the coils are not energised when the extruder board is resetted. And you're right again, It is a Mendel.
I will try to shield the cables or at least to shorten them and see what happens.
Re: Cannot stop the extrusion cleanly
November 30, 2010 01:15PM
Ok, I've been working on that problem and here are the results:
- I added a shielded cable. The shield is connected to the extruder ground via the ground pin of port D10.
- I restarted the interface, and pushed the extrude button several times using several extrusion speeds.

- First of all, changing the value of the extrusion speed doesn't affect the speed of extrusion, it only affect the duration of the extrusion. So it shouldn't be called 'extrusion speed', unless I am missing something
- Second, I can still observe the random steps. A more careful observation showed me that this doesn't happen all the time though. Sometimes the stepper stops neatly and remains quiet, sometimes it doesnt and it keeps stepping randomly.

So I don;t think that it is due to noise, it must be something else. My guesses are that it may be a correction algorithm that goes mad if the stepper keeps moving after the signal is low, or there is a problem with the separate grounds of the motherboard and the extruder. Maybe I will use a commcon power supply and ground to make sure.

Any other suggestions?
Re: Cannot stop the extrusion cleanly
November 30, 2010 02:31PM
You definitely need a good ground between the extruder and the motherboard. This is because the step and direction signals have no differential noise immunity like the RS485 does.

Re: Cannot stop the extrusion cleanly
December 01, 2010 12:28PM
At the moment, the motherboard is powered by USB and the extruder board is powered by the power supply.
Do you think I can link both grounds together? I am not sure if that will be fine for the USB.

Edited 1 time(s). Last edit at 12/01/2010 12:36PM by Lionel.
Re: Cannot stop the extrusion cleanly
December 01, 2010 01:58PM
Well the grounds definitely need to be connected to make the reprap work, whether the USB likes it or not!

Re: Cannot stop the extrusion cleanly
December 01, 2010 06:35PM
Yeah, it sounds exactly like noise to me as well. You might have a ground loop between your pc and Mendel; check for ac or dc voltages between the pc, motherboard and extruder grounds. The extruder ground should be connected to the motherboard ground via the RJ45 connectors. The step and dir lines are very sensitive though; running them anywhere near a motor wire will cause spurious steps.

The reprap host extrude button is working as well as it usually does; it doesnt do what you'd expect with the 5d code. I use gcdump to send gcodes manually for testing.
Re: Cannot stop the extrusion cleanly
December 02, 2010 11:54AM
Ok, problem solved. It was a problem of noise indeed.

I joined the grounds together and held my breath while powering the whole thing: no smoke, and the stepper is now behaving correctly. Thanks for your help!

Just as a remark, I don't think it is a good idea to power the motherboard and the extruder from two different sources. I understand that it makes it easier for programming the sanguino when the machine is not finished but it also makes it confusing and more noise prone. Maybe there is room for design here.
Re: Cannot stop the extrusion cleanly [Solved]
December 24, 2010 12:34AM
the instructions tell you to cut a few traces and add a few parts to make the motherboard powered by the 12V (I think)
Re: Cannot stop the extrusion cleanly [Solved]
December 25, 2010 08:19AM
Yes, I did that already (http://reprap.org/wiki/PCB_adaptions_for_Mendel), but (unless I missed something) there were no instruction about linking the grounds of the main board and extruder board together.
Re: Cannot stop the extrusion cleanly [Solved]
January 14, 2011 09:50AM
I'm confused by this thread. I thought that the extrude button on the Reprap host only runs the extruder for a certain time and then stops it automatically. At least, this is how it behaves on my Mendel. RepSnapper behaves in the same way.
Re: Cannot stop the extrusion cleanly [Solved]
January 15, 2011 06:48AM
Yes, that is what it does here too. I was initially thinking that the extrude length parameter was affecting the speed of extrusion, but it does not.
Sorry, only registered users may post in this forum.

Click here to login