Welcome! Log In Create A New Profile


marlin firmware

Posted by 1978bamf 
marlin firmware
May 23, 2015 07:13PM
so I have downloaded the marlin firmware and also have arduino 1.6.4 however when I go to upload this onto my board it says compiling sketch on arduino and just stays there. am I doing something wrong?? I cant get any further than this part. I have tried deleting marlin and reinstalling it but it has the same effect. cant upload at all. any suggestions?
Re: marlin firmware
May 24, 2015 05:20AM
It takes a minute to compile the code ( at least on my Celeron Laptop )
Also, there are two buttons on the top-left corner of the IDE: "verify" and "upload".
You´ve set the right COM-port and board-type in Arduino-IDE?

Re: marlin firmware
May 24, 2015 09:44AM
I'm running an I5 based PC and it takes a while to compile the code before it starts the uploading process. I haven't actually timed it but mine seems to take between 3 to 5 minutes to compile and upload.
Re: marlin firmware
May 25, 2015 09:17AM
I had the same problem then I realized the power supply I just purchased was dead. So it hung up compiling. Checked the compiling on another printer and viola! It worked fine. Ordered a new power supply.
Re: marlin firmware
May 25, 2015 03:10PM
In the Arduino app, under File->Preferences, make sure both "compilation" and "upload" are checked after "Show verbose output during". That will show you if there's an error.

I wouldn't think the power supply would have anything to do with it. USB power is enough to connect to the board.
Re: marlin firmware
May 26, 2015 11:57AM
Make sure you have the 2560 Mega set and the Com Port set in the arduino IDE. The Mega should power from the USB port on the Mega. You do not have the RAMPS connected to load the firmware on the Mega.
Sorry, only registered users may post in this forum.

Click here to login