Welcome! Log In Create A New Profile


Testing problems

Posted by asadpasat 
Testing problems
December 30, 2015 12:44AM
So I recently got the " He 3D - XI3 High Precision NEW prusa I3" kit. I assembled it and wanted to start printing. So I installed Printer Interface on my laptop (pretty much program where I can just press to move any of the axis). The axis that I'm having problem is the z-axis. When I press to move it for example by 10, there is loud sound like the motors are trying but nothing is happening. The motors are not even spinning. Sometimes when I keep pressing it one of the motors spins little bit and then stops. Anyone experienced this problem? If you don't understand my problem please ask.
EDIT: I tried to run one f the z axis motors and it works. It fails when I plug in both of them and try to run them at the same time.
EDIT2: So I rewired and connected the two motors. I just connected them and threw them on one pin instead of two. Now the problem is that they don't spin equally. What I mean is when I run the Printer Interface and put let's say 10mm run increment, the motors don't run equally (one spins more then the other), which is super confusing as they are supposed to spin equally (right?) if i connected them together.

Edited 3 time(s). Last edit at 12/30/2015 03:36AM by asadpasat.
Re: Testing problems
December 30, 2015 01:43AM
There are 2 things that could cause your problem I think.

1. Please check if both steppers are driving in the same direction, if not, flip over the stepper plugs of the stepper that has the wrong direction

2.the setting of the z stepper current is too low. Increase a little bit by turning the potentiometer clockwise untill the steppers are running.
Be aware that if the current is too high you can damage the driver. You can check it measuring the reference voltage too.

Kindly regards
Re: Testing problems
December 30, 2015 02:35AM
There is a good chance, your firmware settings for z-max speed are too high.
I had to reduce mine from 5 to 3 by sending "M203 Z3" through your printer interface. If moving Z works, then send "M500" afterwards to store the new value in EEprom.
Re: Testing problems
January 02, 2016 11:56PM
They need to be wired in series if you have only one terminal for the two steppers then red and green from #1 Stepper goes to terminal on the board...... #1 blue connect to #2 red then #1 black to #2 green and finally #2 black and blue go to the board terminals You now have only 2 wires from each stepper going to a terminal block on the board the others are spliced together

Re: Testing problems
January 03, 2016 11:49AM
with HE3D products you CAN NOT trust the colors of the wires. I rewired my Z motors about 10 times before i finally got them right. These stepper motors have two coils inside of them, each coil has its own two wires. You want to use a ohm meter and determine which two wires on each motor are connected to eachother (the ones between which there is practically zero resistance) those need to be next to each other in the connector. The pairs were different on my two Z motors, so you have to test every single motor. People told me that i needed to run the motors in series, but I got it working much easier by doing it in parallel on the two plugs side by side on the ramps.

Another thing to check for is your microstepping jumpers, you should have little black clips that go under the stepper drivers on the ramps. Weird things happen when your firmware thinks you have more or less installed then what you have in reality. My HE3D instructions didn't even tell me to put them in.
Sorry, only registered users may post in this forum.

Click here to login